Previous 1 2 3 4 5 6 Next 86 Replies Latest reply: Dec 9, 2014 10:23 AM by Dallas Kruse Go to original post
  • Jaap74 Level 2 Level 2 (170 points)

    Happy to say that I now am 24 hours without the connection error popup!

     

    An easy way to detect the broken images is to startup iPhoto holding the 'option' and 'command' button. I took a screenshot from the web, but I selected the 2nd, 3rd and 4th checkbox.

    438309-500-267.png

    Then be patient.....iPhoto will now detect the photo's that have broken links. At some point a popup comes up that iPhoto cannot detect a picture. iPhoto asks you if you want to search for the Photo. I just noted the picture file name and pressed cancel. After a few hours the whole library was searched and I had 20 pictures that couldn't be detected. Then I used spotlight to try to find these picture files. I seemd they were on an external HD. Based on the thumbnail I now I now knew which pictures were causing the error. I went back to my iPhoto library, found these pictures and deleted them. Emptied the trash (do not forget!). Then I imported the picures from the external HD.

  • MKadrie Level 1 Level 1 (0 points)

    Well that took forever. I had to pull every picture that was on my remote computer over to my laptop which is now taking up way too much space. I need to archive and free up some real estate now

    We'll see if this cures it. Will let you know.

  • Jaap74 Level 2 Level 2 (170 points)

    Well....I am still without the connection error! For 5 days now and did a lot of iPhoto stuff.

  • MKadrie Level 1 Level 1 (0 points)

    Good and bad here. I think this is the problem I have been experiencing. However, it turns out I have way more problems and will probably have to do a reinstall of the OS.

  • Jaap74 Level 2 Level 2 (170 points)

    A reinstall won't solve it as long as you keep using your current iPhoto library. I did a clean install of OSX Lion, but after I imported my iPhoto library from a backup, the error message came back.

     

    Your OS is OK, your iPhoto library is corrupt....

  • macilvena Level 1 Level 1 (0 points)

    To resolve this issue clear out your recent servers list in the go to server dialog box and clear out all your login items....add back what you need as some of these may contain references to old network connections...worked for me

  • Jaap74 Level 2 Level 2 (170 points)

    I believe there are two different issues that create the same network connection error popup. For some users cleaning the server list works. For others it is a corrupt iPhoto library that needs to be cleaned.

     

    I am now 1 month without any error!

  • Matt Frear Level 1 Level 1 (0 points)

    David Keppler's answer worked for me - thanks.

  • Peikup Andropov Level 1 Level 1 (0 points)

    Hey Matt, My name is Kris Frear I am a iOS advisor for Apple.  Was just wondering (because this came up is  a Google notification for my name) if we might be related somehow. If you wanna get in touch with me let me know.

  • ZX48 Level 1 Level 1 (0 points)

    This solved my PrInt Dialogie beachballing problem. The error seems to have been trigegred by me remotely opening an Application on a machine that is no longer connected. Trashing the PDF alias to this application inside:

     

    <username>/Library/PDF Services/

     

    solved the problem perfectly!

     

    Thanks!

     

    d1n0 wrote:

     

    Hi everyone,

    Just wanted to chime in - I've also had this problem and it started sometime after 10.6.
    One thing I had been trying to get to work was cocoa booklet which no longer works in 10.6 - so installed it on another system which is running on 10.5.
    Somehow it appears that pdf services got mixed up in this (not sure how) and kept popping that error message whenever any setting was changed on the printer.
    I have no clue how this happened and after much hair pulling and grinding of teeth found how to clear it.
    I emptied out the following directory
    <username>/Library/PDF Services/
    This folder had a cocoa booklet app that seems to be pointing to the new machine - no clue how this happened.
    I deleted this and the problem disappeared.
    I hope this helps anyone with the same problem as I'm running out of teeth to grind and hair to pull!!.
  • TwitchOSX Level 1 Level 1 (10 points)

    How do you clear your server list?

     

    Here's my problem. I have a windows box on our network called "pc2". It shows up in my Shared area in the Finder in 10.7, but every once in a while, I will click on it to access it's shared folders and get "Connection Failed" at the top of the finder window. If I click on "Connect As..." I get the standard "There was a problem connecting to the server "pc2". The server may not exist or it is unavailable at this time. Check the server name or IP adress, check your network connection, and then try again."

     

    Thoughts? I didn't do anything to that machine and this tends to happen every once in a while which is a pain in the butt to say the least. If I reboot either this Mac or that PC I think it will fix the issue but I don't want to be rebooting computers all day long.

  • Tony Fair Level 1 Level 1 (0 points)

    This worked thanks!

  • micksmac99 Level 1 Level 1 (0 points)

    [I grepped my ~/Library/Preferences folder for references to the ghost server\share that was trying to be connected to at login and got the following results:

     

    Preferences/com.apple.loginitems.plist

    Preferences/com.apple.recentitems.plist

    Preferences/loginwindow.plist

     

    I trashed all the above (you may want to just rename them to be on the safe side) and the problem has gone.]

     

    I've tolerated this annoyance for about three to four years now on my 2009 MacBook Pro unibody.  Looked for an answer several times but no luck.  The above worked for me.  I'm very grateful.  Thank you.

  • Madrian Level 1 Level 1 (0 points)

    I had the same problem!

    After I did everything mentioned in this post, I deleted com.apple.loginwindow.plist from system/library/logindaemons!

    ATTENTION: my iMac didn't boot anymore! It took me a lot if time and effort to install lion on an usb flash drive and boot it from flash drive then copy the file back to the location. Only booting from flashdrive takes more then half hour and everything is in slow motion. DO NOT REPEAT THAT MISTAKE!

     

    After solving the above problem I had to repair permissions and since almost one week I do not have this popup window any more!

    applications/utillities/disk uttilities / sellect the hard drive and hit repair disk permissions.

    For me it seems that this has worked (I hope it will not come back)

  • merfi Level 1 Level 1 (0 points)

    I've tried everything in this post and nothing worked for me... It is really annoying specially right in the middle of the work sigh...

     

     

     

     

    Note: Macbookpro Retina: OSX 10.8.3