12 Replies Latest reply: Sep 23, 2009 1:58 PM by BDAqua
John Howarth Level 1 Level 1 (45 points)
I have done a clean install of OS10.4 onto a G4 laptop, so it can be used by a new person. Airport is connected, according to the icon and the checkmark next to the network name. The network is working correctly on another Mac laptop. However, Safari always is reporting "You are not connected to the internet". System Prefs/Network says "Airport is connected to the network NAME. AirPort has a self assigned IP address and may not be able to connect to the internet".

The other laptop, using OS 10.5, says "Airport is connected to NAME and has the IP address xxx.xxx.x.x."

What should I be doing to connect the first machine?

MacPro 2.8Ghz 8-core, MacBook Pro 15", Mac OS X (10.5.7)
  • BDAqua Level 10 Level 10 (119,870 points)
    If the IP on the G4 Laptop is indeed starting with 169.254 then the Router is not talking to it, at least not handing out a DHCP IP.

    See a similar problem here...

    http://discussions.apple.com/thread.jspa?threadID=2156065&tstart=15
  • John Howarth Level 1 Level 1 (45 points)
    Thanks for the reply, BDAqua.

    The G4 was connecting wirelessly, and working correctly, this morning. I wanted to give it a new start in life for a new family user, so I re-installed the original OS10.4 from the original discs. I connected to the wireless network when it appeared in the list, entered the password, and the icon turned from grey to black, with a tick next to the network name in the list. But I cannot get onto the internet. Safari says "you are not connected to the internet." My desktop machine is hardwired, and has no problem. My MacBook is using the wireless network with no problem.

    The IPv4 address in Network Prefs on the MacBook is 192.168.0.4

    The IP address under TCP/IP on the G4 is indeed listed as 169.254.67.100 - you say these numbers mean the Router is not talking to it, but what can I do to remedy that?

    The Netgear helpline (router is NetgearDG834G) talked me through re-setting things, and concluded it was a computer problem on the G4, which it does appear to me to be. After all, it was working correctly before I re-installed the OS.

    I looked at the thread you directed me to, but could not infer from it what I should do in my case.
  • John Howarth Level 1 Level 1 (45 points)
    Also, if I connect an Ethernet cable, I still get the same error message from Safari, and cannot access the internet.
  • BDAqua Level 10 Level 10 (119,870 points)
    Then... Try putting these numbers in Network>TCP/IP>DNS Servers, for the Interface you connect with...

    208.67.222.222
    208.67.220.220

    Then Apply

    Also, the Interface that connects to the Internet, needs to be drug to the top of Network>Show:>Network Port Configurations and checked ON.
  • John Howarth Level 1 Level 1 (45 points)
    Thanks for that. I tried it, but unfortunately it has no effect.
  • BDAqua Level 10 Level 10 (119,870 points)
    The IPv4 address in Network Prefs on the MacBook is 192.168.0.4

    The IP address under TCP/IP on the G4 is indeed listed as 169.254.67.100 - you say these numbers mean the Router is not talking to it, but what can I do to remedy that?


    Does the Ethernet get a 169.254 IP also?

    We could try Manually for either Interface in the TCP/IP tab...

    IP: 192.168.0.9

    Subnet Mask: 255.255.255.0

    Router: 192.168.0.1
  • John Howarth Level 1 Level 1 (45 points)
    Success! Taking inspiration from your previous posts in the thread you directed me to, I tried manually entering the IP address, with a greater number as the last number. It worked. Now I see you've posted to say the same thing.

    Many thanks. These forums are truly a wonderful resource.

    So why, when I revert to automatic IP configuring, does it change back to 169.254.67.100?
  • BDAqua Level 10 Level 10 (119,870 points)
    So why, when I revert to automatic IP configuring, does it change back to 169.254.67.100?


    Great to hear, but it must be some munged OS component on that Mac that is/isn't requesting DHCP from the router, but now you know how to get around it!
  • John Howarth Level 1 Level 1 (45 points)
    The next day...

    Unfortunately that's not the end of the problem. I can now connect, manually, to my own router. But when I try elsewhere, connecting in a friend's house or in a public place - "There was an error joining this network". The machine detects that there is a network, but will not accept the password. I haven't yet had the opportunity to test its reaction in a password-free environment.

    This was how the problem first manifested itself, after doing a clean install of 10.4, ie it would not accept the network password. At some subsequent point, after changing the router password and having my hand held by Netgear's helpline, I was able to get the machine to accept a password, but it would not communicate with the router (the machine showed I was connected by Airport, but I didn't receive anything back). Everything has now been software updated to 10.4.11, and I even went through the everlasting "Your network settings have been changed by another application" scenario. Trashing the SystemConfig Prefs solved that one.

    But I am still left with a machine that will not connect to the internet, other than to my own router, when I must configure using the TCP/IP setting of "using DHCP with manual address". I can't even get it to accept the password of another router.

    This is starting from scratch, with a clean OS. Yesterday morning, using 10.4.11, before I re-installed the OS, it was working fine, and had been for a couple of years. Btw, I did try re-installing the OS a second time, with identical results.
  • BDAqua Level 10 Level 10 (119,870 points)
    Man-o-man!?

    When trying to connect to one of these, Have Console in Utilities open so we might get a clue as it happens.

    Also, forget if we tried logging out & back in before connecting?
  • John Howarth Level 1 Level 1 (45 points)
    BDAqua,
    Sorry for the delay again. I'm going to have to put this one to rest. The computer has now passed to my daughter and she's taking it to an Apple Store to hopefully get it sorted. Many many thanks for your help.
  • BDAqua Level 10 Level 10 (119,870 points)
    Thanks for the report John.