Previous 1 2 3 Next 31 Replies Latest reply: Apr 6, 2010 8:40 PM by sparhawk6 Go to original post
  • melbest77 Level 1 (0 points)
    Thanks for the info. My 5th gen was working just fine until I had to start over with my PC Windows XP. I had the newest version and was able to sync just fine. The second I had to reload Itunes for the "first" time, my computer was able to detect but not identify.

    Going to try a few of the suggestions including the device manager. Thanks!
  • amylemonade Level 1 (0 points)
    When I go to Device Manager, I don't see anything that looks very obviously like the driver that you're talking about. Can someone explain how exactly to uninstall the driver?
  • Jezzace Level 1 (0 points)
    I had this problem as well. I tried everything and was on the phone with apple for 2 hours only for them so say they couldn't help but they'll look into. Cheers...

    Then today I was fiddling about with the options in itunes and i found a fix for mine! Under preferences,devices I clicked reset sync history and then plugged my ipod nano 5g in and voila, there it was working in all its glory. I can't be certain this is what fixed as i've been messing with itunes and my pc for a while trying to get it working but its worth a go.
  • nano5rachel Level 1 (0 points)
    I am having the same problem.

    i bought the Nano 5 gen for my son as i have an ipod touch. But it comes up with the same message.

    it is detected on my laptop but not on main home computer.

    I have tried all the suggestions above with no joy.

    Any other ideas?????
  • jessthebod Level 1 (0 points)
    What do you mean by quit out of itunes?
  • djb1990 Level 1 (0 points)
    Im having the same problem :S i dont know what to do! ive tried everything, its my first ipod, ive had itunes for a while. i just get the same message as you when i connect my ipod. ive tried just moving my music folders onto the ipod myself but of as sly as apple are you have to use itunes :/ so im stuck with an ipod with no music!! Any help would be much appreciated!
  • light bringer Level 1 (0 points)
    Problem statement:
    Running Win XP Pro SP2 with a new gen5 iPod, freshly installed version of iTunes. Received “An iPod has been detected but it could not be identified properly…” and was unable to set up the iPod.

    I solved the problem by doing three things at once, so any one of them may be what was effective.

    1) I have a data partition on the E: drive. I used my partition manager to hide the partition. After a reboot, the iPod appeared as E:, and I was able to do the initial setup. I then disconnected the iPod and “unhid” the E: partition. After that, the iPod came up with an appropriate non-E: drive letter and seems to function fine.

    I also 2) reinstalled iTunes and 3) turned off my firewall and antivirus software for good measure.
  • JonathanBoulton Level 1 (0 points)
    Hi

    I tried a number of these suggestions, but in the end followed some instructions from Apple when I did a 'Run Diagnostic' from my iTunes help menu.

    I had to reset my Apple Service, which is via Start - MyComputer - Manage. Then Service and Applications, select Service and find and select the iPod Service, which you click on Restart.

    Now when I reconnected the 5th Gen Nano, iTunes recognised it.
  • prettyininkk Level 1 (0 points)
    None of any of this has helped me. I've reinstalled iTunes, I've redone my Ipod nano 5th gen, I've made sure to redo all of the Quicktime, etc. I've tried resetting my Sync info. None of this worked for me. I synced my Ipod yesterday with no problem and then tonight I updated to iTunes 9 and now have this problem.

    Something tells me it has to do with the new iTunes as I didn't have this problem until I updated.
  • prettyininkk Level 1 (0 points)
    TY Jonathan!! That worked for me!! I'm happy now!
  • IpodAdrian Level 1 (0 points)
    OKEY. Nonsense to what they all said.
    I am not a professional, but I had the same problem, and I was able to solve it.
    I used a program called CopyTrans Manager. Which is an alternative for iTunes.

    1. Download CopyTransManager @ http://www.copytrans.net/

    2. Run CopyTrans Manager, you will see a list of available softwares,
    select CopyTrans Doctor and wait for it to automatically install and run.

    3. Once it is done, select finish, next close all CopyTrans Manager applications.

    4. Open Itunes, and your ipod should be recognized now.

    ps. You do NOT have to buy, or activate the program for this job to be done. But you can still do so for the extra stuff it offers.
    GOOD LUCK!!!!!

    Message was edited by: IpodAdrian
  • technot18 Level 1 (0 points)
    This issue is still ongoing see my other topic "downloaded the latest update". i-tunes 9.1 reconises my daughters 4th gen but not my 5th. Issue is with the driver (windows is trying to uninstall it(code 21)). I had not sync'd my ipod for a couple of months both my daughters have had problems like this before with 4th gen's. Come on Mr apple give us a fix.
  • fikigo Level 1 (0 points)
    I have this same problem too. I don't have any problems with Ipod Shuffle or Touch, only with my 5th gen Nano. I've tried all the steps recommended by Apple but no luck. At a loss what to do next...
  • iPod Whisperer Level 3 (775 points)
    This sounds like it might be the mobile device manager. My feeling is that you might get good results from just uninstalling and reinstalling all the apple software from your system and reinstall them. Here is a link that will help you do that:

    http://support.apple.com/kb/HT1925

    i
  • sparhawk6 Level 1 (0 points)
    I'm having the exact same issue with 9.1 and my 5th gen nano. I tried downgrading the 9.0, but no dice. I also believe its a faulty driver. How can I load the previous version of the USB driver?