6 Replies Latest reply: Sep 25, 2009 12:03 AM by Yotsuba
narutoshi Level 1 Level 1 (0 points)
Since the latest version of iTunes (version 9?) was installed, when iTunes Store brings up on screen some (not all) Chinese characters look like not the ordinary Japanese Chinese fonts but (probably) traditional Chinese characters. Some, like pictures showing on-sale tunes released by Japanese artists, are displayed with no problem.

Apart from the problem with iTunes Store described above, Safari version 4 (for Windows) had another fonts problem. It doesn't show characters in menu properly. I didn't tell what characters set it was.

I just wonder how other Japanese users of iTune or Safari deal with this issue and if Apple had managed to test before releasing the version.

Toshiba Satellite T11
  • Yotsuba Level 1 Level 1 (10 points)
    I actually came here to make the same topic. Since updating to iTunes 9, the Japanese store is not using the correct character encoding which makes the store, basically, unusable.

    The update to the new store also caused my to lose an authorization, forcing me to reauthorize a PC that was already authorized (so now instead of having 3 PCs authorized, I have 4 authorizations used for 3 PCs). I don't know if that's related or not, but both happened at the same time.
  • Pamela Gadsden Level 3 Level 3 (950 points)
    Time to tell this directly to Apple.
    Go here : http://www.apple.com/support/itunes/

    Select Music purchases and tell them about the font problem that's making music purchases impossible, you'll get the email option which is probably the best choice for this.
  • narutoshi Level 1 Level 1 (0 points)
    Thanks for making your note here as it shows the problem I see is not just my problem but Apple's problem.
  • narutoshi Level 1 Level 1 (0 points)
    Thanks for the advice. But I have spent a lot of time to look for where to post my claim to Apple. Eventually I found this place and the site with the URL does not seem to show exactly what a customer can do - apologies if I'm wrong.

    I'm okay with the problem unsolved as I will go another shop to get a tune. Thanks to the Net it is not just a Apple's store where I can get what I want to.

    Anyway, thanks again for your attention to my note and a reply.
  • Yotsuba Level 1 Level 1 (10 points)
    Well I tried that. So much for 24 hour responses. It's been 3 days and not a single word from them. (And no, it wasn't eaten by the spam filter). This is just pathetic. Break iTunes for a whole country and then do NOTHING to even fix it?
  • Yotsuba Level 1 Level 1 (10 points)
    Ok, I finally got a response from support but their suggestion didn't help me. For the record their response was to uninstall the KB927489 update for the MS gothic and MS mincho fonts. I didn't have that update installed.

    However, it did lead to a solution which I'll post here for those who are able to use it (this should work for Japanese versions of Windows but will require a dual boot setup).

    1 - Boot into the OS other than the affected one (ie, the Windows 7 RC if you have it installed as a dual system; you may be able to do this from a dos prompt, if you can boot into one but I can't confirm that)

    2 - Find the MS gothic and MS mincho fonts in the affected OS's windows/font folder (copy them to a new location that can be accessed from the affected OS (you can't generally do this while using the affected OS as the system locks these fonts down)

    3 - Once those fonts are deleted from the Windows/font folder for the
    affected OS, boot back into that OS and run iTunes. Right now, it
    should show English normally, but Japanese will be squares -- indicating the correct font is not installed. The system
    font on the Start menu will also be incorrect.

    4 - Copy the fonts backed up in step 2, back to the Windows/font
    folder and reboot the PC.

    5 - Once it's booted, the system font should be back to normal and
    loading iTunes should show Japanese displayed correctly.

    At least, it's worked for me. If you can't access dos/boot into another OS, then you'll probably have to wait for Apple to fix this issue.