7 Replies Latest reply: Sep 21, 2009 3:56 PM by marky68
marky68 Level 1 Level 1 (0 points)
I have just stopped using a wireless router via Airport. I now use the Homeplug AV adapter system via Ethernet. I have internet no problem, but now have no network that will enable me to connect my IPhone via WIF to the internet through my IMac. Can someone please help?

Imac20, Mac OS X (10.6), IPhone 3G.
  • Dah•veed Level 7 Level 7 (32,665 points)
    While your iMac is connected to the internet with an ethernet connection, you should be able to turn on the Airport card in the iMac and set up a local wifi network that your iPhone can use to share your iMac's internet connection.

    You would need to create an AirPort network in System Prefs>Network. If AirPort does not exist in the left hand pane click the + below and create one. Check the box to Show AirPort status in menu bar. Then from the menu bar choose Create network... and create a secure network with the name and password of your choosing.

    After you have created the AirPort network go to System Prefs>Sharing and highlight Internet Sharing. (Do not check the box.) Then to the right choose to Share your connection from Ethernet from the pulldown menu. Below share To computers using AirPort. Now go back and check the box for Internet Sharing.

    With the AirPort network you have created, you should now be able to connect your iPhone to it as with any other WiFi network.

    Dah•veed
  • Duane Level 10 Level 10 (117,955 points)
    You would need to create an AirPort network in System Prefs>Network. If AirPort does not exist in the left hand pane click the + below and create one. Check the box to Show AirPort status in menu bar. Then from the menu bar choose Create network... and create a secure network with the name and password of your choosing.


    Sorry but that is not the correct procedure. That would create an adhoc network which is not what is needed. Here is what you need to do:

    (a) Open System Preferenes-> Sharing preference pane.

    (b) Click on Internet Sharing (don't enable it, just click on the words).

    (c) To the right click in the check box for AirPort.

    (d) Click the "AirPort Options..." button to name the network and setup wireless encryption.

    (e) Click the OK button.

    (f) Now (back in the Sharing preference pane) on the left hand side, click in the box to enable Internet Sharing.

    If that Mac has the firewall enabled, you will also need to enable Web sharing (in the Sharing preference pane) and may need to disable the firewall completely.
  • Dah•veed Level 7 Level 7 (32,665 points)
    If no AirPort service has been created in Sys Pref>Network, there will be no AirPort option to choose in the Sys>Prefs Sharing pane.

    That would create an adhoc network which is not what is needed.

    Please explain?

    Dah•veed
  • Duane Level 10 Level 10 (117,955 points)
    Sorry I copied too much. This is the part that is incorrect:

    Then from the menu bar choose Create network... and create a secure network with the name and password of your choosing.
  • Dah•veed Level 7 Level 7 (32,665 points)
    Duane, not being a dumb taquito, I try not to post something of which I know nothing about. However, that still manages to occur occasionally! When the OP asked for help, I knew nothing about his issue. I had never shared an internet connection wirelessly. But in my mind I thought that this indeed should be possible with a Mac with an AirPort card. I experimented.

    Not having an iPhone or an iPod Touch I used my iMac and my Mac mini. They are in rooms on opposite ends of my apartment. I set up a wireless airport network from my Mac mini to share its ethernet internet connection wirelessly with the iMac. I did it exactly as I shared with the OP. It took all of 3 minutes, start to finish. Then I walked to the other end of the apartment and connected the iMac to this wireless network and was surfing the internet from the Mac mini's ethernet connection in all of 30 seconds. It was a secure wireless connection.

    I have now followed your instructions. They also worked flawlessly and because they were now familiar steps took barely two minutes to set up, walk, connect and surf. The results are identical!

    However, if the OP only had your instructions to follow and did not encounter an AirPort service in Sys Prefs>Sharing, they would have been up the proverbial +cala de la mierda+, without a paddle.

    Dah•veed
  • Duane Level 10 Level 10 (117,955 points)
    However, if the OP only had your instructions to follow and did not encounter an AirPort service in Sys Prefs>Sharing, they would have been up the proverbial cala de la mierda, without a paddle.


    Perhaps but the only way that AirPort wouldn't appear as a service is if they had intentionally disabled it. By default it is a listed service whether the user actively uses AirPort or not.
  • marky68 Level 1 Level 1 (0 points)
    I will give it a go this week. Thanks.