8 Replies Latest reply: Dec 3, 2009 12:25 PM by Chris Byrd
Neflyte Level 1 Level 1 (0 points)
Unfortunately, Snow Leopard has broken VPN DNS (thanks go out to Apple's QA department).

I've tried several methods of "fixing it", but I end up seeing the following issue (output from scutil --dns):

DNS configuration

resolver #1
domain : xxxx.cc
nameserver[0] : 192.168.0.1
order : 200000

resolver #2
nameserver[0] : 10.0.2.1
nameserver[1] : 10.0.2.2
order : 100000
(...)

Notice how there is no domain on resolver #2. No matter what I do, I can't get one to populate. So, requests to my VPN domain never get to the correct DNS servers and my connections fail. I've tried manually specifying DNS servers and domains for the VPN connection, but the domain still doesn't populate. I've also tried removing all files under /Library/Preferences/SystemConfiguration/ and rebooting, however that only resolved an earlier issue with simply connecting to the VPN endpoint.

Does anyone have any suggestions on how to populate a domain name in my second resolver?

MacBook Pro - Core2 Duo 2.2GHz, Mac OS X (10.6)