4 Replies Latest reply: Sep 22, 2009 12:37 PM by Eric Barbosa
Eric Barbosa Level 1 Level 1 (85 points)
I bought my MacBook Pro in August, and ever since I got it, with both Leopard and Snow Leopard, I have had a problem where an app would freeze, typically Safari or iTunes, but could be any app, I would try to go to the dock to force quit it, and the Dock would freeze, went to right side of menu bar and that would freeze. About 10-15 seconds later it would resume normally.

Interestingly, if it freezes as I am playing a flash video on the web, the audio would continue but the video would stop, and when it continued it would fast forward to the current point. Also, once I was printing to a USB HP AIO, and when my computer froze the printer would freeze, when my computer continued the printer continued.

The last time it froze, I went to Console afterwards and found a bunch of these errors:

9/21/09 12:13:15 PM Mail[180] * Assertion failure in -[IMAPToDoStoreReconciliationAgent prepareToReconcileForMailboxID:], /SourceCache/Message/Message-1076.1/MessageStores.subproj/IMAP.subproj/IMAPToDo StoreReconciliationAgent.m:56
Cannot reconcile with nil store
(
0 Message 0x0000000101030828 -[MFAssertionHandler _handleFailureWithPreamble:description:arguments:] + 137
1 Message 0x000000010103078d -[MFAssertionHandler handleFailureInMethod:object:file:lineNumber:description:] + 220
2 Message 0x0000000100ef4963 -[IMAPToDoStoreReconciliationAgent prepareToReconcileForMailboxID:] + 138
3 Message 0x0000000100ef437e -[ToDoReconciler(Internal) _triggerAgentsForPhase] + 631
4 Message 0x0000000100ef3969 -[ToDoReconciler requestReconciliation:] + 911
5 Message 0x0000000100ef35bf -[IMAPToDoStoreReconciliationAgent requestReconciliation] + 102
6 Message 0x0000000100ed659b -[IMAPMailboxSyncEngine _goWithMessages:] + 1278
7 Message 0x0000000100ea96d2 -[LibraryIMAPStore openSynchronouslyUpdatingMetadata:withOptions:] + 343
8 CoreFoundation 0x0000000101f3235c _invoking__ + 140
9 CoreFoundation 0x0000000101f3222d -[NSInvocation invoke] + 141
10 Message 0x0000000100e8ca35 -[MonitoredInvocation invoke] + 214
11 Message 0x0000000100e73f50 -[ThrowingInvocationOperation main] + 31
12 Message 0x0000000100e73890 -[_MFInvocationOperation main] + 275
13 Foundation 0x000000010217611a -[__NSOperationInternal start] + 673
14 Foundation 0x0000000102175dd8 ___startOperations_block_invoke2 + 99
15 libSystem.B.dylib 0x0000000101bcccf6 dispatch_call_block_andrelease + 15
16 libSystem.B.dylib 0x0000000101bab1e9 dispatch_workerthread2 + 231
17 libSystem.B.dylib 0x0000000101baab28 pthreadwqthread + 353
18 libSystem.B.dylib 0x0000000101baa9c5 start_wqthread + 13
)

When I got this Mac, I did a Migration from Time Capsule, but for some reason it could not finish and I had to move over a lot of apps with drag and drop.

MBP 15" 2.8GHz 4GB, Mac OS X (10.6.1), iPhone 3GS 32GB, iPods: touch 2G 16GB, shuffle 3G 4GB
  • 1. Re: MacBook Pro occasionally freezing since bought
    Dale Weisshaar Level 6 Level 6 (15,855 points)
    Have you done any maintenance?
    Try using Disk Utility to do a Disk Repair, as shown in this link, while booted up on your install disk.
    You could have some directory corruption. Let us know what errors Disk Utility reports and if DU was able to repair them.
    After that Repair Permissions.

     DALE

  • 2. Re: MacBook Pro occasionally freezing since bought
    Eric Barbosa Level 1 Level 1 (85 points)
    Dale,

    Thank you for your reply.

    Did not receive any errors doing a disk repair.

    Here is the Repair Permissions log:
    Warning: SUID file "System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAg ent" has been modified and will not be repaired.
    Permissions differ on "Library/Application Support/Apple/ParentalControls", should be drwxrwxr-x , they are drwxr-xr-x .
    Repaired "Library/Application Support/Apple/ParentalControls".
    Permissions differ on "Library/Application Support/Apple/ParentalControls/ALRHelperJobs", should be drwxrwxr-x , they are drwxr-xr-x .
    Repaired "Library/Application Support/Apple/ParentalControls/ALRHelperJobs".
    Warning: SUID file "System/Library/PrivateFrameworks/DesktopServicesPriv.framework/Versions/A/Reso urces/Locum" has been modified and will not be repaired.

    Strangely, I ran Repair Disk Permissions right after I did the Repair Disk on the Install Disc, and then I re-ran it trying to get the "Warning: SUID file..." so I could put it in this message, but was surprised to see that it repaired the Parental Controls files twice.

    Eric
  • 3. Re: MacBook Pro occasionally freezing since bought
    Dale Weisshaar Level 6 Level 6 (15,855 points)

    Those permissions errors are normal. No need for worry there.

    Did you have any luck with your issues though?

     

    DALE

     

     

  • 4. Re: MacBook Pro occasionally freezing since bought
    Eric Barbosa Level 1 Level 1 (85 points)
    The problem hasn't occurred since I wrote this. It used to happen a lot more than it does now. I tried a safe boot and deleted the cache a couple weeks ago, which seemed to help in the short run. Lately it only happens once every couple of days, but the days it happens, it usually happens more than a couple of times.

    And just to note, I have Mail open in the background 95% of the time. So that means it doesn't just need Mail to be open.

    Also, it seems to happen more often at home than elsewhere. At home I typically have it connected to my 24" LED display, and to ethernet, and is the only time when it does a Time Machine backup to my Time Capsule. Wonder if that has something to do with it?