Previous 1 2 3 Next 40 Replies Latest reply: Feb 24, 2010 11:41 AM by philippm Go to original post
  • Pondini Level 8 Level 8 (38,715 points)
    Kid A wrote:
    I'm also having this problem. I used disk utility to repair the external USB drive connected to my Airport Extreme and reformatted it which fixed the issue, but the problem came back just a few days later. Very annoying, and I do think putting the computer to sleep may be the culprit, but can't be sure.

    Apple, please fix this!! What good is a backup solution if I'm constantly forced to delete my backup data? Not to mention the hassle and aggravation. Until this issue is resolved, Time Machine is pretty useless so I'll need to back up my files manually.

    You're posting in the Time Capsule forum, but backing-up to a USB drive attached to an Airport?

    While that does work for many (including me), you need to know it's not officially supported by Apple:

    Two things that might help:

    +Disk Warrior+ (version 4.2 only) may be able to repair the sparse bundle when DU can't.

    Oddly enough, the names of things may be part of the problem. Start with your +*Computer Name*+ at the top of the System Preferences > Sharing panel.

    It must not be blank; it should not be more than 25 characters long; and you should avoid punctuation, spaces, and special characters.

    After changing it, click the Edit button and make the corresponding change to the +Local Hostname.+

    If that doesn't help, apply the same rules to the name of your Airport Extreme and Network, via Airport Utility.
  • Auke Jilderda Level 1 Level 1 (0 points)
    I ran into this same issue. It seems, in my case, it turns out that considerable patience was all that was needed for Time Machine to complete. (Only to bail out, signalling the disk image is damaged. Again.)

    I use Time Machine to backup my laptop (MacBook Pro 13inch, 2009 model with solid state disk) to our NAS (Synology DS207+) across a gigabit network. The backup disk image at present measures 30.0 GB of data. Upon setting up my network after having moved houses, Time Machine appeared to be forever stuck at "Making Backup Disk Available". Upon closer inspection, Time Machine was
    very hard at work, supposedly verifying and/or repairing the backup disk(?), and required several hours to complete.

    Although the backup disk did not show in Finder, it had already been mounted by Time Machine. You can can verify whether it is mounted by running the 'mount' command in your Terminal, e.g.:
    jilderda@coruscant:~$ mount
    /dev/disk0s2 on / (hfs, local, journaled)
    devfs on /dev (devfs, local, nobrowse)
    map -hosts on /net (autofs, nosuid, automounted, nobrowse)
    map auto_home on /home (autofs, automounted, nobrowse)
    afp_35Bgno35Bgno35Bgno35Bgno-3.2d000007 on /Volumes/backup (afpfs, nobrowse)
    In addition, the laptop and NAS both showed considerable network load, with data received by the laptop most of the time hovering around 3 to 4 MB/s with periodic lulls (at 1 MB/s) and peaks over the 20 MB/s, indicating that Time Machine is busy perusing the backup disk. You can monitor this using Activity Monitor or other network monitoring solutions. The Synology of course also shows the traffic in their user interface.

    After some 6 hours, Time Machine got beyond the "Making Backup Disk Available" and finished its process. In other words, it seems some (considerable amount of) patience is all that is needed for Time Machine to get through this (and probably very much patience if you have a set up that is slower on the local I/O speed, the network, or the NAS I/O speed).

    Unfortunately in my case, Time Machine then signalled the backup disk image to be corrupt and Disk Utility also fails to repair it. This is now the 4th time within half a year so unfortunately Time Machine is proving too flaky to be a real backup solution at present. That said, I am not convinced the corruption is related to Time Machine needing so much time. It seems for some reason it peruses the disk image and, if your disk image is not corrupted, it presumably finishes that process and then runs the backup as usual.

    Hope this helps,

  • Pondini Level 8 Level 8 (38,715 points)
    Auke Jilderda wrote:
    . . .
    I use Time Machine to backup my laptop (MacBook Pro 13inch, 2009 model with solid state disk) to our NAS (Synology DS207+) across a gigabit network.

    Sorry, but Time Machine does not back up well, if at all, to network drives, except Time Capsules or a shared drive on another Mac running Leopard or Snow Leopard on the same local network. It will often back-up to a USB drive connected to an Airport Extreme, but even that is, technically, unsupported, and may require running a special Terminal command to make it work.

    Here's the official word:

    If the Synology doesn't meet the requirements in that article, you're unlikely to get Time Machine to work with it reliably.
  • Auke Jilderda Level 1 Level 1 (0 points)
    Synology products officially support Time Machine and AFP mounts and the TM setup can work fine for months at a time. Until Time Machine gets confused which thus far always results in the backup image being lost entirely. The two most common confusions are TM calling the backup image 'backup-1' instead of 'backup', which I suspect is because it failed to unmount properly at the previous backup action, and TM managing to somehow corrupt the backup image. Only TM can access the backup image, there is only one instance of TM on the network, and the NAS runs regular disk checks so TM seems the primary suspect to corrupt the image all by itself.

    TM is a nice idea and very user friendly but a long way from being solid enough to deliver on its promise as a easy, reliable backup mechanism.
  • Pondini Level 8 Level 8 (38,715 points)
    Auke Jilderda wrote:
    Synology products officially support Time Machine and AFP mounts and the TM setup can work fine for months at a time.

    Synology may claim to support Time Machine, but unless it meets the criteria in the Apple tech article, Apple doesn't support that hardware.

    TM is a nice idea and very user friendly but a long way from being solid enough to deliver on its promise as a easy, reliable backup mechanism.

    It does not promise to back up reliably to incompatible hardware.

    From a post in another forum (found by V.K.):

    The technical reason why Apple limits Time Machine to 10.5 AFP volumes appears to be to prevent disk image corruption. There were additional features added to AFP in 10.5 to support Time Machine. These presumably allow the disk image engine to force disk image journal data to write out all the way to the disk. Without such features, a network interruption can result in a corrupted filesystem on the disk image despite journaling. Remember, journaling relies on the journal being written all the way to disk before the changes take place. If you can't guarantee that (e.g., because of network/NAS buffering) then the journal is useless. Time Machine appears to rely heavily on disk journaling to deal with network drop-outs, interrupted backups, and the like. Take this away and your data is at risk.

    If the NAS you are using supports these features it should report them to the OS and you should natively be able to choose that volume. If you have to trick the OS to use the volume it means the NAS does not support it.

    To summarize: if you care about your backup data you should avoid using non-natively supported AFP servers.

    That post obviously applies to Leopard; Snow Leopard appears to have added some requirements, that are also not supported by all NAS devices, and some that were working with Leopard no longer work with Snow Leopard.
  • Parasolid Level 1 Level 1 (0 points)
    Somewhat different problem: I have a new brand-new iMac that I want to connect to TC for backups. My older iMac is being re-purposed, and I i want to dump the 500GB+ of backups to make room for the new one. (There are 2 other computers on TC as well, with another 500GB, so the 1TB TC has only 13 GB available. This is not near the 80GB I need to back up.

    How can the now-not-needed stuff be cleared off to make room? I tried throwing away the backup images into the trash, which took hours, but the space still seems to be allocated to the old account.
  • Pondini Level 8 Level 8 (38,715 points)
    Hi, and welcome to the forums.

    Different problems shouldn't be "tacked on" to unrelated threads; it's confusing (and called "threadjacking").

    Please repost with details: exactly what did you delete? The sparse bundle, or some of it's contents? If some of the contents, which?

    It sounds like you may not have room for TM backups of all those Macs. TM usually needs 2-3 times the space of the total data it's backing-up.

    When you re-post, include the total data on each of them, so we can address that, too.
  • Auke Jilderda Level 1 Level 1 (0 points)
    Thanks Pondini, that is a big help to understand why Time Machine keeps falling over. Crap that the solution is so vendor specific though -- vendor lock-in is so last century. Time to look for a proper backup solution; one that works with proper NASes.
  • swaybrig Level 1 Level 1 (5 points)
    Followed Liz's directions on page 1 of this thread and my Time Machine backups are working again! Thanks, Liz!
  • cripplesmith Level 1 Level 1 (0 points)
    I confess: I ran out of patience, after a mere 12 hours of looking at "making disk available", opted for "Force Quit" and start over...with some changes. First I deleted the existing sparsebundle, and then, after a bit of thrashing around, I discovered that by setting up the TC as the Wireless Network Host in "bridge" mode (and connected to my existing modem using an ethernet cable into the WAN post), all worked as it should - fast backups, fast access to shared files. I'm only an amateur geek, and I doubt I could reliably explain what boxes to tick to set up bridge mode, but I'll bet there's someone on this forum who could fill in the blanks.
  • philippm Level 1 Level 1 (0 points)
    I had the same problem on my iMac running 10.6.2 with an external hard disk connected to an Airport Exterme.

    I fixed it by unplugging the disk and then plugging it back in again after a few seconds.

    (Don't forget to Disconnect All Users in Airport Utility first, though).
Previous 1 2 3 Next