Previous 1 2 Next 15 Replies Latest reply: May 9, 2010 8:32 AM by stereoarm1
Averello Level 1 Level 1 (0 points)
Hello,
I just tried using my Nokia A2DP headset to hear some music from my MacBook Pro 13,3" (late '09) .
Everything goes right, the pairing, the use of the device
BUT
my problem is that the quality is disgusting!
The strange thing is that the same headset works just fine with my iPhone 3G in the same tracks (mp3) .

Is there a way that you can change sound quality for the Bluetooth headset?

Also, using another bluetooth device to talk over Skype the quality is poorer, and my interlocutors cannot hear me clearly, while the same headset works nice with my iPhone or the other mobiles phones, without quality loss.

The poor quality it is owed to the software (Mac OS X Snow Leopard 10.6.1) or to the hardware of the MacBookPro (13,3" model late '09) ??

MacBook Pro 13,3" (June '09), Mac OS X (10.6.1)
  • dcnet Level 1 Level 1 (0 points)
    I have a similar problem with my Motorola S9-HD. I sounds great and has plenty of volume on my Dell Laptop, but has poor quality and low volume on my MacBook.
  • Korlone Level 1 Level 1 (0 points)
    I just bought a the SHB 9000 philips headset, and the sound is poor, and it comes from the macbook because I tried it with with my old samsung phone and it works great even though I'm not sure that it supports A2DP.
    Even when I use it with the wire I got a constant crackle when I start a movie or music.

    Can somebody help us ?
  • skilng11 Level 1 Level 1 (0 points)
    I have the same problem w/ my motorola S305 headphones.... this is RIDICULOUS that macbooks/OS X do not support these correctly, when windows PCs and phones (and iPhones!) do. Someone please help me, I'm a relative novice to mac, and I hope to hear it will at least be worked on.... This better not be a lame attempt to avoid a hit on ipod sales. Come on Apple, get your $#%@ together.
  • Rich_Hill Level 1 Level 1 (0 points)
    Just wanted to confirm that my recently purchased Motorola S9-HDs sound absolutely terrific with my iPhone 3GS but not with my Summer 2009 MacBook Pro (running OS X 10.6.1). I was really hoping to use the S9-HDs as a solution for listening to music while traveling for business with my iPhone and MBP but the terrible sound quality dissuades me from using them with the MBP. Any insight would be greatly appreciated.
  • Philip Cheney Level 1 Level 1 (10 points)
    I battled with this for a while and for the longest time used another program to do the A2DP streaming for me. I just stumbled upon this today, thought, and it seems to do the trick!

    http://scott.dier.name/2009/10/osx-snow-leopard-a2dp.html

    Basically, the Mac defaults to a really crummy sound quality, even though it shouldn't have to. The link above show you how to change the minimum default quality setting. Works like a charm, though you may have to hunt for the ideal setting.
  • mrcc Level 1 Level 1 (0 points)
    I cant find utulities-special options. can anybody help me??? Thanks
  • surfgeek Level 2 Level 2 (200 points)
    Changing minimum setting does not seem to have much if any effect with my Motorola S9 headphones. I have MBP 13" 10.6.2. Come on Apple, this should be a priority if you want macs to be true media machines.
  • mrcc Level 1 Level 1 (0 points)
    Sprinkesnirg said...
    open Terminal and type in this:
    *defaults write com.apple.BluetoothAudioAgent "Apple Bitpool Min (editable)" 50*
    This is case sensitive, so just copy/paste it

    Thanks Sprinkesnirg for solution.
  • chillyperson23 Level 1 Level 1 (0 points)
    Same problem with Motorola S9-HD on my new iMac 27 inch. I fixed it for a while by going to Bluetooth Explorer> Utilities> Special Options, and changing the bitpool value to 40. But after I had to reinstall snow leopard (because of issues) I cant even find bluetooth explorer in spotlight or in utilities anymore. If you have bluetooth explorer, then that works great but if you don't, you're stuck until Apple fixes the problem.
  • JonnyClark Level 1 Level 1 (5 points)
    Just for the record, I had similar problems with a cheap-impulse-buy headset. It worked flawlessly with my cheap-impulse-buy bluetooth sender for iPod but on my MBP the sound reminded me of an old 78rpm gramophone.

    I changed the "bitpool min" value to 50 with no effect. 40 worked very well, though.

    Thanks for all the pointers, folks!
  • jberylec Level 1 Level 1 (0 points)
    I just bought the new Belkin bluetooth receiver from the Apple store and hooked it up to my home sound system. When paired with my iPhone 3GS it sounds amazing, I love it!

    But when paired to my Early 2009 Macbook Pro 10.6.2 it sounds horrible and cuts out constantly! I've tried the above work around with 'just ok' results. I've tried 40, 45, and 50 but each setting still has problems.

    Come on Apple, resolve this already!
  • Michael Steen Level 1 Level 1 (5 points)
    Thanks for the workaround. I had to restart my iMac to get the settings to "take" but it's now performing much better. I'm using a minimum of 34 in an attempt to stop it cutting out. Unfortunately even at 34 I still get cutouts (once every few minutes) so more tweaking is needed. This is on an iMac 8,1 paired to some Motorola S9-HDs.

    I have the Apple wireless keyboard and mouse also running off Bluetooth so I'm wondering whether part of the problem is one of sheer data throughput over BT? (Does keyboardmouseA2DP=too much for a BT chip to keep up?)
  • brfsa Level 1 Level 1 (0 points)
    I have a nokia BH-214 and I found that this device supports maximum of 53. I changed my settings to 48 and the sound quality is way better now.. before it was unusable...

    as you can see the maximum negotiable is 53, so 48 is quite good already.

    defaults read com.apple.BluetoothAudioAgent

    {
    "Apple Bitpool Max (editable)" = 80;
    "Apple Bitpool Min (editable)" = 48;
    "Apple Initial Bitpool (editable)" = 40;
    "Negotiated Bitpool" = 48;
    "Negotiated Bitpool Max" = 53;
    "Negotiated Bitpool Min" = 48;
    }


    I changed the minimum to 48 and the maximum to 80 for other devices.

    defaults write com.apple.BluetoothAudioAgent "Negotiated Bitpool Min" 48
    defaults write com.apple.BluetoothAudioAgent "Negotiated Bitpool Max" 80


    Extra info from another Site:

    30 - Low audio quality
    40 - Medium audio quality
    48 - High audio quality
    58 - Excellent audio quality

    Source: http://forum.xda-developers.com/showthread.php?t=457331
  • DragonAndarian Level 1 Level 1 (0 points)
    I have a Motorola headset and I got the settings to the point where it doesn't sound like total crap, but the problem I have noticed is that the audio seems to slow down and speed up. Is there a fix for this?
Previous 1 2 Next