1 2 Previous Next 29 Replies Latest reply: Nov 11, 2009 2:22 AM by lindafs
jesper ordrup Level 1 Level 1 (0 points)
When hitting the "Perform" button in Mainstage 2.01 my Mac OSX Gui freezes. I cant force quit as no keycommands help.

If i SSH to my mac I can see that a lot of processes are still running. Even mainstage is running with a cpu usage of 10% - 15%. And nothing else is using more.

To reproduce:

Open Mainstage 2.01
Open any concert (with guitar)
Click Perform
GUI freezes.

This happened on both Mainstage 2 and after upgrading to Mainstage 2.01.
Also - Logic Pro 9 works like a charm. Loads very large projects plays/edit/records without any problems.

Please advise, thank you

Jesper

macbook pro 3.06, 17", Mac OS X (10.6.1), 4 gb ram, 512gb disk, Apogee Duet
  • 1. Re: Mainstage 2.01 freezes
    Blueberry Level 4 Level 4 (2,860 points)
    Sounds like a graphics card issue, if not even force quit works. I would suggest reporting it to http://www.apple.com/feedback/mainstage.html with your system information.
  • 2. Re: Mainstage 2.01 freezes
    rc tech Level 2 Level 2 (215 points)
    As I posted in another thread, if you have a recent MacBook Pro, you can go to the energy saver preferences and set the graphics option to "better performance." This fixed a problem I was seeing where it was freezing in a different situation with an external monitor...
  • 3. Re: Mainstage 2.01 freezes
    littleeden Level 1 Level 1 (75 points)
    Hello again rc tech - how would I do something similar with my white Macbook (bought April 09)?

    I ask because I had a similar problem last night when the GUI froze while in full-screen mode. The playback continued, and the sound from my guitar and mic were still there, but when the song finished, the whole thing was locked up and I had to power off to re-gain control. This is the first time I've seen this happen, but as I'm planning to gig with MS2 on Friday, it doesn't fill me with confidence.

    Thanks
  • 4. Re: Mainstage 2.01 freezes
    jesper ordrup Level 1 Level 1 (0 points)
    This actually helped

    Mainstage 2 does not freeze up every time, only sometimes.

    Thanks
    Jesper
  • 5. Re: Mainstage 2.01 freezes
    littleeden Level 1 Level 1 (75 points)
    Hi Blueberry,

    If this is the same problem I had last night (see post to rc tech), and it sounds like it, I don't think it's a graphic problem as I was still able to move my cursor around the screen - it's just that none of the on-screen controls worked. I couldn't force-quit as I was in full-screen mode, so had to power down.

    I have taken your advice and reported it as a bug.

    Thanks
  • 6. Re: Mainstage 2.01 freezes
    rc tech Level 2 Level 2 (215 points)
    Unfortunately the MacBook does not offer this option, as it only has integrated graphics, where as the MacBook Pro actually comes with two different graphics cards.

    The cursor moving around is actually a red herring -- on older computer systems (many systems build before the year 2000 or so) the cursor was drawn "in software" which means that when the system froze, the cursor would lock up too. In newer computer system the cursor is drawn "in hardware" which means that even when your system is completely locked up the graphics can continue to figure out how to draw the cursor. Although it sounds like a totally useless feature, it used to make a performance difference...
  • 7. Re: Mainstage 2.01 freezes
    littleeden Level 1 Level 1 (75 points)
    Ah ha - ok, that explains that. Thanks, rc tech
  • 8. Re: Mainstage 2.01 freezes
    littleeden Level 1 Level 1 (75 points)
    Hi Blueberry

    I notice on another thread you mention using panic (Ctrl-P) to get control back without re-starting.

    Do you think this would work in this case, as well?
  • 9. Re: Mainstage 2.01 freezes
    littleeden Level 1 Level 1 (75 points)
    Well, to answer my own question to you, Blueberry - 'no it doesn't'.

    Had the same problem at reheasal last night, and the only thing that worked was pressing and holding the power button. The only effect anything else had was to make the screen flash (the GUI was still visible, but sort of momentarily greyed-out).

    First performance with Mainstage tonight, no alternative, very apprehensive - watch this space.....
  • 10. Re: Mainstage 2.01 freezes
    jesper ordrup Level 1 Level 1 (0 points)
    I've had zero breakdowns with Mainstage after changning "Energy Saver" Graphics setting to "Higher performance".

    /Jesper
  • 11. Re: Mainstage 2.01 freezes
    littleeden Level 1 Level 1 (75 points)
    Thanks rc tech

    Unfortunately, from what you and blueberry have said, backed up by Jesper's comment, it looks as though my Macbook is simply not up to the job of running Mainstage 2 reliably.

    Would you say this is fair comment, or have I missed something vital?
  • 12. Re: Mainstage 2.01 freezes
    rc tech Level 2 Level 2 (215 points)
    Sorry for not getting back to you earlier. I think your computer is powerful enough -- but it seems like it might be a Snow Leopard bug, as I didn't have any problems when I was still running Leopard. You can try downgrading to Leopard...
  • 13. Re: Mainstage 2.01 freezes
    littleeden Level 1 Level 1 (75 points)
    Many thanks rc tech.

    Played my first gig with MS2 on Friday - difficult, with fingers crossed Fortunately, no freezes, and I haven't seen any since. On the plus side, the sound was awesome, and drew a number of favourable comments, and the ease of use, even without a pedal board, was really refreshing. At last I'm able to tweak the mix of my backing tracks live, praise be!
  • 14. Re: Mainstage 2.01 freezes
    littleeden Level 1 Level 1 (75 points)
    OK, update - second gig with MS2, and I'm into about the fourth number, in full-screen mode, change patch for a solo, try to change back - no dice, the screen's frozen again. The arrow keys don't work to move back to the previous patch, the screen white's out when I try selecting any screen button. What made things worse, was I didn't have a vocal channel in the patch I set up for the solo sound, so although I got to the end of the song, I had to do it without vocals.

    This is serious. I bought Apple because of their reputation for reliability, and I don't see how I can rely on MS2 for live. Any helpful suggestions would be very much appreciated, otherwise it's back to the drawing-board.
1 2 Previous Next