Previous 1 2 Next 19 Replies Latest reply: Feb 23, 2010 3:56 PM by Eric Hoffmann
kevin0101 Level 1 Level 1
Tsmuxer by smartlabs doesn't open. Mkvtools opens but can't see file structure. FFmpegX crashes when importing many kinds of files. I have found I am back at my P.C. to do most of my video editing. I find Snow leopard useless and will be downgrading. Does anyone else have these problems?

iMac 3.06 dual core intel, Mac OS X (10.6.1)
  • K T Level 7 Level 7
    expertise.publishing
    Publishing
    kevin0101 wrote:
    Tsmuxer by smartlabs doesn't open. Mkvtools opens but can't see file structure. FFmpegX crashes when importing many kinds of files.


    Have you checked with the sites for those apps to see if they have been updated for Snow Leopard capability? That job lies with smartlabs as an example, not Apple of course.

    This is a link to a page on a site that is running a list:
    http://www.macintouch.com/specialreports/snowleopard/slcompat.html

    You can check there, but again, I would recommend going directly to any product related site to see if the developer has released an update or posted a release schedule, etc.
  • kevin0101 Level 1 Level 1
    I have tried to contact Smartlabs and I get no response. I have also spoken with apple reps. whom advise me to downgrade due to the issues I am having. I have also check with a few sites whom claim that programs work. Some work but not all functions. Even when starting using rosetta.

    SL is not all it is cracked up to be. I am not happy with it at all. especially because I have to clean install to downgrade.
  • VoxMac Level 1 Level 1
    Hi Guys,

    I've worked for you ! I Give you a Christmas Present !
    I've done a Snow Leopard Hack of the latest version of tsMuxer (1.10.6).
    It works properly, but take time to read the SnowLeopardHack.Readme.en where I explains the problem, and the way I've solved it (and the little restriction).

    You can download it at : http://rapidshare.com/files/325511189/tsMuxer1.10.6_SL_Hack_byVoxMac.dmg

    Merry Christmas.
  • iBookster Level 1 Level 1
    Thanks for the present - just what I was looking for. However it crashes on my macbook air. It won't even launch:

    Exception Type: EXC_BREAKPOINT (SIGTRAP)
    Exception Codes: 0x0000000000000002, 0x0000000000000000
    Crashed Thread: 0

    Dyld Error Message:
    Library not loaded: QtGui.framework/Versions/4/QtGui
    Referenced from: /Users/thomas/Desktop/tsMuxerGUI.app/Contents/MacOS/tsMuxerGUI
    Reason: image not found
  • VoxMac Level 1 Level 1
    Sorry iBooker, it seems that Qt libraries are needed.
    You may download them from http://qt.nokia.com/downloads using the LGPL (free) license.
    As I have used the LGPL version of the SDK to compile the sources, it seems that it's compile with dynamic libraries and that they aren't bind in the program.

    VoxMac
  • VoxMac Level 1 Level 1
    Guys,

    I've followed my investigations about tsMuxer and Snow Leopard.

    Here are the results :

    _GUI is not working due to an incompatibility in the qtlib_.
    The GUI crashed and give the message :
    +Qt: qcolorFromCGColor: cannot convert from colorspace model: 0+
    +ASSERT: "false" in file kernel/qt_mac.cpp, line 99+
    +Abort trap+

    The work-around is to recompile the GUI from source given by SmartLabs. (QT libs and XCode are required for the operation).
    If you don't want to compile the program by yourself, you can take the version down in the post.

    _tsMuxeR is not working due to fonts interpretations problem._
    We got a 'bus error' when trying to execute the command in command-line mode.
    The problem is due to 2 particulars korean fonts supplied in Snow Leopard.

    To solve the problem, if you don't use those korean fonts, delete or rename
    the two following fonts : AppleMyungjo.ttf and Gungseouche.ttf located in /Library/Fonts
    When done, the tsMuxeR command Line should Work

    _New version_
    Based on that, I've rebuild the GUI and I've added the original tsMuxeR 1.10.6 inside the application.
    Feel free to download it at http://rapidshare.com/files/326372784/tsMuxerGUI.1.9.9-with-tsMuxeR-1.10.6.zip
    Be aware that qtlib are requested in order for the GUI to run (http://qt.nokia.com/download)

    VoxMac
  • Adriana Velarez Level 1 Level 1
    VoxMac first of all, thank you so much for taking the time out to share your findings with us. I know I can tell you I was very excited reading your latest post.

    TSMuxer loads up but when I select any MKV movie I get this error:
    Can't detect stream type. File name:
    "/Users/Adriana/Movies/greatestmovie.mkv"

    I have renamed the fonts and even deleted them and also rebooted.
    I have downloaded the open source LGPL qt libraries.
  • VoxMac Level 1 Level 1
    Hi Adriana,

    Have you tried with another movie ?

    Otherwise you can try to open a Terminal (Applications>Utilities>Terminal) and try this command (tsMuxerGUI in /Applications):
    */Applications/tsMuxerGUI.app/Contents/MacOS/tsMuxeR /Users/Adriana/Movies/greatestmovie.mkv* (one line)
    If it shows you the descriptions of the contents of the mkv or something else than a Bus Error, that means that the application is OK, and that the file has something wrong.

    Can you show the message that you get from the Terminal, that will help for investigations.

    Regards, VoxMac
  • VoxMac Level 1 Level 1
    Me Again, I've done a stand alone version that doesn't required the QT libs anymore (they are in the Apps).
    The new version is bigger than the previous one, but still small (14 MB).
    You can download it here : http://rapidshare.com/files/327571911/tsMuxerGUI1.9.9_with_tsMuxeR_1.10.6_Snow_Leopard_StandAlone.zip
  • VoxMac Level 1 Level 1
    VoxMac wrote:
    Me Again, I've done a stand alone version that doesn't required the QT libs anymore (they are in the Apps).
    The new version is bigger than the previous one, but still small (14 MB).
    You can download it here : http://rapidshare.com/files/327571911/tsMuxerGUI1.9.9_with_tsMuxeR_1.10.6_Snow_Leopard_StandAlone.zip

    I've changed the link to give the original Licence and Russian Readme from SmartLabs :http://rapidshare.com/files/327599781/tsMuxeR1.10.6_VoxMac_UnofficialBuild.dmg
  • VoxMac Level 1 Level 1
    Seems RapidShare has problems, so here is a MegaUpload Link : http://www.megaupload.com/?d=1ZDZHPJU
  • Adriana Velarez Level 1 Level 1
    Thank you VoxMac. I downloaded your new version from megaupload and it does load the video now. Before I was getting Bus error in the terminal. I tried the new app with the libraries included and still got the Bus error. I read your readme file and it reminded me about the fonts. I looked at the font and I had just renamed them and never deleted them. So this time I deleted them and it loaded up fine in the terminal and gui.

    I renamed the fonts by adding .bak to the font name (*.ttf.bak)

    Now to see if this works building up a nice AVCHD that can scan and skip chapters. The regular version of TSMuxer (not yours) I was using before in Leopard was not allowing this properly. I ended up using MKV2VOB to build AVCHD that could scan/seek forward and back.

    PS Is anyone else experiencing slow chapter skips with PS3? I click on the skip forward chapter and the screen goes black, the video input name shows up on my TV (HDMI 2 input), goes away, screen black again and then I see the video. This whole thing takes about 5 seconds.
  • VoxMac Level 1 Level 1
    Hi Adriana, I'm glad your problem is solved.

    For your other problem, I haven't notice any problem with chapters skipping with the PS3.
    Your problem remind me the problem I have when I use cropped MKV, because tsMuxer
    add a special black video, in order to trick the green bar down the video, and it seems that
    the PS3 is confused when skipping chapter.

    Now, I use AviDemux to add black bar to the video (it's slow when you want to keep the quality),
    and this avoid the use of the black video.
  • Adriana Velarez Level 1 Level 1
    Yes that is exactly what I'm doing. I'm using cropped MKVs and MKV2VOB does use some type of trick to fix that from what I read in their program updates information.

    I would use AVIDemux but from your description it sounds like you're re-encoding movies and I rather not do that. I also have HD (720p) movies from my digital camera (canon sd940) and they are cropped and without black bars and would rather not reencode everything. But thank you very much for telling me about your experience at least now I know why the chapter skipping is slow.

    I do notice that these cropped MKVs to AVCHD puts the video starting from the very top of my TV and leaving a big thick black bar on the bottom and no black bar on top. Is this what it's supposed to happen with the black bar "fix" that some programs are using or am I doing something wrong?
Previous 1 2 Next