4 Replies Latest reply: Sep 30, 2009 6:50 PM by szettel
farscape2 Level 1 Level 1 (0 points)
Windows 7 & iTunes 8 worked flawlessly, then came the upgrade to 9... Since then, everytime I start up iTunes, Windows Installers keeps configuring iTunes.

When I updated to 9.01 I thought that might eleviate the issues when it didn't I set out to find out why.

Found that it (windows Installer) tries to keep getting access to the .pcast value in the registry. Turns out I don't have access to it, so neither does Windows Installer.

So I set the permissions to the pcast value to my account, having full access. The values in the key are now shown in the registry, but... Windows Installer now comes up with a fatal error when it tries to configure iTunes stating that it does not have access to the pcast value...

What's the deal? Are more people suffering from this? Why did this problem not occur when using iTunes 8?

More importantly, is there a solution out there :)?

Thanks in advance!

farscape2

Other OS, Windows 7
  • borissieapple Level 1 Level 1 (0 points)
    I have troubles to when installing or updating v8 to 9.0.0 or 9.0.1.
    There are "problems with Windows Installer" according to iTunes.

    There are certainly NO problems with Windows Installer. The problem was iTunes, and still is iTunes. Seems like Apple is nagging their Windows clients.

    btw: i have Windows 7 RTM x64 as OS.

    Unfortunatly I have no solution for you.
    For myself I wait for another patch/new version, make an image of my harddisk, and try the newer version.
  • polydorus Level 6 Level 6 (11,950 points)
    I am not sure that this will help as you may already have tried it, but take a look at this post:
    http://discussions.apple.com/message.jspa?messageID=5489263#5489263
  • farscape2 Level 1 Level 1 (0 points)
    Thanks, but actually I did the exact same thing (also took me quite a few hours to figure out the problem resided with the registry values), however, I didn't change 40 keys, just the pcast keys and their underlying (non-inheriting) keys, with the result that it couldn't access them at all (which is weird, because all the registered admins to my machine had full access to it), resulting in the fatal error I mentioned above :S

    iTunes wouldn't even uninstall after that!

    Reverting to the registry backup I made before making these changes, so that at least I could uninstall iTunes 9.01 didn't make a difference, it kept nagging about Windows Installer not having access (at this time, neither did I - at least that made some sense :D).

    I ended up doing a system restore, so now I'm still getting the windows installer that configures iTunes at each start up, but at least it starts up again.

    Tomorrow I'm going to try and uninstall it and install iTunes 8 again and see if the problem persists or if that fixes it (some people seem to be having this exact same problems way before iTunes 9 and some don't, the combo being iTunes and Windows Vista or Windows 7).

    farscape2
  • szettel Level 1 Level 1 (0 points)
    I don't know if this will work in windows 7 but it has always done the trick for me in Vista x64.

    The problem seems to be related to the shortcut link located here:
    C:\ProgramData\Microsoft\Windows\Start Menu\Programs\iTunes
    as every time I start iTunes straight from its executable or from a shortcut of my own making it starts up perfectly fine, no installer bit.

    So every time I upgrade iTunes all I do is swap out the default shortcut in the aforementioned folder for a self made shortcut. Its a PITA, but it's far easier than all the registry edits.

    Message was edited by: szettel