8 Replies Latest reply: Oct 31, 2009 9:27 PM by enostrum
Jason Goldsmith Level 1 Level 1 (135 points)
I am experiencing a weird problem. When I add a person's email address to the "To:" field, their last name is repeated. This happens when the person is an entry in my Address Book.

For example, say David Smith is an entry in my Address Book. When I start to type David Smith into the "To:" field, the field auto completes with david.smith.smith@mac.com. When I hit the return key to accept this auto complete, I get "David Smith Smith" in the "To" field. Of course, I've double checked address book to make sure the last name isn't listed twice (it isn't). This has happened to many other addressee's. Weird. It's also very consistent. Only certain addressee's show this behavior.

I'm using Mail with an exchange account.

Jason

2.4 GHz Intel Core 2 Duo 17" MacBook Pro, Mac OS X (10.6)
  • mr.e-man Level 1 Level 1 (15 points)
    I'm getting this as well. It just started happening with the SL update and Exch2007 ActiveSync. I'm noticing that when names pop up with a double last name they are being auto-populated by EAS reading from Active Directory. These are not names I have in my Address Book. Mail must be pulling these over LDAP from our company's Active Directory database of users.

    Any suggestions to correct this are appreciated. It's not a deal breaker because I also get the correct name from the LDAP lookup, it's just annoying to see it in the auto-complete list, and more often than not it's the first result for the name.
  • Bucht Level 1 Level 1 (90 points)
    same problem here, seems to be linked to exchange 07 which i also use but i don't have activesync enabled. it works fine except looks wrong. strangely enough, sent mail appears fine.
  • mr.e-man Level 1 Level 1 (15 points)
    Sounds like it's LDAP related then. I don't see how else Mail would be getting that info. Maybe Mail just REALLY likes last names. ;^)
  • Ugino Level 1 Level 1 (0 points)
    Has anyone fixed this problem???....
    anoying by the way...
  • bneely Level 5 Level 5 (5,255 points)
    Check your Address Book cards and make sure the "First Last" text is not all in the first name field. Also, be sure to check for these addresses in Mail's previous recipients list (available via Mail's window menu).
  • Jason Goldsmith Level 1 Level 1 (135 points)
    Going to Previous Recipients and deleting the offending name solved the problem. That person is still in Address Book, but no longer listed under Previous Recipients.

    Thanks!
  • ekruB Level 1 Level 1 (0 points)
    I'm seeing this same problem, except with first names.

    For example, I have an entry like "Mom" or "Dad" with first name only, it looks fine in Mail, Address Book, and iPhone all sync'd through Exchange. Then a few days later, I go to write an e-mail to Dad and his address comes up as "Dad Dad" in Mail. I edit my address book and "Dad" is now defined both as first name and last name. I delete the "Dad" from last name and make it a few more days or a week and then it happens again.

    I see hints of others seeing this problem on the web (this forum and http://forums.macrumors.com/archive/index.php/t-363518.html), but no solution yet.

    I've only seen this problem since upgrading to Snow Leopard and using the new built-in Exchange sync. iPhone is running 3.1.2.
  • enostrum Level 1 Level 1 (0 points)
    This is a very strange problem that I am suffering since 2 years ago.
    It seems that Mail.app likes to autocomplete your address book contacts with mail information but it makes it wrongly.
    This can be avoided by several ways:
    -unchecking that option in Mail/Preferences/Composing (I'm Spanish, so I'm not sure if that is the correct menu) but this also turns off the autocompleting when entering addresses in the "To:" form.
    Apple should make different checkboxes because they are different options...
    -putting spaces when surnames not needed so Mail thinks it is completed and won't autocomplete it
    -Checking and deleting "Previous Receipts" menu because here starts the problem. If here the name is ok, it will remain ok but if here appears dupicated it will be duplicated very soon (I'm not sure when actually) so check it, correct it in address book and delete the entry from previous receipts.
    -LAST AND BEST. Stop using previous receipts, it will still autofilling the "To:" form with your addressbook contacts but you don't have to check previous receipts every time you send a mail. Delete all the list, close mail and enter "defaults write com.apple.mail SuppressAddressHistory -bool true" in Terminal.

    Greeting from Spain.