1 2 Previous Next 27 Replies Latest reply: Jul 2, 2010 12:33 PM by satcomer
Andreas D. Level 1 Level 1 (0 points)
Hi community!

I have a very annoying problem with my home network. I have a windows xp pro box I use as a media player (running plex) - to copy movies/music to it from my MacBook I activated network sharing of one folder on the windows pc. I have a user set up to access this share using a password. Everything works fine - most of the time.

Sometimes when I start copying a lot of files (like 20 .avis) some of them don't make their way to the shared harddrive. I see them getting written on the windows harddisk but as the copy process from my MacBook is finished, they're getting deleted on the windows share.

I searched the forums and found some tips about using a username/password (what i did), but nothing worked for me - files keep disappearing after I copyed them to the share.

So is this a generall SL bug? Is there a workaround?

Thanks!

Unibody MacBook Late 2008, Mac OS X (10.6.1)
  • 1. Re: Windows (smb) share - files disappear after complete copy
    dlytle75 Level 1 Level 1 (0 points)
    I have been having the exact same problem. I have looked for solutions on the internet and have come up with nothing. I noticed this problem after installing Snow Leopard. I see the files copy to my Windows server, then after the copy is complete, some of them are deleted. Not sure what's happening here.
  • 2. Re: Windows (smb) share - files disappear after complete copy
    Animatco Level 1 Level 1 (0 points)
    I am glad to see that I am not the only one. If I copy just a single file it seems to not be deleted, but multiple files are. I can ftp, but this was easier.
  • 3. Re: Windows (smb) share - files disappear after complete copy
    Diveflo89 Level 1 Level 1 (0 points)
    I have the exact same problem...Apple come on we need a fix for this!
  • 4. Re: Windows (smb) share - files disappear after complete copy
    jayemdee Level 1 Level 1 (0 points)
    having the same problem.

    MacBook running 10.6.1 copying files to a Windows Server 2003 R2 64-bit server. Have been using it as my home server for years.

    Now when I copy files up, some (not all) of them just disappear after the copy is complete.
  • 5. Re: Windows (smb) share - files disappear after complete copy
    grovberg Level 1 Level 1 (10 points)
    For the record, this problem is not unique to Snow Leopard. I've been having this problem off and on with 10.5 for over a year.
  • 6. Re: Windows (smb) share - files disappear after complete copy
    ekistics Level 1 Level 1 (0 points)
    Yup same thing started happening to me in our 20 person office. We upgraded about 12 imac's to Snow Leopard and files (that are copied or worked on from the Mac) have started to disappear off our Win 2003 server. They are gone gone gone. We are now working locally on files then copying back to the server at days end. This is a royal pain in the ***!
  • 7. Re: Windows (smb) share - files disappear after complete copy
    Phero2 Level 1 Level 1 (0 points)
    I have the same problem. Copy many files and some if not all are deleted. Copy one and it works more often. This is a really bad problem and it has been there for a long time - also before 10.6.

    When is Apple going to fix this? I guess nobody knows.
  • 8. Re: Windows (smb) share - files disappear after complete copy
    felee Level 1 Level 1 (0 points)
    Hello,

    Just to add my 2 cents, I have the about same problem with Leopard 10,5,8 and after some tests I have note that the file copy fail when I try to copy to NTFS destination, so when I test to file copy from MAC OS X server to Mac OS X no problem, to WIndows with FAT32 no problem, but with NTFS the filecopy fail !

    Hope that could help.

    Rgds
  • 9. Re: Windows (smb) share - files disappear after complete copy
    MelvinTong Level 1 Level 1 (0 points)
    Just to confirmed the same problem - I lost a number of movie files (both .avi and .mkv) after moving them from my MacBook Pro to my storage server running Windows 7 with NTFS.

    If anyone knows a way to recover the files, that would be greatly appreciated. Some of the files are over 1GB each and they are not easy to come by...
  • 10. Re: Windows (smb) share - files disappear after complete copy
    TreyF Level 1 Level 1 (0 points)
    I too have been having the same issues with files disappearing copying files to my synology cs407. I have discovered some that I'm not sure is related. Under SL my shared volume is reporting being bigger and it does when I map the volume under my MacBook running 10.5 or in vmware fusion. If I copy files in fusion or under 10.5 it doesn't seem to happen. Can anyone else verify this?
  • 11. Re: Windows (smb) share - files disappear after complete copy
    Robbie Zellitti Level 1 Level 1 (0 points)
    I am having the same issue at our college with OS X.6.2 on an iMac brand new out of the box. I have been working with our Network folks who setup the Active Directory and it seems the creator/owner doesn't get into the permissions list. So when you copy a file there is no owner on the file permission. This is a file I copied from a FAT formatted USB drive and from the desktop. So you see it for a second and then it disappears. If you save the file the permissions are correct and you can see the file. A save as and replace will allow you to see the file that you copied. Any thoughts?
  • 12. Re: Windows (smb) share - files disappear after complete copy
    JDThree Level 1 Level 1 (55 points)
    Hate to just do a "me too" chime in without any solution, but I have the same junk randomly.
    Just now, I moved 9 files, a little over 2GB each, to one of my windows home server shares.
    Took the normal time to move files over my 802.11n network, and I saw the files disappear from the source folder on my desktop on my MBP one at a time as they got moved. Got the operation done sound once all were moved, no problems, and when I went to look at the destination drive, none are there. Nowhere to be found... Frustrating, very frustrating.
    I don't usually have anything disappear moving things one at a time. And usually I copy then just delete the originals after the copy completes, but I wanted to save that step this time. Which really irks me because now I have to redo those 20GB of files and copy them this time before deleting...

    I'm a windows user since the 80's, just got my macbook pro in July this past summer, and I like it for everything EXCEPT file operations. That's just one place where the mac really seems ********, the lack of flexibility, options, or commands when it comes to dealing physically with files... And this random disappearing file thing really frustrates me because it's so random, and so inconsistent. At least if it was always caused by doing something specific I could avoid whatever that trigger was. but I can do the same thing ten times and it works for 9, then the 10th time the exact same thing done in the exact same fashion fails...

    If it weren't for the awesome power of gestures with this touchpad, and expose, I'd just boot to windows 7 as my primary OS and say goodbye to these headaches... But this touchpad is just too easy to get used to in OS X, was actually the thing that pushed me over the edge to finally try a mac since I could dual boot...
  • 13. Re: Windows (smb) share - files disappear after complete copy
    w_m0zart Level 1 Level 1 (0 points)
    I found a workaround: (I think partition type is irrelevant, on my windows xp installation it works both on an ntfs partition and a windows ext2 partition, using ext2 driver http://www.fs-driver.org/):

    Just make sure that your shared folders on the xp system aren't empty before you connect to it.

    After putting just an empty folder inside the shared folder from within Windows, mounting it from my Mac works without these problems. Files now stay.

    Can someone reproduce this?
  • 14. Re: Windows (smb) share - files disappear after complete copy
    QuonsetDK Level 1 Level 1 (0 points)
    I have the same problem:-( When copying files to a Windows server 2003 a large number of files disappear after copy is finished. I have tried to change the copied files to read only just before the last file is copied. That makes the files that were already copied stay!! The conclusion must be that the files are in fact copied without problems but the Mac OS is for some reason deleting the files afterwards. This is a major BUG.... I will leave Mac OS if a fix in not found fast. Losing pictures when moving them from a flash card to a Windows share is in no way acceptable NB. tried the empty folder work arround without any luck.
1 2 Previous Next