Skip navigation
This discussion is archived

Can't see iPhoto movies from the iMovie Event Browser

21742 Views 30 Replies Latest reply: Apr 25, 2010 1:32 PM by luz98 RSS
  • asheri Calculating status...
    Alan, you know what's interesting, my sister-in-law bought a 17 macbook pro a few months ago and she has the same problem: none of her iphoto movie show up in imovie. She only has a few movies, maybe 20.

    She does not Snow loaded so it's not that... maybe a iLife update that accomidates 10.6? Not sure, anyhow, she is taking her MacBook to the apple store today to fix this problem and also the fact her wireless card is intermitten.

    I'll post what apple did to correct the problems asap.
    2.4 iMac, 4 GHz Ram, 750 GB Internal, Mac OS X (10.6.2), 4 TB Drobo, 20" Apple Cinema Display, Apple TV
  • dowdellea Level 1 Level 1 (0 points)
    Guys, ok. I am not sure exactly what I did to make it work but here is the summary:

    - rebuilt iPhoto library - didnt help
    - deleted all slideshows (who actually uses them anyway) - didn't help
    - made a new slideshow, deleted it - didn't help
    - took out all "&" symbols from events, and from albums in iphoto
    - started iphoto with "new" library, put one photo in there
    - started imovie
    - shut both down
    - restarted iphoto with my full library, containing >1500 videos
    - rebuild iphoto library again
    - started imovie
    - clicked on iPhoto videos
    - I can now see all my iPhoto videos!

    Clearly iMovie talking to iPhoto can handle >1500 videos, it's something else causing this bug, something that gets fixed when you rebuild the iPhoto library. I will let you know if I have any other issues..

    Alan
    iMac 24"
  • AndreaEos Calculating status...
    Hi Guys,
    Unfortunately I have the same bug and all of your procedure does not help.
    In addition imovie show me the external HD (where i have my photo ) with a yellow flag and an exclamation mark

    but I see all photo, i just missing of my AVI files from iphoto library in imovie.
    I cry!
    Mac OS X (10.6.2)
  • AndreaEos Level 1 Level 1 (0 points)
    Hi,!
    Solution found!
    iMovie 8.0.5 has this characteristic,
    Reinstalling 8.0.4 from TM now i can see from iPhoto library all of my movies.

    Regards !
    Mac OS X (10.6.2)
  • dowdellea Level 1 Level 1 (0 points)
    Well, I am back again... my "clean up" process of the iphoto database only worked one time then it was back to crashing again each time we click on iPhoto. So, I took AndreaEos advice and reinstalled 8.0.4 from TM (drag 8.0.5 to trash, then drag 8.0.4 from TM to Applications). You can see the version using Get Info command "I". 8.0.4 did not crash when choosing iPhoto.... I wonder if a simple reinstall of 8.0.5 might do the same thing? Not sure what we lose going back to 8.0.4, but Apple, it's really sad we have to do this... I still don't consider this question answered, by the way....

    Alan
    iMac 24", Mac OS X (10.5.8)
  • AndreaEos Level 1 Level 1 (0 points)
    Hi ,
    I get 8.0.4 from TM but i did not put 8.0.5 in the trash.
    during the installation TM asked me if i want write the 8.0.4 on 8.0.5 OR mantein both installed .
    I indicated to write on it .
    I don 't have any problem until now. In case of problem try to install both version.
    In any case my method is not a solution, it is a botch.

    I hope in future revision 8.0.6.

    Ciao
    Mac OS X (10.6.2)
  • nevillev Level 1 Level 1 (0 points)
    I second the hope that there will be an 8.0.6 which fixes this issue.

    I had the same issue with 8.0.5. After reading these helpful posts I did exactly one thing: Restored 8.0.4 from TM; replacing 8.0.5.

    Once again my thumbnails show up correctly; and I have (so far) not experienced any negative side effects from the restore.
    Macbook Pro, Mac OS X (10.6.2)
  • MattVH Calculating status...
    The "&" sign seemed to be the sole problem for me. I had the same issue until I removed the "&" from the iPhoto event name, quit both iPhoto and iMovie and restarted. The iPhoto library thumbnails generated correctly again.
    Mac OS X (10.6.2)
  • David Tozer Level 1 Level 1 (5 points)
    So, my newest iPhoto video event would not show up in iMovie, thus me searching and finding this message.

    All previous events showed up - I guess I was lucky in that sense.

    I deleted the new event, created a new one and imported the files back. Problem solved.

    Out of paranoia, I always back up my image and video files to an external drive before deleting them off the card, post iPhoto import. It paid off in this case. A monster external drive does wonders for making me feel more secure with my media.

    I would still like to see a fix for this, outside all the work-arounds suggested.

    Cheers
    15" MacBook Pro, Mac OS X (10.6.2)
  • timwaring Calculating status...
    I have a version of the problems described here that seems perhaps even worse. iMovie 09 has recently stopped showing ANYTHING in the event browser, save a camera icon, and a hard disk icon, both of which are empty. There is no 'iPhoto' library at all. Has anyone else had this level of problem? How should I address this? I rebuilt by iPhoto library, no luck. I trashed my iMovie prefs. No luck.

    Ideas?
    13' MacBook Pro, 2009, Mac OS X (10.5.8)
  • Eddie Level 1 Level 1 (20 points)
    I have the same problem as timwaring. No iPhoto library in iMovie at all!
    12 PowerBook G4, Mac OS X (10.4.2)
  • gooseberries Calculating status...
    My lucky day! Thanks to postings on this thread, I too turned off my music in my iphoto slideshows and then launched imovie and "presto" all my iphoto movies imported automatically to imovie just like in the old days! I'm assuming this problem happened when I updated to ilife09. As far as avi files, I have never had a problem with imovie recognizing these in imovie08.
    Macbook 4.1, Mac OS X (10.5.8)
  • Mike Reineck Calculating status...
    If removing music from all iPhoto slide shows doesn't do the trick, there might be a corrupt video file in iPhoto that needs to be isolated.

    Open iPhoto, use the search function to find .avi, .mov and any other video formats; move them to iPhoto's trash,not system Trash, and then add them back in to isolate the problem format, and then the file or files.

    Then in iPhoto Trash, restore other formats and non problematic files.
    iMac 3.06 GHz Core 2 Duo, Mac OS X (10.6.2)
  • cvdgenugten Calculating status...
    Hmmm.. I actually feel very silly posting this.

    Maybe it helps some of you though.. I never noticed the Show: All Clips pull down menu on the bottom left of the imovie window. I thought I had the same problem as many of you. Turns out this was set to Show Favorites and unmarked. All of my new imports were showing up but the ones I used already weren't. Which was all of them.

    I set it to Show all, and voilá, my problem was solved.. Silly me
    iMac 8,1, Mac OS X (10.6.2), Macbook Pro 13" SL iPhone 3G iPhone 3Gs
  • airless Calculating status...
    I had the same problem.

    But my solution was to empty trash in iPhoto.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.