3 Replies Latest reply: Oct 6, 2009 8:44 AM by ScottMcUK
Fung Mo Level 1 Level 1 (0 points)
Hi all,

One of USB port (next to "shift" button) of my macbook is disabled as warning of "drawing too much powr from computer".

I have tried to following methods to re-enable the USB port but all fail to do so.

1. PMU (remove battery and a/c cable then press power button for 5s and restart)
2. SMC (press option + "apple"key + P + R at start up for 3 times)
3. Press and hold power button for 10s at start up
4. enter safe mode (press and hold "shift" at start up.

could any one suggest other method to bring back the power of USB port?

Thanks!

Macbook 2GHz Intel Core Due 2GB DDR2 SDRAM, Mac OS X (10.6.1)
  • Fung Mo Level 1 Level 1 (0 points)
    I connect a wireless keyboard and mouse receiver (98 mA) with a USB hub (48 mA)...

    these are under 500 mA (max allowed of USB port on macbook)

    however sometime i will connect and sync iphone.
    on the screen of iphone also mention it could not charge with that device (USB hub)
    maybe this is the cause of overcurrent....

    BTW
    How can I identify the USB port is hardware (dead) or software problem (disabled by OS)?

    THANKS!
  • wai sing do Level 1 Level 1 (0 points)
    hey there fellow hongky

    im no expert, but have you had a look in system profiler if there are any clues? also try running techtool delux if you have it.

    failing that it sounds like it is an issue with the usb port (hardware) and not software related. take it to one of the service centres in hongkers. the one i use and recommend is senco masslink technology in wanchai. otherwise CASE in kowloon (they have online bookings available) .

    cheers
  • ScottMcUK Level 1 Level 1 (0 points)
    Same problem with my HP printer "device drawing too much power...". The printer is constantly offline and has a little power plug symbol next to it on the printer list, and like a little bolt of lightning on the printer icon in the dock.

    I think an SMU reset would sort it. I too have tried to reset the SMU like the OP, but have had no success. It's a really weird method to carry out, and the problem is you don't get any indication on whether you have conducted the procedure correctly. I mean, taking out the battery and pressing the power button for 10 seconds!!! Sounds like a wind up. They'll be asking me to stand on one leg and rub my stomach next!!!