9 Replies Latest reply: Feb 15, 2010 1:47 PM by tritoniadiomedea
sabor Level 1 Level 1 (5 points)
Snow Leopard has been the update with the least features that has given the most problems.

The latest I found out because my MBP is driving me nuts, the fan is ALWAYS turned on and CPU usage is insane. Two process are the culprits:

-Mingler
-iCalExternalSync (http://img.skitch.com/20090927-e7kux466ya6wdiayg7he1irky7.jpg)

Can someone please explain to me:

What on Earth is Mingler and why is it taking 84% of my CPU?
Why is iCalExternalSync taking all of my CPU? I have configured Mail with an exchange account, is this the price we pay?

Really going crazy with this update, really buggy even though I am at 10.6.1 now.

MBP, Mac OS X (10.6.1), I'm ******.
  • Nick Sharples Level 1 Level 1 (0 points)
    I'm having this same issue...

    Mingler was taking up 13.8GB of virtual memory. Right when I ended the process the fans on my MacBook Pro instantly turned down and things started running smoother.

    What's the deal? I've been having all kinds of issues ever since upgrading to Snow Leopard.

    Suggestions?
  • Nick Sharples Level 1 Level 1 (0 points)
    I'm having this same issue...

    Mingler was taking up 13.8GB of virtual memory. Right when I ended the process the fans on my MacBook Pro instantly turned down and things started running smoother.

    What's the deal? I've been having all kinds of issues ever since upgrading to Snow Leopard.

    Suggestions?
  • Graham Outterside Level 4 Level 4 (2,910 points)
    I've never seen an activity called Mingler - are you sure its part of SL and not a part of a third party application ?
  • sabor Level 1 Level 1 (5 points)
    So here is wat I did:

    I deleted my Exchange account, closed iCal, killed the iCalExternalSync, and I have never seen those processes again.

    @Graham: Maybe it's a process that gets activated when using an Exchange account, I had never seen it in my life until I started using Snow Leopard.

    I stopped using Mail and am using Mailplane, so if your problems persists, I'd recommend stop using Mail.app until Apple gets their sh*t together.
  • osultan Level 1 Level 1 (35 points)
    I just started having this problem a few days ago. It was preceded by a number of obscure sync errors that would not go away.

    Anyway, this is what I did, so far it seems to have worked:

    1. Go into Entourage Preferences and uncheck any sync-ing I was doing (in my case, the only thing I sync is calendars)
    2. When into Activity Monitor and killed syncserver, mingler, icalexternalsync
    3. Trashed ~/Library/Application Support/Sync Services
    4. Rebooted
    5. Went back into Entourage Preferences and re-enabled syncing of calendars can chose the option to over-write whatever was in iCal, MobileMe, etc

    So far so good....hope this helps,

    Omar
  • tmahn Level 1 Level 1 (0 points)
    Same probelem but I am not using Entourage/Exchange. I stopped publishing calendars and that seems to have gotten rid of the problem so far.
  • dias_se Level 1 Level 1 (0 points)
    Ok!

    This may solve the problem.

    For me there was two parts:
    1: While synchronizing with mobileme two processes went rampant. Mingler and Syslogd.
    2: The logfile "system.log" grew between 1 and 2 Gb every time I synchronized (at the time of discovery it was 30 Gb).

    Cause:
    Probably a poorly programmed external iCal calendar (for me swedish holidays) that I earlier had thrown away.
    This calendar was only visible in my iPhone as part of my mobileme calendars. But it was NOT visible when logged in to mobileme or in my computers iCal.

    My solution was to replace all calendars on everything with the ones at my main computer.

    1: In your iPhone: Turn of iCal synchronization with mobileme. When asked - erase all.

    2: Clean out iCal in your computer (prefs etc, leave the program). The way I did it was by using AppDelete. The program does not erase everything so i actually got to keep all my appointments). Throw in trash - restart - empty trash.

    3: Overwrite all iCal data at mobileme with the data on your computer's iCal.

    4: For extra safety I also did a synchronization with the phone via iTunes where I overwrite all calendars on the phone. Note! When connecting the phone to the computer emedeatly stop all synchronization.

    5. Pick up the phone and turn on synchronization with iCal again. When asked merge all data.


    Now! If you still have the extra large system.log file you can get rid of it using Disc inventory X. thus the file in question is invisible. You find it here: /private/var/log/system.log

    Move the file to trash - restart - empty trash.


    This was my solution to stop Mingler and get my hard drive back. I take no responsibility what so ever for anything. If your Mac explodes after this don't come to me and complain.
  • Roger Tang Level 1 Level 1 (5 points)
    I had a similar problem and I traced it back to an insane amount of duplicated ical entries (something like 36,000 dupes). Used ical dupe deleter and that solved the problem. This suggests a possible calendar problem (corrupted or too many dupes or entries that are being synced).
  • tritoniadiomedea Level 2 Level 2 (385 points)
    Your suggestion worked. I used iCal Dupe Deleter and removed over 12,000 duplicated calendar events. I then reset my MobileMe and wrote over my MobileMe info with my local computer info. Problem has gone away and I do not see Mingler much now. Also, syncing only take a minute or so, and before it was taking 20 minutes.