Previous 1 2 3 Next 88 Replies Latest reply: Dec 2, 2013 5:40 AM by WonkaUtrecht
MattIseman Level 1 Level 1
My laptop HD was dying, so I replaced it. Rather than doing a full Time Machine restore, I decided to upgrade from Leopard to Snow Leopard and just start all over and streamline my laptop dragging and dropping most documents from old manual backups, but the iPhoto library is the one thing that is only backed up on Time Machine.

Because I renamed the laptop and it's a fresh install, when I click on iPhoto and go to "Browse Backups" it does not go to my original iPhoto library backup.
If I navigate to the backup I want using the Finder to go through the Time Capsule, when I click on the iPhoto library and choose "Restore to..." I get the message "The operation can’t be completed because you don’t have permission to access 'iPhoto Library'."

If I simply drag the folder to iPhoto I get: "The iPhoto Library is a Time Machine backup, and so cannot be used as the main library. Relaunch iPhoto with <option> key held down to choose another library."

I have tried to check the permissions (get info) on the Time Machine and that folder, but I cannot see anyplace where my permission would be limited.

Anyway, looking for anyway to restore just the old iPhoto library from Time Capsule to my fresh laptop installation.

MacBook Pro/ Mac Pro Dual Core, Mac OS X (10.6.1), Time Capsule 500MB
  • ChristiaanW1 Level 1 Level 1
    I'm having this problem too, on Snow Leopard
  • davidmarc Level 1 Level 1
    I screwed up my iPhoto library so tried to recover it from TM. I get 3 Gb copied (out ot 18 Gb) and then get *"+The operation can’t be completed because you don’t have permission to access “iPhoto Library”+."*

    I tried to change permissions on the TM backup drive via Get Info ➔Sharing and Permissions but that didn't fix it either.

    Dragging the folder from the TM BU drive on the appropriate date gives the same error message.

    ANy thoughts on how to proceed?
  • Benjamin Taylor2 Level 1 Level 1
    Unfortunately I have the same problem too. Get 4.53gb through 33gb restore and get the "operation can't be completed ...." message. Any ideas on how to resolve?
  • azcahill Level 1 Level 1
    Unfortunately, I am now also in the same boat. Luckily I had a Super Duper image from my Snow Leopard install that I can get back so I'll only be without the last 45 days. Whew.

    I spent more than 2 hours trying to get one of the TM backups to complete. I will be waiting with great interest to see what the ultimately resolution is.
  • William Boyd, Jr. Level 6 Level 6
    MattIseman wrote:
    Anyway, looking for anyway to restore just the old iPhoto library from Time Capsule to my fresh laptop installation.

    Click-and-hold (or control-click) on the Time Machine icon in the Dock, then choose "Browse Other Time Machine disks". That should allow you to access your iPhoto library from your old Time Machine backup.
  • Wolfgang Matzl Level 1 Level 1
    I'm in ...
    same problem for me, my library causes iphoto to crash at startup, no way to restore it with time machine due to permissions. stops after 2,54 gb instead of restoring the whole 48 gb.
    with iphoto library manager i was able to rebuild the library but i'd have to make all albums again and rotate the photos and and and ... and miss my calendars and books
    i don't understand why time machine does not what it is supposed to ... very annoying issue !!!
  • geoban Level 1 Level 1
    I was having this same problem when I found this thread last night.

    I've come up with two solutions that seem to be working.

    1) Right click on the iPhoto Library you want get at in Time Machine and Archive it - then move that .zip folder over.
    2) Log onto your computer from another computer over your home network and locate the iPhoto Library you want to get at and transfer it.

    In my case I had a 49.28 gig iPhoto Library - the transfer takes about 9 hours.

    Good luck.
  • ottawaRob Level 1 Level 1
    "The operation can’t be completed because you don’t have permission to access “iPhoto Library”."

    seems odd that no one has a solution to this. can this really be happening to us? I have about 100GB of photos that are quite valuable. without a solution they are gone!!!

    I thought Time Machine was supposed to insure that you'd not lose your data?

    this has to be fixed, like NOW!
  • sbrand Level 1 Level 1
    I had this same issue today, but solved it on my second call to Apple. The solution, at least for me, was to restore not via the finder, which crashes partly thru the restore with the "permissions" error, but accessing Time Machine via iPhoto instead.

    The tech had me create a totally new, blank iPhoto library in the same folder where the one I want to restore from Time Machine is located. For most people, this is in the Pictures folder, but because of earlier mistake, mine was nested in the Pictures folder within the top level Pictures folder. This solution didn't work until we got that right.

    Once this is created, leave iPhoto open in the new library with zero pictures, then enter Time Machine. Time Machine opens magically from the iPhoto portal, rather than the Finder portal that I was used to. Select the restore point along the right hand timeline, as usual. All your photos are there, and you can restore events, albums, or photos. In my case, I needed to Restore All. Worked like magic, and didn't get stuck part way thru the way it does when restoring from Finder.

    Worked for me, hope that helps.
  • Peter Biffar Level 1 Level 1
    After hard drive replacement, I noticed that Time Machine did not restore the iPhoto library. I then tried to restore just the library, but after restoring about 2 Gigs out of 50gigs, I run into the above "permission" message. I reinstalled iPhoto 09, plus updates, no success.
  • Cocoa.Bean Level 1 Level 1
    Thanks a lot for the tip.

    I had deleted a user's account but they then later said they wanted to get their photos back. I tried to open their original iphoto library saved on the time machine disk but OS would not allow it. I even changed the read write permissions of the backup folder after drilling down through
    TimeMachine Disk>backups.backupdb>....>Macintosh HD>Users>Username>Pictures>iPhoto Library, but it still wouldn't open.

    I followed the tip to create a new iPhoto library by Option clicking iPhoto, creating a new library and naming it with the old user name. As described this presents you with a blank iPhoto collection which you can then 'import to Library' by going through roughly the same steps above, drilling down through the TM disk but stopping at the user's Pictures folder. Click 'import' and magically iPhoto pulls in all the archived photos. How cool is that!

    From here I moved the new iPhoto Library-username to the Shared folder allowing the user to get to their pictures again.
  • Pupsicle Level 1 Level 1
    My iPhoto Library corrupted on vacation. Whilst I did have copy of my photos of South Africa on the camera chip still, I did not want to lose history already built up.

    I got the smelly "The operation can’t be completed because you don’t have permission to access “iPhoto Library” error when simply trying to restore from TM.

    I suspect this is due to the fact that my current user account, including user name, is different to that used to name the Home folder. My account name on my old iMac was there when I used TM to transfer all of my data from that old machine, but I had (probably foolishly) created a new account name on the MB in my excitement to play with the new toy. This was then compounded by me deleting the old user name in a fit of stupidity... Lesson learned!

    I tried changing the access rights on the Home folder and the Photos folder to allow my new user name read/write acccess but failed here.

    Following some of the suggestions in the other posts I deleted the old iPhoto Library files in the Photos folder and let iPhoto create a new blank library for me. This was named _2 but I renamed the library to match that in my TM backup.

    Entering TM whilst having iPhoto and the blank library as the active item did indeed boost me straight into the iPhoto backups where a quick restore all brought all of the history back.

    Wow, problem solved (I hope!).

    On an aside I suspect the corruption occurred through me inserting the SDHC 16Mb camera chip into the card reader on the MB Pro. For the first few times the card was automatically detected by iPhoto and photos quickly loaded. Later in the week the chip showed up in Finder but did not show in iPhoto so I dragged the new photos across to get them in the library.

    All I have to do now is to figure out how to realign my user accounts and privileges to avoid the same problem later...

  • Holy Fire 001 Level 1 Level 1
    Hey guys. This is super easy and we're over-complicating things.

    Two simple things have to be true for this to work (import an old iPhoto library to your new hardrive)

    1) You have access to your Time Machine backup folders in Finder, specifically the pictures folder:

    /Volumes/(name)-Time Machine/Backups.backupdb/(name)/(date)/(name)/Users/(name)/pictures

    2) You then COPY ALL contents from that Pictures folder into your CURRENT pictures folder on your new hard drive. NOTE: You must keep all directories, folder, and file names and arrangement EXACTLY the same, for now. You can re-arrange as necessary once you're completed the import.

    3) Now, you should have also copied over the file "iPhoto Library" or whatever your old library name is, to your new pictures folder.

    4) Hold down Option and click on the iPhoto icon to open the application.

    When the "Which library do you want to use?" screen pops up, select the "Open Other" option.

    5) Allow iPhoto to load your complete library.

    6) Done!

    Hope this helps.
  • Dave Lentz Level 1 Level 1
    I too, attempted to restore my iPhoto library from a Time Machine backup, and received the "don’t have permission to access 'iPhoto Library'." notification of failure. Looking at this thread, it goes back into 2008 ... not a very hopeful sign. And of course, the restore having begun, the old library is now toast.

    Pretty bad when the data recovery tool nukes what you started out with.

    I am unable to get this to work, whether iPhoto is running or not when Time Machine is invoked. Anyone having DETAILED instructions on exactly how to get Time Machine to restore individual photos through iPhoto instead of a bulk replacement via the Finder is encouraged to post them.
Previous 1 2 3 Next