Previous 1 2 3 4 Next 88 Replies Latest reply: Dec 2, 2013 5:40 AM by WonkaUtrecht Go to original post
  • Király Level 6 (9,635 points)
    Try enabling the root account, log in to it, and see if Time Machine will let you restore the iPhoto Library then.
  • Dave Lentz Level 1 (20 points)
    I managed to recover my iPhoto Library, by mounting the sparsebundle Time Machine disk image, then drilling down to the day I wanted to restore from, locating the iPhoto Library bundle, and copying it into a working folder by positioning the working directory (cd) in the Time Machine directory containing my backed-up library, and using a "sudo cp -Rp iPhoto\ Library" command to copy it into the target working folder. Then I simply dragged it into the Pictures directory via the Finder.

    However, the recovered library bundle has apparently brought whatever lock is in place with it, as iPhoto cannot open it, claiming:

    The iPhoto Library is locked, on a locked disk, or you do not have permission to make changes to it. iPhoto can try to repair the permissions.

    And iPhoto of course is unable to repair the permissions. I suspect this is all due to Time Machine slapping some metadata onto the contents of its archives, and nobody else in the OS X world being aware of this, so that Finder cannot perform the restores when Time Machine asks it to, and if one forces a copy via the "big hammer" of Terminal command-line commands, the copied file still retains the lock, so that iPhoto is unable to get at the contents either.

    Obviously, this is not a solution. I am returning to the fray ...
  • Király Level 6 (9,635 points)
    Try these Terminal commands on it (assuming "davelentz" is your account's short user name):

    sudo chown -R davelentz (hit spacebar, drag iPhoto library into Terminal window, press return)
    sudo chmod -R -N (hit spacebar, drag iPhoto library into Terminal window, press return)
    sudo chmod -R u+rwX (hit spacebar, drag iPhoto library into Terminal window, press return)
  • Azamat K Level 1 (0 points)
    Thank you!
    Now I can open my iPhoto 09 without any problems.
    You really help me!
  • zivzed Level 1 (0 points)
    I'm newly stuck at this point, and none of the solutions listed have helped. any advice?
    -200gb iphoto library is corrupted, instructed to use a backup. 10.6.4 iphoto 8.2
    - TM won't restore due to an access privileges error that occurs 18.5 gb into the restore (regardless of which date of TM backup I try).
    -Tried direct import from TM into a new photo library, failed with 14k pictures to go.
    -Cannot create a new blank library within a TM picture folder (not enough privileges to access TM error)
    -tried archiving/zipping whole iphoto library from TM; it stopped at 120+gb after 20+hrs.
    -Apple support had no answers to date

    sincere thanks for any help...
  • David Porter9 Level 1 (115 points)
    I've joined this thread after encountering the same 'permissions' prohibition about 10% of the way into using my Time Machine backup to recover iPhoto 9 library disappearance. I've used the suggestion to create a new iPhoto library, leave it open, trackback in TM to the desired folder of the same name, and then to ask it to restore. The window in TM has been open for about six hours now with a spinning progress wheel saying 'loading photos'....but the result is a blank screen.

    Any ideas? I suspect there may be a missing step in the instructions farther back in this thread.
  • David Porter9 Level 1 (115 points)
    Update on my post from 8-18 evening.
    I stopped the attempt to restore with a new iPhoto Library file. There was no evidence that anything was actually happening.
    I looked back at other suggestions earlier in the thread. This morning I created a zip file of the archived iPhoto Library in TimeMachine and dragged it to my desktop, then copied to an external drive with plenty of space. I'm now trying to unzip the file. The file size and permissions appear to be appropriate. Any thoughts or suggestions would be appreciated. If this doesn't work I'm going to try the iPhoto Library Manager software and just build a new file.
  • zivzed Level 1 (0 points)
    Struggled with this selfsame disaster for some time. Tried all prior suggestions, moved library to external drives, reimports etc, copies, restores. All failed, somewhere at 18gb into the 200gb iphoto re-import.

    What worked: iphoto library manager. It simply rebuilt the entire library and folders and thumbnails from the old library, which i had copied off time machine to another drive. Took a day, but done. Required a lot of sitting by it, as it encountered 'unable to import' file errors along the way, but am back to near complete success.

    Strong recc for this.
    good luck.
  • David Porter9 Level 1 (115 points)
    Thanks for the response. I'm still hopeful. I pulled a zipped file of the Time Machine archived library when it was last intact onto my desktop but discovered I couldn't extract it---not enough space on my disk. So I copied it to an external hard drive where it did extract and appeared to have the correct size, permissions, etc. I am now importing the unzipped file back into my Pictures folder. It's about halfway done and hasn't faulted yet. Keeping my fingers crossed.
  • David Porter9 Level 1 (115 points)
    Last update! Hurray! The transfer off the External Hard Drive of the unzipped iPhoto Library file completed. I opened iPhoto and everything-albums, thumbnails, pictures, events, and books, etc.
    was there! Hope this may help someone else. Look through the preceding three or four threads.

    Best of luck.
  • bhbarto Level 1 (0 points)
    I can confirm that this does in indeed work. Thanks.
  • flory72 Level 1 (0 points)
    Hey! I had the same problem and was looking for help in this topic but I just found a solution. When you have the iPhoto application open, go to File and at the bottom of the options list there's the option to "Browse Backups" it opens Time Machine where your photos are. Sadly, I forgot to backup lately so the photos I needed weren't found but I hope this helps someone else.
  • Jcweez Level 1 (0 points)
    After installing iLife '11, my iPhoto library shrunk from 27G to 4.7G, almost of the original photos disappeared except the thumbnails, the iphoto is running so slow and freeze most of the time. I try to restore it from time machine but after 4Gb of transfer, the "operation cannot be complete because you don't have access to iphoto library" prompt came out, what I did was, went to the iphoto library of time machine and zipped it to the desktop then unzipped it, trashed the original iphoto library and transfer the unzipped library to picture folder on the side bar. it works and the iLife '11 is now running smoother. hope this helps
  • Evan Wiener Level 1 (5 points)
    I had the same problem with iPhoto '11. I tried using Time Machine to pull an old iPhoto Library from before the iLife '11 install, but it gave me the permissions error. I'm trying to compress the Library from the time machine drive to a zip on my desktop.

    Should I run the to grant proper permissions for iPhoto on this old Library before running iPhoto '11 to import it?
  • William Boyd, Jr. Level 6 (10,515 points)
    Evan Wiener wrote:
    Should I run the to grant proper permissions for iPhoto on this old Library before running iPhoto '11 to import it?

    You could, or you could probably just use the Finder to set the permissions. All the files in my iPhoto library see to have permissions of me: Read & Write; everyone: Read & Write. Pull down the gear icon in the lower part of the "Info" window and choose "Apply to enclosed items".

    By the way, there's an update out that you're supposed to apply to iPhoto before you open it the first time.
Previous 1 2 3 4 Next