Previous 1 2 3 4 5 6 Next 88 Replies Latest reply: Dec 2, 2013 5:40 AM by WonkaUtrecht Go to original post
  • Stan Fisher Level 1 Level 1 (0 points)
    As I understand the situation, from the assistance of a more knowledgeable forum person than myself, the problem is not the ownership as set in iPhoto, but rather that Time Machine takes root ownership of iPhoto libraries stored within it. It won't allow you to transfer iPhoto libraries back to your Mac, bizarre as that circumstance seems to me. One way to get around the problem is to compress the library as a .zip file, which automatically downloads to the desktop and from there can be transferred back to iPhoto.
  • bj5411 Level 1 Level 1 (0 points)
    I had similar problems. After upgrading to iPhoto 11, the application was extremely slow and was even freezing when I tried to use the "Create Card" function. I tried to restore my old library from my Time Capsule but I got the ".. you do not have permissions..." message. I tried several of the proposed solutions in this thread (font removal, boot in safe mode, etc.).
    The ONLY solution that worked for me was the zip and unzip solution discussed in this thread, Iphoto 11 seems to be working well now, including the create card function. It took a while to do the whole thing because of the size of my library.
    I think Apple should look at all these issues and come back with some better solution than leaving us in the cold.
  • William Boyd, Jr. Level 6 Level 6 (10,515 points)
    Stan Fisher wrote:
    the problem is not the ownership as set in iPhoto, but rather that Time Machine takes root ownership of iPhoto libraries stored within it.


    Perhaps so, but I was suggesting that permissions change technique as something to use after the iPhoto library was retrieved from the Time Machine backup, using whatever technique worked to do the retrieval.
  • mercury girl Level 1 Level 1 (0 points)
    I had to erase my hard drive, and the Apple genius told me not to restore all my data lest I reproduce the issues that led to my laptop's poor performance issues. So I had to restore individual files back onto my laptop.

    I had the same problem with being unable to restore my iPhoto library from my Time Machine backup due to a "permissions" error. I solved it by locating the version of my iPhoto library I wanted in my "Time Machine Backups" via the Finder (not by entering the Time Machine). Then I compressed the iPhoto library via File:"Compress iPhoto library". The zip folder was saved on my desktop. Then I moved the zip folder into my User:Pictures folder, and decompressed it in the Pictures folder. It becomes "iPhoto library 2". Click on it, and it will ask if you would like to open it in iPhoto. [Make sure you do not already have iPhoto open.] Say YES and it becomes your default library. All of my albums were also intact.

    Good luck! Figuring this out was ****.
  • Spencer Swift Level 1 Level 1 (5 points)
    sbrand - it doesn't seem anyone else commented on or noticed your message, but I have to say THANKS! That was the trick for me as well.

    I was rebuilding a new boot drive after my old one failed. I had a good backup, but not a bootable backup, so I was restoring off Time Machine in stages. Most things worked fine launching Time Machine from the Finder, but not iPhoto. I got the same "permissions" error after copying roughly 1.5 GB of 17.0 GB.

    After reading ALL the responses on this thread and some others, your's was the simplest, so I tried it first. Worked perfect on the first try. All 17 GB in one shot.

    People - I suggest you at least try this method before you go to the trouble of some of the others.
  • nwriko2 Level 1 Level 1 (5 points)
    please help

    i'm embarrassed to admit that i do not seem to be able to "zip a file" inside time machine. "geoban" who originally came out with this solution says to right click on the iPhoto library but when i do so i do not get the compress option which i normally get when i'm not in time machine.

    can anyone help?
    "sbrands" solution mentioned by "Spencer Swift" doesn't work for me because my iPhoto doesn't open at all!

    thanks

    Message was edited by: nwriko
  • nwriko2 Level 1 Level 1 (5 points)
    just in case i wasn't clear enough in my explanation, "David Porter9" on this thread page 2 wrote :

    "I pulled a zipped file of the Time Machine archived library when it was last intact onto my desktop"

    how can that be done? (a normal restore don't work due to "permissions")
  • Pondini Level 8 Level 8 (38,720 points)
    You don't do that via Time Machine, but the Finder.

    See the tan box in #E9 of [Time Machine - Frequently Asked Questions|http://web.me.com/pondini/Time_Machine/FAQ.html] (or use the link in *User Tips* at the top of this forum).
  • couto27 Level 1 Level 1 (0 points)
    plug the hard drive to mac

    in finder just go manually to your external hard drive (backups time capsule ) until

    finder > your external hd > backup > latest >macintosh hd > user > your name >image > iphoto library

    copy and paste to your mac and open voila fixed
  • signalius Level 1 Level 1 (0 points)
    I bunged up my iPhoto library by having it on the same external partition as my Time Machine Backups and then creating a folder for it, moving it into that folder, getting some nasty error message, changing the permissions from _unknown to admin read/write, and then spilled a beer on my keyboard. After trying a lot of these suggestions plus using iPhoto Library Manager software to no avail, I tried importing the library into Aperture 3 and... it's working

    But it's going to take a while. I'll post back with the final results.
  • signalius Level 1 Level 1 (0 points)
    Yep, that seemed to work. But it took a long-*** time. Aperture 3 takes a great deal of RAM when it's doing something like this, up to 3 gigs. patience is not something I'm known for and I like to interrupt system processes when I think they're hanging up and not working, usually with disastrous results.
  • Gubbz Level 1 Level 1 (10 points)

    I too had this problem and I've found the simplest solution imaginable. Take note, if the idea of rebuilding your iPhoto library is only slightly better than gnawing off your own arm, then this is not for you, BUT it did get back ALL my pictures, all 22,000 of them.

     

    1. Open up iPhoto and tuck it to one side, clearly able to see the left-hand side bar.
    2. Open up your time machine disk and navigate to the iPhoto library you need.
    3. Drag the iPhoto library into the Photos section of iPhoto (I suspect there are many variations that work for this last bit, but I wasn't going to go stopping it importing my pics)
    4. Wait while it imports everything that was previously stored (and I mean everything)

     

    It's not an individual importer, not is it a nice and elegant solution at restoring the way it was, but it is a simple solution for those struggling with restoring from a Time Machine backup.

  • AliGators Level 1 Level 1 (0 points)

    In my zeal to clean up and clean out my hard drive, I managed to fully and completely delete my iPhoto library. Brilliant. 

     

    Sbrand, I thank you for posting up your experiences and solution. I followed your guidance and within a very short amount of time, had fully recovered my pictures, events, faces and places.

     

    Thanks again!

  • Easygoingchap Level 1 Level 1 (0 points)

    That's a simple and brilliant solution... Thanks mate...

  • Gubbz Level 1 Level 1 (10 points)

    Another simple one (bit tidier than my last one) is to again locate the old iPhoto Library that you can't restore with Time Machine, get iPhoto to restore it or simply told you don't have the permissions to allow you to copy it.

     

    1. Locate the Time Machine iPhoto Library on your backup disk

    2. Right click / CTRL click and select 'Show Package Contents'

    3. Open 'Masters' folder

     

    You can now see all the folders of iPhoto images by Year > Month > Day they were taken (I think, or edited, I am unsure), so you can just drag the folder of images into your new installation of iPhoto. I just dragged the Masters folder, but if you only needed to restore the pics of a particular year, month or day, then that's up to you. This way compared to my previous is nicer in that you don't get the multitude of duplicate images iPhoto uses for Faces etc

     

    Masters > 2011 > 07 > 08 would be photos from 8th July 2011, nice and simple