Previous 1 2 3 4 5 6 Next 88 Replies Latest reply: Dec 2, 2013 5:40 AM by WonkaUtrecht Go to original post
  • Martin Cooper Level 2 Level 2 (155 points)

    Yes it opens a library but how do I save it to continue to use it. It is only the backup for that date and you cannot add anything to it.

  • Chris Portle Level 2 Level 2 (335 points)

    geoban wrote:


    I was having this same problem when I found this thread last night.

    I've come up with two solutions that seem to be working.

    1) Right click on the iPhoto Library you want get at in Time Machine and Archive it - then move that .zip folder over.
    2) Log onto your computer from another computer over your home network and locate the iPhoto Library you want to get at and transfer it.

    In my case I had a 49.28 gig iPhoto Library - the transfer takes about 9 hours.

    Good luck.


    Good solutions.  Both worked for me, though option 1.) was much quicker and option 2.) only worked when a Windows PC accessed the TimeMachine backup. 

  • barnz1 Level 1 Level 1 (0 points)

    Thanks for the more simple instructions, which worked for me.  However I did get an odd situation: when I tried to open the "new" library, I got an error message saying that I had to update iPhoto to the current version, because the old version couldn't handle this.  Once I upgraded to iPhoto 11 (also known as version 9) I was able to open the "new" library, but was immediately greeted with another dialog box that informed me I had to perform an update on the library to be compatible with the new version of iPhoto I was now using!  Seemed a bit of a waste of $15, but in the end it all worked, so no real complaints.

  • deano3500 Level 1 Level 1 (10 points)

    This discussion has been very helpful for me.  I experienced the same problem with Time Machine "permission" and was unable to restore the Library completely. It did restore partially but only thumbnails and lots of what I assume are face identification thumbnails used by iPhoto itself - but none of the real photos that were in the Library.


    Anyhow I did what seemed to be the simplest concensus arising from this discussion:

    1. Create archive Zip file from within the Time Machine Finder. This ends up on the Desktop.

    2. Move to the target Pictures folder and unzip.

    3. Upgrade the Library as iPhoto requests to ensure compatibility.


    Everything worked fine.  Many thanks to all for the insights.

  • egon1984 Level 1 Level 1 (0 points)

    I found a solution which is the best one, in my opinion: just enable FTP sharing and access your Time Machine drive through FTP (you can do this locally, there's no need to have another computer), then you can copy/paste/drag items in the Finder as usual. Nothing more.

  • Peter Wepplo Level 1 Level 1 (15 points)

    This seems like a good idea. How do you do it?


    Do you turn off AFP sharing? What other sharing do you turn on? What application do you use to connect to your local host? How do you connect to your local host from your local host? Do you manage TimeMachine, start TimeMachine, or simply copy the TimeMachine file?

  • Peter Wepplo Level 1 Level 1 (15 points)

    This is a fairly common problem. You can find similar discussion under Leopard and Snow Leopard disucssions if you "Refine List". Then you can click on TimeMachine and then click on the permission tag. I thought I was going to have resolved my issue, but my library was rather large and I realized that I would not be able to have an archive and the unarchived library on my internal hard disk at the same time. I am still hoping for a simple and safe solution.


    This is also what I am advocating,

    Provide feedback:

    Subject: TimeMachine iPhoto Library Permissions error


    This was my suggestion:

    I have encountered the TimeMachine iPhoto Library permissions error. I have also found this to be a fairly common subject in the Apple support pages.


    This is what I wish was a solution to the TimeMachine iPhoto library permissions error. Because this is a permissions error, I wish I could open TimeMachine and repair the permissions with Disk Utility. I wish to see an analogy to the use of TimeMachine within iPhoto to access your TimeMachine library to restore it.


    Perhaps if others made a similar request, a simple and safe solution could be found.

  • egon1984 Level 1 Level 1 (0 points)

    I just enable FTP and then I connect via the Finder: then I'm able to copy/paste/drag files/folders.

    (Time Machine manages only wired hard drives or Time Capsules, not ftp directories, so my solution just works with the Finder... but it works  )

  • Peter Wepplo Level 1 Level 1 (15 points)

    I just tried the FTP solution (I think) suggested by egon1984. This is what I did. I went into system preferences and change sharing from AFP to FTP. I connected to my external TimeMachine disk, open the backup and using the finder copied the library over. This began as it had in the past, but then aborted at the usual place with a file permission error message.

  • egon1984 Level 1 Level 1 (0 points)

    How did you connect to Time Machine? This is what I do: from the Finder menubar I select "Go > Connect to server..." and then I type something like "". I mean: I DON'T access Time Machine directly as asual, but I access it passing through the FTP protocol.

  • Peter Wepplo Level 1 Level 1 (15 points)

    The FTP method did not work. This is what I found. I was able to connect via Then I clicked down to the backup I was trying to bring over. At first I just tried the entire directory. After I waited for it to determine the number of files to copy, it began to hang up. Error VQ_NORESP. I then began to break it up into smaller pieces and then I began to get the permission error. So, I don't think that was going to circumvent the permission errors.


    I think my current method, though tedious, is actually going to succeed. First, I just did a restore from TimeMachine. This copied over a number of files until it hit the permission errors. That was the easy part. I think opened my TimeMachine backup file, show package contents, and then began copying groups of folders. Sporatically, I again encountered a permission error and the remainder of the folders would be empty. I opened the folder containing the permission error and copied the individual files. The Finder asks for my password and then it copies them to my hard disk. I double check to see that each folder matches the same number of files and size as the original. 


    I don't understand the permission errors. Looking at individual files, they have the same permission setting as other files. 

  • egon1984 Level 1 Level 1 (0 points)

    Of course, our situations are different (even if we got the same error). I had that issue since Time Machine birth: yesterday I was able to prevent it by that ftp trick. I'm not sure if it always works (...and I trust your experience, so that trick is not a definitive solution) but, since it worked perfectly for me, maybe it'll work for someone else. 

  • Peter Wepplo Level 1 Level 1 (15 points)

    A further update on the permission error issue.


    First, I agree with egon1984's comment on the errors, they may well have been different types of errors. Clearly the permission is not the ownership issue. I am guessing that some of my files have been edited with Photoshop and this is leaving some residual flag. Furthermore, I think strategies I have successfully used are similar to the ftp transfer method and succeed in circumventing the problem in a similar way.


    Since I had upgraded to iPhoto 11, I did succeed in restoring my earlier iPhoto 9 library. I did this with a combination of TimeMachine, ftp the files in a folder with an error (this asked for password but brings over all of the files, though in a tedious manner), and then with File Synchronization to bring over missing files (because the ftp method might meet a permission error in the middle of a folder). After all of this, I did succeed in restoring my iPhoto 9 library. However, I discovered my missing places were also missing in my most recent backup as well. I decided to abandon iPhoto 9 and return to my iPhoto 11 library.


    The ftp method let me look at the permissions of the individual files that stopped the ftp transfer process from the folder level. I could not discern why they should stop transfer. I believe the reason was the same as was stopping the TimeMachine transfer. When I tried the File Synchronization app, I was expecting that it would locate missing files. I discovered that it succeeded in transferring the files without my entering a password. Ah, interesting!


    For my final restore of my iPhoto 11 library, I used a different program that uses the TimeMachine backup, namely Back in Time. This restored my iPhoto library almost as I had expected from TimeMachine. Opening this restored iPhoto library gave an error message saying that this library could not be opened. That was because it pointed to my TimeMachine file. I used iPhoto Library Manager to delete the TimeMachine backups listed in iPhoto and restarted iPhoto pointing to the default library. This worked.


    Conclusions: I believe TimeMachine has a bug that prevents it from restoring iPhoto libraries as we should expect from a backup program. That is the source of the permission errors. It appears as though there are several work arounds to this basic error which include ftp transfer, archive and unarchive, other transfers programs, File Synchronization, Back-in-Time, and perhaps others. I remain convinced that the most suited solution is to report to Apple this bug ( and hope they resolve this problem.

  • taylorfromca Level 1 Level 1 (0 points)

    Guys... Check out this thread on how to unlock time machine files and folders that are denying access. I didnt use it for iPhoto because I don't use iPhoto. However, it worked on every locked folder I tried it on. Hope this helps!


  • Buddy-B Level 1 Level 1 (0 points)

    After trying many other approaches, yours finally worked!!!  Thanks so much.  I was about to reformat the hard drive and restore everything from time machine.