Previous 1 2 3 4 5 6 Next 88 Replies Latest reply: Dec 2, 2013 5:40 AM by WonkaUtrecht Go to original post
  • rk82 Level 1 Level 1 (0 points)

    Hi, by reading through the posts I am not entirely sure if any one has been able to restore their iPhoto library.


    I found myself in the same position and was getting the permissions problem when trying to restore from Time Machine. I have worked out that the only way to restore is to navigate to the Pictures folder and restore that folder rather than trying to restore the actual library itself.


    I hope this info is of use to you folks.

  • Paco Level 4 Level 4 (1,365 points)

    Yes, I found that worked for me as well, as I mentioned in my earlier post. It's good to know that it worked for you as well.

  • asquires13 Level 1 Level 1 (0 points)

    This solved my similar problem with my Aperture library. After unzipping the archive that I created of the Apertyre library I still had to repair permissions by holding down Cmd + Alt when double clicking on the un-zipped library.

  • Faulty Towers Level 1 Level 1 (0 points)

    Did the trick, thank you.

  • Scott Harper1 Level 1 Level 1 (15 points)

    RK82, Thanks.  I thought I had lost 28000 pictures.  I had been unable to restore them from TM backup.  Restoring the entire picture folder did the trick, though.


    I think I still have a messed up photo library.  Anytime I make a new project, it disappears next time I launch iPhoto.

  • vsteiger Level 1 Level 1 (0 points)

    Brilliant! Thanks so much rk82!

  • jap0nica Level 1 Level 1 (0 points)

    My problem is somewhat more complicated and I wonder if anyone can advise me. Apparently I made changes to my iPhoto Library using a newer version and I am now unable to even open it. This applies to not only my HD copy of iPhoto, but also the one on my external drive.  When I tried to use Time Machine to restore, I got the annoying "you don't have permission" message.... but I also noticed that the size of my iPhoto library (no matter what date I choose) is ZERO.  What happened to my photographs?  I was going to take my Mac in for servicing, but I don't want to waste my money if nothing can be done.

  • Pondini Level 8 Level 8 (38,715 points)

    jap0nica wrote:

    . . .

    but I also noticed that the size of my iPhoto library (no matter what date I choose) is ZERO.

    That's not unusual for an item you don't have permission to read -- the Finder won't show you it's size, either.


    Have you tried the things in #E10 of Time Machine - Troubleshooting?

  • jap0nica Level 1 Level 1 (0 points)

    Thank you! That is most encouraging. I thought that no size meant that the contents were gone. I took a look at #E10. While I am capable of following straight-forward instructions, I feel that this potential fix is too complicated for me so I will be taking my Mac in for servicing.  Thanks again.

  • lgndry Level 1 Level 1 (0 points)

    The best way around these issues is to copy the iphoto or any other file you are having this issue with to another drive. Go buy one from Best Buy or Staples and format it with eXFAT through the disk utility (applications\utilities\disk utility). eXFAT will strip ALL permissions from the file and you can then open it from that drive (option key held down when you click iPhoto to choose and browse to the eXFAT drive) and do a repair to the database. Once you are happy everything is there, delete your original iPhoto database in Pictures and copy this "new" one back in it's place.


    You can then use this drive to copy files to and carry it around or as a second form of backup. Another benefit is that you can now use this drive to transfer files to/from Windows machines with no issues as both Windows and MAC read eXFAT drives (Windows XP SP3 and up).

  • cbondie Level 1 Level 1 (0 points)

    I had a corrupted iphoto 11 libray.


    I looked at many posts as to how to restore iphoto from TimeMachine. There is apparently a glitch in TimeMachine that will not let you restore the library.


    As many people mentioned, I kept getting the "The operation can’t be completed because you don’t have permission to access “.


    I worked a week trying to figure it out. I tried everything, including compressing the file from TimeMachine to try to put it on the desktop, and rebuilding the library, among other recommended fixes. Nothing worked.


    Finally, it occurred to me that I have another copy of all my photos on another computer. I used my external drive  to make a copy of that library, and then I transferred that library in its entirety to the machine with the corrupted library. I then opened the good library, and eventually threw away the corrupted one.


    Therefore, the only solution I have is to not use TimeMachine to make a backup of iphoto. Manually make a copy of your library.


    Luckily, I was able to salvage all of my photos and I will make sure I have my backup up to date on my external drive.

  • jap0nica Level 1 Level 1 (0 points)

    Well, my Mac repair shop was able to retore my photo library using Time Machine.  I don't know how they did it, but they obviously had the expertise.

  • GlobalScot Level 1 Level 1 (0 points)

    I also could not upgrade because it said I do not have permissions.  I went to the iPhoto Library, did "Get Info", under permissions, made it "read & write" for everyone.  Then iPhoto was able to convert my library to the new version.

  • WonkaUtrecht Level 1 Level 1 (0 points)

    Thanks rk82! spend 4 hours trying multiple ways to recover 130GB of pics until I found your post. Worked.

Previous 1 2 3 4 5 6 Next