14 Replies Latest reply: Oct 19, 2009 1:26 AM by Mike Boreham
steve7100 Level 1 Level 1 (0 points)
I have a problem when I send a mac zipped file to a PC user and they try to unzip the file
they are asked for a password. I didn't put password protection on the file and the PC user (XP) says they can unzip other files ok. Any ideas would be appreciated.

G5 iMac, G4 Powerbook, Mac OS X (10.4.11)
  • Fortuny Level 7 Level 7 (21,425 points)
    Hi,

    have a look at YemuZip http://www.yellowmug.com/yemuzip/

    Hope it helps

    Stefan
  • steve7100 Level 1 Level 1 (0 points)
    Thanks I tried YemuZip but it was pretty much the same thing.
    There must be some kind of issue with Tiger 10.4.11 and PC's with zipped files.
    I gave the files to a friend with Leopard on his computer and the file unzipped on a PC
    just fine. I never had this issue before with Tiger, guess an apple update screwed up ?
  • Fortuny Level 7 Level 7 (21,425 points)
    Hi,

    very odd one.

    I still have Tiger fully updated on my Mac Pro (with Leopard and Snow Leopard), but never in the past nor now have this problem.

    Maybe doing a full (bootable) backup/clone of your OSX Tiger and then reapplying the last Tiger Combo Update 10.4.11 plus the latest Security update 2009-005 can help with it.

    Stefan
  • steve7100 Level 1 Level 1 (0 points)
    Thanks for the help. I'll keep trying.
    I'm sure there are issues on the PC side that could be contributing
    to the problem. Ya think ???
  • Fortuny Level 7 Level 7 (21,425 points)
    Hi,

    could well be.

    To dive deeper into this, what E-Mail app are you using and what program is used on the Windows PC ?

    Stefan
  • Mike Boreham Level 4 Level 4 (2,095 points)
    I have this problem, randomly and occasionally...ie it happens rarely and when it does I can find no difference between a successful zip and "password" zip.

    It is not to do with e mailing. For example today I made a zip of six jpegs. I dragged it into my XP in Parallels and XP wanted a password. I then made a zip of six different jpegs in the same directory and dragged it into XP and it unzipped fine!!

    I did the exercise because I had sent the bad one to a customer via Filechute and he complained he was being asked for a password, which is exactly what I found when I tried it my XP Parallels.

    I have done "get info" on the files in the good and bad one and can see absolutely no differences.

    I have tried zipping the bad ones with Finder, Filechute and Betterzip with the same result.

    The bad one will open OK in Vista but not XP.

    I use Filechute a lot to send jpegs to customers and this only happens about 1 in 50 times, for no apparent reason.

    Really baffling!

    Would love some help on this

    Thanks
  • The hatter Level 9 Level 9 (60,520 points)
    Are they using 7-zip on PC?

    Vista/Windows7 has its own group policy and permissions on files that even get in my way moving files between multiple PCs, sitting next to each other, all running Windows 7, all mine.
  • Mike Boreham Level 4 Level 4 (2,095 points)
    No, they (and me when I test it) are simply right-clicking on the zip and selecting "extract all" from the options.

    On a file that works, this works, on a file that doesn't it asks for a password.

    I did try using a little free prog in XP called Zipeg which worked on the problem file. I am sure there are others, but I can hardly ask customers to install a third party app on their computers just to do something as simple as open a zip!

    In my case it looks like XP could do with a bit the the Vista/Win7 group policy medicine since Vista works but XP doesn't !
  • Mike Boreham Level 4 Level 4 (2,095 points)
    Just noticed that Zipeg says it uses the "powerful 7zip engine"
  • steve7100 Level 1 Level 1 (0 points)
    I'm using the built-in mac mail program, not sure what the client was using.
    I took the zip file on a thumb drive directly to a PC (XP) and still didn't work, so I don't think
    the e-mail programs are doing any thing weird.
    Had the files zipped on a mac running Leopard and they unzipped fine on the PC.
    It's just one of those pull your hair out bugs that make no sense. The iMac is up to date with all the
    software updates from Apple. 10.4.11. I think I'm overdue for a fresh re-install of Tiger anyway.
    Maybe that will work. ???
  • Fortuny Level 7 Level 7 (21,425 points)
    Hi Steve,

    reading Mike Borehams interesting posts to this topic and having him the same problem as you, I doubt that updating to Leopard (or even Snow Leopard) does help.
    Mike is on 10.6.1 Snow Leopard.

    On the other hand, doing the zip on Leopard seems to work for you.

    Maybe making a new account on your OSX and try the zipping with that new account can also help.

    Dubious, to say the least.

    Stefan
  • Mike Boreham Level 4 Level 4 (2,095 points)
    The point I would emphasise about this problem is the inconsistency.

    Most of the time, zips made with Finder do not cause a problem in Windows. Occasionally I send a zip to someone and they get the password problem. As far as I know it is only an XP problem.

    When it happens, I can find nothing different about the files I have zipped or the process I used, to cause the problem.

    I have certainly experienced the problem with both Leopard and Snow Leopard.
  • steve7100 Level 1 Level 1 (0 points)
    Stefan & Mike,
    Thanks for your input. Guess it always comes back to Mac vs. PC.
    Maybe Windows 7 will put an end to all the compatibility issues.
    HAHAHAHAHAHAHA. Sorry, couldn't help myself there.
    I'll just hope re-installing Tiger will do the trick, if not, oh well.
    Just have to find clients that only work on Mac's I guess.
    Thanks again
  • Mike Boreham Level 4 Level 4 (2,095 points)
    Just been exploring alternatives uploading unzipped files to my iDisk/Public folder.

    I was very pleased to be able to download my recent problem folder to an XP machine without a password problem.

    Then I thought that good scientific method requires that I reconfirm the original problem so I repeated exactly the original problem process using Filechute and zipping.... and of course today it was fine, no password required by XP. Last week repeated attempts with this same folder asked for password in XP every time (but not other folders).

    For now I can't see any alternative to doing a test download into XP to check for the problem, before sending to the customer.