4 Replies Latest reply: Dec 9, 2009 9:14 AM by Drcamphill
Drcamphill Level 1 Level 1 (0 points)
Before OS 3.1, my Exchange mail account correctly pushed, and still does.

My pop3 accounts were set to Manual and only grabbed new email when I went into each accounts Inbox.

Since upgrading to 3.1 every time I open the Mail app all accounts grab their email regardless of what the settings are in mail settings. I tried Manual, Fetch, Advanced etc. I don't want my pop3 accounts to grab their mail until I go into it's Inbox,,,like it used to work last week on 3.0.1

iPhone 3G 3.1
  • Envision99 Level 4 Level 4 (1,165 points)
    I'm still on 3.0, and even before on 2.x firmware it would always grab all the email from all my accounts when I open the email app.
  • paulcb Level 6 Level 6 (19,090 points)
    AFAIK, my 3G has always (since 2.x) downloaded the mail on all my accounts as soon as I opened the Mail app and continues to do so.
  • Oran Turner Level 1 Level 1 (25 points)
    This is actually either a new bug, or a new change from 3.0 behavior. In 3.0, if an account was set to manual, you had to actually open that account in mail and check for messages manually. In 3.1, all accounts are checked at the same time, even if they are set to manual.

    So, tell me if this is new bug, or Apple's new preferred method? Personally, I found the 3.0 behavior to make much more sense. Do I want all of my email accounts to automatically check for messages when I intend to use only ONE account...no. Therefore, I've actually had to turn off some of my other accounts in order to prevent being bombarded by messages at inopportune times.

    That's one strike against 3.1 for me!
  • Drcamphill Level 1 Level 1 (0 points)
    This appears to be a bug, although it does not appear that Apple has acknowledged it.