Previous 1 2 Next 23 Replies Latest reply: Dec 6, 2009 9:44 PM by randyj1964
Zero Grav Level 1 Level 1 (0 points)
Hi,

Like the title says, I've been experiencing connectivity issues with Snow Leopard via WiFi. It is not a constant problem, most of the time I can connect to the router without problems, but once in a while Airport seems to be freaking out and keeps asking me for the password. After entering the password I see the loader icon for about five seconds and then it tells me the connection timed out.

I'm certain that the password is correct and that it is an issue between the router and Mac OS X. I've had this problem when I first bought this laptop and was still running Tiger, but after installing Leopard it never happened again. I've searched these and other forums, but no one was able to provide me with a solution.

I've tried removing the password from keychain and the SSID from my Network preferenced with Airport turned of before rebooting, toggling Airport on and off or just rebooting the laptop. Nothing helps.. And then after a day or so it suddenly works again.

In the meantime I can still connect with my other computers (windows), and my iPhone 2G.

I use a Philips SNA6500 router at home and another Philips model at my dorm, one uses a wep key and the other a WPA one. So it's not just Apple's difficulty with handling WEP that's in play here. I've tried changing the frequency of the signal without luck and switched from B/G mode to single modes. Upgrading the firmware or resetting the device didn't help either.

I'm not really convinced that there actually ís a solution to this other than Apple releasing a patch. The fact that it worked flawlessly under Leopard shows that they could. After searching the Apple boards I've noticed that I'm not the only person experiencing these problems, and in the days of Tiger it was common knowledge that Philips and Apple didn't mix well. I'm mainly making this thread to back-up the other people with connectivity issues.

Thank you for taking the time to read this.

Macbook Pro 2.2Ghz Santa Rosa (Mid 2007), Mac OS X (10.6.1)
  • Roomiller Level 1 Level 1 (0 points)
    I am having this exact problem and it is actually driving me toward insanity. I went straight from Tiger to Snow Leopard, so I did not enjoy the peace and calm of a dropless Leopard install.

    Our router is a LinkSys WRT54G v. 3. We've tried many firmware versions so we know it isn't that. Our new MacBook unibody and an iPodTouch on the network that have no problems at all.
  • Arshia Bigdeli-Shaygan Level 1 Level 1 (5 points)
    I am experiencing the exact same issue starting a few hours ago. I was online watching videos and suddenly I get no connectivity (even to the router setup page) and my iMac either doesn't see any WiFi networks, sees all the ones around me but "Connection timed out", or doesn't connect at all. Funny things is i'm on my iPod Touch without issue, my PC laptop connects fine, one roommates PC and Palm connect just fine, and my other roommates iMac, MacBook and iPhone all connect just fine!
  • John Scott1 Level 2 Level 2 (300 points)
    I have a MacBook (White) and a Mac Mini and both connected via WiFi with a Linksys
    WRT54GS V7.2 have issues. Mostly I loose internet but retain local network.
    Safari to me is the issue. Because I have tried Updates and it gets internet access for those. So I am wondering what is the problem. I have tried resetting Safari and clearing it. It seems to solve the problem for a day or so only to return. Considering how much I use a browser I am going to have to revert to 10.5 Leopard or give a try at using Firefox or Camino.
  • donv (The Ghost) Level 5 Level 5 (4,600 points)
    Firefox works great, but I am not saying that Safari is your problem. I'd sure try Firefox if I was having the problem.
  • Zero Grav Level 1 Level 1 (0 points)
    Thanks for the replies guys..

    As to your issue John Scott, I don't think you're experiencing the same issue we are/i am. My Airport fails to connect completely, so obviously nothing that requires an internetconnection works.

    My WiFi menubar icon shows that it's searching networks and connecting to via the animated strength bars. After about 10 seconds it stops after which it just shows the faded icon (no connection) or it gives me an option to connect to the available networks. So I just click the SSID of my personal network, it fills in the password for me but after clicking OK it just times out.
  • NRCharman Level 1 Level 1 (0 points)
    I have exactly the same problem. Philips SNA6500. Worked fine on Leopard, worked on Snow Leopard initially, then stopped connecting last week.
    I'm not sure if I lost connectivity after an OS upgrade, or after a Parallels upgrade.
    My Macbook can see the router, it correctly identified when I changed the access protection, (didn't ask for password when protection removed, asked for it again when reapplied WPA protection). Everything else in the house can connect. I can connect via Ethernet. My problem is 100% constant, though. I have tried connecting the Macbook via another Wifi router yet.
  • NRCharman Level 1 Level 1 (0 points)
    I have found a fix for my problem.
    Under system preferences it lists two Parallels host adapters, an airport connections, an Ethernet and a Firewire connection. Using the option buttos at the bottom of that list I change the order so that the Airport came first, (top of the list).
    Suddenly the mac will connect. Hope this helps others.
  • DaveE128 Level 1 Level 1 (0 points)
    I am having the exact same problems, but with an Orange Livebox wifi router, set to WPA only. With Leopard it just worked. With Snow Leopard it keeps timing out, but sometimes connects ok. It never seems to connect first time after turning my MBP on. This morning I had major problems connecting, kept timing out but the signal is weaker than usual.

    I have airport at the top of the list in system preferences > networks, and it doesn't seem that I can re-order the list anyway!

    I sure wish apple would fix this! Obviously they are capable of making this work
  • Zero Grav Level 1 Level 1 (0 points)
    Just to let you guys know, 10.6.2 has not resolved the situation.

    The situation has gone from bad to worse, since my first post I haven't been able to get online once at my dorm using wireless. No complaints whatsoever from any of the Windows users, just to stress that the issue is not a router one. My friend who uses a Macbook running Leopard has no problems at all and both our iPhones' WiFi work flawlessly.

    At home I can still connect, but I still have the occasional connection time-out that's usually fixed by waiting for a day and/or turning of the router for a minute or so.
  • laurentmeyvaert Level 1 Level 1 (0 points)
    I have the exact same problems.

    What I do to solve it (temporarily) is plug the ethernet cable in my Macbook, and reset the router (power off - power on). But a couple of days I have the same problems again.

    I'm glad I can do this little trick with my macbook, but another problem I have is that I want to buy an iMac, but I'm affraid that I'll have the same network issues, and I won't be able to just run downstairs plug my iMac in the ethernet and reset my router.

    I really hope Apple will fix this soon, because it worked without any problems on 10.5, so why can't they do the same with 10.6?
  • pomme-homme Level 2 Level 2 (415 points)
    Same thing here. My Mac Book Pro always finds my AEBS at home but only occasionally my network at the office (WRT54GL) even though both are on my trusted networks list. If I try to connect manually, the Mac Book searches for a network for about 10 seconds and times out.

    Resetting the router seems to fix the problem (I think) but it seems to occur somewhat randomly.
  • switheyw Level 1 Level 1 (10 points)
    My wife uses a 10.5.x mac mini, I use a 10.6.x Macbook Pro. Both systems are within 20 feet of the WiFi router.

    After my 10.6 Macbook Pro awakens from a sleep it often (but by no means always) has trouble connecting to my wireless router. First thing after a reboot, it always connects quickly! Therefore, I've taken to rebooting whenever I have problems reconnecting.

    I gave up trying to enter a password to connect to my network, it never works.

    Until the connect happens, the wireless icon on the menubar shows very little or no signal strength. The router is 15 feet away, and the other mac in the room, (a macmini still at release 10.5.x) is still connected and has access to internet. Why does the wireless icon show such low signal strength (until finally connected) ? Shouldn't signal strength be known before 'connection'?

    The 10.5.x mac mini never ever has connection problems.
  • Ol. Level 1 Level 1 (0 points)
    I have almost the same rooter (Philips SNV6520) and I'm experiencing the same issue on a MacBook Mid 2007
  • Winds Level 1 Level 1 (0 points)
    I have the same problem. WiFi was working fine until a few days ago. Keep getting connection timeout when trying to connect. Haven't been able to connect over WiFi since. Having to use an ethernet cable. Please sort this problem out asap! My first mac purchase & cant say im too impressed at the moment!
Previous 1 2 Next