Previous 1 2 3 4 Next 56 Replies Latest reply: Nov 5, 2009 8:00 AM by cymx5 Go to original post
  • bordercolliekid Level 1 Level 1 (0 points)
    Ha!

    I've tried to report this to Apple as a bug... this is the result:

    http://i239.photobucket.com/albums/ff79/engineroom/Public/Screenshot2009-10-07at 82851PM.png

    I'd laugh if I wasn't in an apoplectic rage.
  • bingbling Level 1 Level 1 (0 points)
    yeah
  • Stanley Horwitz Level 4 Level 4 (2,705 points)
    Apple is responsible for fixing the bug that is causing this problem. Protecting data by backing it up is not Apple's responsibility. This is spelled out in Snow Leopard's EUL. Comparing this situation to a defect car part is silly, but if you want to make a comparison, then even Toyota isn't going to replace your car's contents (i.e., the stuff in the trunk) if a defect in the car causes a severe crash.

    Let this be a lesson to back up your data. With SL, there is no excuse to allow years of important data to go unprotected. Just invest in an inexpensive external disk drive, plug it in and let Time Machine do what its intended to do.
  • Gary P Level 4 Level 4 (1,395 points)
    But you were right in the sense that, if this was 100% reproducible, this forum would be flooded with a huge wave of complaints. So it seems the bug only happens under a specific set of circumstances. In any case, Apple needs to get all over this very quickly, to avoid some truly bad PR. And for the people affected, knowing it is not widespread is cold comfort.
  • UKDoc Level 1 Level 1 (0 points)
    Have to say that, sadly, I have suffered from this too, thankfully I had a CCC backup of my machine and only lost a couple of days stuff ...

    Chronology of events:-

    1) Logged in as my normal Admin account, all fine.
    2) Shutdown machine for a few hours after doiung what was needed.
    3) Power up machine, accidentally log-in as "Guest", I clicked incorrectly on the track pad, something I have yet to correct doing ...
    4) Guest log-in fine, about the usual amount of time too, so immediately log out
    5) Try to log in as usual user, MBP accepts my usual login details, however ...
    6) Log-in behaves like a new user, default background, dock contents etc, Safari has lost all bookmarks, iTunes has no content.
    7) Thank goodness have back up - use CCC to restore ...

    What seems really odd about this is that there's little or no unusual disk activity and yet masses of content is missing ... but, the Applications folder is intact with all software that should be there, it's just documents and data that is missing ...

    Needless to say, have disabled guest log-in.

    FYI, 10.6 install was done from a legit purchased disc, not an upgrade, however the machine did have 10.5 on when I started, it was not an "erase disc and start a new" installation.

    Hope this gets resolved sooner, rather than later ...
  • Marty Martino Level 1 Level 1 (10 points)
    First off, my sympathy for those you who have been victimized by this 'bug' (if it is a bug and some kind of backdoor in SL).

    A question for you all: do you manually log in each time at bootup or do any of you use auto-login? I am using auto-login and have been using the guest account fairly regularly. Only I have to log out of this admin/user account to get to the guest account. After that, I restart and this MBP auto logs into this account I'm using. And I have not encountered this. However, I have noticed just a few moments ago, a Guest folder appearing in Users. This is new and I'm a bit nervous. But the twist is - the guest account is disabled. I do not remember seeing it while the guest account was enabled (I don't remember if I disabled it in 10.5 before upgrading but I did disable then reenable guest yesterday). There shouldn't be a guest user folder, while the guest account is disabled should there?

    Message was edited by: Marty Martino
  • Eric Westby Level 4 Level 4 (1,800 points)
    Thomas A Reed wrote:
    I guarantee that this had nothing to do with the guest account. If logging in to the guest account erased your hard drive, you'd hear tens of thousands of complaints here, yet I don't.


    Ouch: famous last words, given Apple's acknowledgment of precisely this problem two weeks later. A reminder to those of us who are old hands here to try and be open-minded even when presented with unusual complaints.
  • rrahimi Level 3 Level 3 (615 points)
    As Graham said 77GB is most probably not completely gone.

    Most of it should be recoverable through some file-recovery utility. Don't know of any free ones right now, but if you do not have a backup, then don't login/use your machine and instead try to restore data using another machine.
  • cymx5 Level 1 Level 1 (0 points)
    Unless someone has had success with another program, here is my account of $99 not well spent. I purchased Data Rescue II to see if it could recover my data. The only records it could find were past documents which were actually disposed of through the Trash Can. No files that were lost, in respect to the Snow Leopard bug, could be recovered in my case.

    As precaution, I zeroed out my hard drive and did a clean install of Snow Leopard. I got impatient with Apple.
  • Phillip Jones Level 1 Level 1 (25 points)
    Woof, that is tough. I was hoping you were going to tell us you had it all bootable backed up double including a Time Machine or that absolutely nothing on the hard drive was important enough to keep. Otherwise, it must be as much an embarrassment as unfortunate. I feel your pain; it happened to me several years ago–never again. I keep 2 hard drive copies in one location but have a Time Machine separated over to my guest house and back up there using Airport. My laptop makes 4. My critical files are also kept in a fireproof safe. Your warning worked–I am now even more resolved.
  • dechamp Level 4 Level 4 (3,495 points)
    I found this article which explains what's happening. The bug only appears with systems that had the Guest Account Enabled in an earlier OS (Maybe just Leopard, but who knows) and updated to Snow Leopard.

    http://reviews.cnet.com/8301-13727_7-10373212-263.html?part=rss&tag=feed&subj=Ma cFixIt

    The quick fix to stop the problem from happening is to disable the Guest account and then re-enable it for Snow Leopard. The article says Apple is aware and is working on the problem.

    I would suggest that all affected users provide additional feedback directly to Apple: http://www.apple.com/feedback/macosx.html - as there is not much this user to user forum can do to recover the lost files or stop the problem from happening to begin with.
  • rrahimi Level 3 Level 3 (615 points)
    Sorry it didn't work for you.

    Usually soft-delete is un-doable as long as no other data is written over deleted files. In such delete, what gets wiped is the address of files in allocation table. Tools like Data Rescue analyze the disk bit by bit and restore the files. Usually the original structure (folders, etc.) is lost, but the actual files remain intact.

    The process though is very time consuming. I once had to recover 0.5TB of data on a 1TB disk and left it for roughly 24 hours. I got almost all of my files back so my experience with Data Rescue been a rather good one and that's why I recommended it.

    Your new install should be alright since guest account is disabled by default in a clean install of SL.

    Hopefully Apple will fix this soon and inform users so they avoid guest login while waiting for a patch.
  • The hatter Level 9 Level 9 (60,370 points)
    Nobody that lost data cares what is/is not in the end user legal agreement. That it wasn't caught during testing, they should be. That seems to suggest not enough time and resources devoted to hammering on the system and putting it through its paces.

    Yes, I find it deplorable that Step #1 as part of the OS upgrade/install isn't to prod the user into a backup. And preferably one that will be bootable; off line; and as in 10.3.0 again, no FireWire attached devices during or after the install (to avoid yet another bug with 10.6.0).

    So even if you DO use TimeMachine, what if you can't reach or access your external hard drive, huh? You might need to have 10.5.8 mini system to boot from somewhere.

    The lesson is to backup, of course, but also, not to jump on any new OS, any "1.0" versions. Wait for .2 or .3 instead.
  • cymx5 Level 1 Level 1 (0 points)
    It's definitely spreading. A family member works in a school and told me that that a number of employees have asked about this problem happening on their personal computers. I wonder if commercial users are having the same problem.

    I'm just me, and this is capitalism, so I don't expect a happy win/win response. However, I can't imagine the stress of this problem on any businesses that upgraded.
  • rrahimi Level 3 Level 3 (615 points)
    Businesses usually have a good backup policy in place.

    In fact, it won't even get there, because most businesses disable guest accounts for security purposes.