Previous 1 2 3 Next 41 Replies Latest reply: Mar 31, 2010 10:44 AM by mamunoz
Bob222 Level 1 Level 1 (85 points)
Two new Intel iMacs running 10.6.1.

Booted source machine in target mode. Created image on external FireWire drive. In SUI, selected the source, and chose NetRestore Image.

The created image:

-rw-r--r--@ 1 root staff 9882697406 Sep 30 12:07 System.dmg

--

System Image Utility 2 (SIU), v. 10.6 (438).

Left pane
Sources
Macintosh HD 1 http://that is how SIU interprets the \"Macintosh HD\" mounted volume of the machine I'm imaging (i.e., I'm sure it adds \"1\" to make the name unique).

Right/main pane
Netrestore of master LLCimage
√ Creating Image from Source http://i.e., success
Preparing Image for Restore http://i.e., failure
Creating NetRestore Disk Image http://i.e., failure
Creating Bootable System http://i.e., failure
Copying Source Image http://i.e., failure
Creating NetBoot System http://i.e., failure
Finishing up http://i.e., failure

--

Log:

Starting image creation.
Workflow Started (2009-09-30 10:15:01 -0700)
Starting action: Define Image Source
Finished running action: Define Image Source
Starting action: Create Image
Starting image creation process...

Create NetInstall Image

Initiating NetInstall from Restore Media.

created: /Users/LLC/Desktop/20090930_0948/NetRestore of Macintosh HD 1/System.dmg
Checksumming partition of size 63 blocks...done
Catalog file is too fragmented for restore.
Try "fsck_hfs -r" on writeable copy of the image volume
unable to get UDIF info from "/Users/LLC/Desktop/20090930_0948/NetRestore of Macintosh HD 1/System.dmg" - Bad file descriptor.
asr: image scan failed - Bad file descriptor.
Script is done.

NetInstall creation failed.

Image creation process finished...

Stopping image creation.
Image creation failed.

ACTION ATTEMPTED:

$ sudo fsck_hfs -r System.dmg

System.dmg is not a character device

--

Repaired permissions on source, made sure machine running SIU would not go to sleep, same failure.

Bob

2009 iMacs, Mac OS X (10.6.1)
  • Bob222 Level 1 Level 1 (85 points)
    On the phone with Apple. Here's what I've got so far:

    sudo fsck_hfs -fry /dev/partitionid (you can get the partition id of the TDM volume in the Disk Utility Get Info window for the volume)

    Tried it, but got:

    ** /dev/rdisk1s2 (NO WRITE)
    Executing fsck_hfs (version diskdev_cmds-491~1).
    ** Verifying volume when it is mounted with write access.
    ** Checking Journaled HFS Plus volume.
    ** Checking extents overflow file.
    ** Checking catalog file.
    ** The volume Macintosh HD was found corrupt and needs to be repaired.

    He then had me run Disk Repair on the source volume (in Target Mode). Disk reported as OK. Re-ran Repair, still said OK.

    Re-ran the above fsck command, same failure. He is looking further now.
  • Bob222 Level 1 Level 1 (85 points)
    Apple is aware of a problem with SIU. I'm going to try reversing the roles of the iMacs just to see if the problem replicates. I was told I might try running ASR command line on the image that was created to see if I could get it to work.
  • codyg Level 1 Level 1 (0 points)
    Any idea when a fix will be issued? Not fun trying to image a new lab with no imaging utility.
  • Bob222 Level 1 Level 1 (85 points)
    No idea. I've asked our rep and SE to see if they can help in escalating a fix. We've got a lot of clients to image. I will give ASR a try tomorrow, though. I suppose I could look at Deploy Studio as a plan C. Note that the known problem may not affect everyone, so others may be fortunate.
  • codyg Level 1 Level 1 (0 points)
    I've just got done making an image with ASR and it seems to be giving the same error:

    Catalog file is too fragmented for restore.
    Try "fsck_hfs -r" on writeable copy of the image volume
    unable to get UDIF info from "/Volumes/LAB.dmg" - Bad file descriptor.
    asr: image scan failed - Bad file descriptor.
    administrators-MacBook:Volumes administrator$ fsck_hfs -r /Volumes/LAB.dmg
    /Volumes/LAB.dmg is not a character device
  • Bob222 Level 1 Level 1 (85 points)
    I have no experience with ASR at all. Is what you're describing occurring in a phase in the process following the initial .dmg creation? What the Apple person was suggesting I might try, was to take the dmg image that I did have, and use ASR command/s to try to get to the next phase. If this makes any sense, is that what you tried?

    In any case, it is useful to have your report. Apple tried very hard to help me, and I appreciate that; we need to emphasize to them in numbers (and representing the numerous purchased systems we have that are in jeopardy) that this needs resolution ASAP. Thanks.
  • codyg Level 1 Level 1 (0 points)
    Yes that is what I did, I created the .dmg with the Disk utility and then used "Scan Image from Restore" and it gave me those errors. I just gave you CLI output because the GUI was not giving me much information as to why it failed.

    I have also spent yesterday afternoon getting a DeployStudio server up and running, I uploaded a "Master Image" last night. This morning I tried to restore that image and I got the same exact error message. So it seems that DeployStudio is not a fix for this either. I'm going to keep banging on it, I'll report back if I get anything out of it.
  • Brian Nesse Level 4 Level 4 (2,905 points)
    There is a "shortcut" in the SIU NetRestore process that will cause it to skip the image creation process if it finds a System.dmg in the folder when it starts. This little bit of functionality should allow you to work around the fragmented catalog issue.

    Starting with your fragmented image, the following process should create a non-fragmented image.

    hdiutil convert "</path/>System.dmg" -format UDRW "</path/>System-rw.dmg"
    hdiutil attach -mount suppressed-shadow "</path/>System-rw.dmg"
    (This should return a dev node (e.g. /dev/disk1s2), and the volume will not be mounted) 
    fsck_hfs -fry /dev/disk1s2
    hdiutil detach disk1s2
    rm "</path/>System.dmg"
    hdiutil convert -format UDZO "</path/>System-rw.dmg" -shadown -o "</path/>System.dmg"
    asr imagescan --source "</path/>System.dmg" --filechecksum

    Once this is complete, re-run the workflow, using exactly the same information as before. This will cause SIU to "re-create" the image in the same place. It will find the "System.dmg" and skip that portion of the workflow.
  • Bob222 Level 1 Level 1 (85 points)
    Thanks for the update! While I am interested in trying Deploy Studio, you have saved me some time by not trying it right now as a workaround.

    As an experiment, I reversed the hardware-identical 10.6.1 iMacs and ran the NetRestore process on the setup shipped by Apple, and upgraded to 10.6.1 by me, and had success. So the problem doesn't happen in all cases.

    I'm going to try to create a NetBoot image, and using that for now. I don't know enough about what SIU does when creating that image vs. one for NetRestore -- my guess is I may run into the same problem, but I can let the image build while I twiddle my thumbs.
  • Bob222 Level 1 Level 1 (85 points)
    Brian, thank you so much.

    I'm puzzled by the following. Perhaps I'm overlooking something, but here goes.

    In the log of the successful run of NetRestore Image against the essentially generic iMac ("B", I see:

    […] PackageKit:*Missing bundle Identifier: /Library/Receipts/Office2008en_automatorworkflow.pkg

    ... and similar Flip4Mac stuff .pkg.'s in the same directory. Those files do not exist in "B". They exist in the customized iMac "A". There is a System.dmg of "A" in "B", but I don't that that is where those references are being picked up, but I could be wrong.

    In SIU, the source is listed as "Macintosh HD 1" ("1" because both machines have the same volume name). It shows up with a firewire icon. But it almost seems like SIU is trying to image itself, which SIU can't do.

    Note 2: I apparently spoke too soon about my success. When I open up the NetInstall.dmg image, which presumably is created from the System.dmg, then the latter deleted(?), I don't have any applications, Users, etc. It looks like a stripped down image for booting only.

    I'm going to differentiate the volume names just to be sure, try the commands you recommended, imaging "A" (my production iMac), and report back.
  • codyg Level 1 Level 1 (0 points)
    sh-3.2# hdiutil attach -mount suppressed /Volumes/LAB-rw.dmg
    /dev/disk1 Applepartitionscheme
    /dev/disk1s1 Applepartitionmap
    /dev/disk1s2 Apple_HFS
    sh-3.2# fsck_hfs -fry /dev/disk1s2
    ** /dev/rdisk1s2
    Executing fsck_hfs (version diskdev_cmds-491~1).
    ** Checking Journaled HFS Plus volume.
    ** Checking extents overflow file.
    ** Checking catalog file.
    ** Rebuilding catalog B-tree.
    ** The volume Macintosh HD could not be repaired.

    At this point I tried to keep going just to see what would happen:

    hdiutil convert -format UDZO /Volumes/LAB-rw.dmg -shadow -o /Volumes/LAB-Final.dmg
    Preparing imaging engine…
    Reading Driver Descriptor Map (DDM : 0)…
    (CRC32 $3EB613CD: Driver Descriptor Map (DDM : 0))
    Reading Apple (Applepartitionmap : 1)…
    (CRC32 $17B7E81B: Apple (Applepartitionmap : 1))
    Reading disk image (Apple_HFS : 2)…
    ..............................................................................
    (CRC32 $A4193CAC: disk image (Apple_HFS : 2))
    Reading (Apple_Free : 3)…
    ...............................................................................
    (CRC32 $00000000: (Apple_Free : 3))
    Adding resources…
    ...............................................................................
    Elapsed Time: 7m 56.679s
    File size: 8133363717 bytes, Checksum: CRC32 $C35DCB80
    Sectors processed: 21855882, 21840265 compressed
    Speed: 22.4Mbytes/sec
    Savings: 27.3%
    created: /Volumes/LAB-Final.dmg

    asr imagescan --source /Volumes/LAB-Final.dmg --filechecksum
    Checksumming partition of size 63 blocks...done
    Catalog file is too fragmented for restore.
    Try "fsck_hfs -r" on writeable copy of the image volume
    unable to get UDIF info from "/Volumes/LAB-Final.dmg" - Bad file descriptor.
    asr: image scan failed - Bad file descriptor.
  • Bob222 Level 1 Level 1 (85 points)
    Sorry, I just found that the spare image is for booting, and the actual data from source volume is inside System > Installation > Packages, so all is well on that (non) issue.

    Will report back on the new recipe this afternoon.
  • Bob222 Level 1 Level 1 (85 points)
    While in the directory of "System.dmg", I enter:

    $ hdiutil convert "System.dmg" -format UDRW "System-rw.dmg"

    ... but get:

    hdiutil: convert: only a single input file can be specified
  • Bob222 Level 1 Level 1 (85 points)
    Just checked man; need a "-o" before the output file is specified. Moving on now. with the rest.
Previous 1 2 3 Next