1 Reply Latest reply: Oct 4, 2009 12:32 PM by davybhoy1888
Obasan Level 1 Level 1 (50 points)
I have a 32 GB 1st Gen iPod Touch that I bought in the restore mode, thinking I'd be able to fix it easily. Well, clearly that is not the case! I do not know the history of the ipod - if the previous owner tried to jailbreak it or what - although I am trying to find out. Let me describe the symptoms and what I have done to try to fix the ipod.

As I said, I bought the ipod in its current state. The first thing I did was connect it to the computer and attempt to restore it through itunes. Now, this is what is odd, it did restore and start up once with the full GUI. I wanted to test it out so I added a couple of playlists to it and ejected it, but once that was done it went right back into restore mode.

I have been through most of the advice on the web. I put it into dfu mode and tried to reinstall, I've tried putting it in dfu mode and trying to install previous versions of the os from 1.4 up to 3.0. Most of the time, I am not able to get to the install part of the process (when you get the apple logo with the progress bar underneath it. What happens is iTunes expands the software, and then just at the moment when it comes to install on the ipod, the ipod icon disappears from the itunes sidebar and, it seems, disconnects from the computer. Now, this has happened on several computers now, so it's not a usb port problem on my computer.

I've tried several other things. I have tried using Ziphone in case it was a failed jailbreak. However, in that program I don't get very far - before it starts it tells me that the usbmuxlistenercreate is not found. The most helpful tool I've come across is iRecovery which is a terminal app. (I'm not sure if that's the right term, but it's accessed through terminal). With that program I am able to reach the ipod and get some info on it and execute some commands. I can paste the printenv results if that would be helpful. I've found several sites that recommend setting the autoboot to true rather than false. I've tried this but the odd thing is that after I set autoboot to true (and I do a printenv again to make sure it's reset), I try to restore the ipod, it fails (errors 20, 21, and 1604 are the most common) and when I go back in, the autoboot is set back to false. Seems to be a pattern of resetting.

I'd really appreciate some help here. I can access Windows (although only 7) through my virtual machine and I do have access to a computer with 10.5.8 on it as well.

iMac C2D 2.4 4GB, MBP 1.83 CD, Mac OS X (10.6.1)
  • davybhoy1888 Level 1 Level 1 (0 points)
    Hi mine done something similar after downloading v9, when i got to the part with the Apple logo & download bar mine stopped too ! I discovered there was a problem with it not downloading the new usb driver - maybe this might help you !. during download go into control panel - Administrative tools - Computer management - Device manager & look for an exclamation mark on i-pod usb driver - if this is so double click it & update the driver ! hope this helps you ! Davy.