14 Replies Latest reply: Oct 4, 2009 9:38 AM by fruhulda
macnificent7 Level 1 Level 1 (0 points)
For no reason I can think of, my New Times Roman font in Pages '08 suddenly stopped working properly and comes out all distorted. It was fine yesterday, and then today 'poof'. All other fonts are fine. New Times Roman in other applications are fine. Just Pages. (I recently upgraded to Snow)

Does anyone have an idea what happened, or most importantly, how I might fix this?

Thanks a million!

MacBook Pro 2.4 Gz, Mac OS X (10.6.1)
  • fruhulda Level 6 Level 6 (15,120 points)
    Is this in several Pages documents? Old ones and new ones?
    When did you upgrade to 10.6.1? Do you have the latest versions of Pages'08 (3.0.3)?
    More details you help to solve the problem. We can't know how things are on you machine, you have to tell us.

    It could be a corrupt document. Try another font in that document. Make a new document.
    Delete the com.apple.iwork.pages.plist in User > Preferences folder

    There are other possibilities too.
  • Level 8 Level 8 (41,790 points)
    (1)I guess that it's not _New Times Roman_ but _Times New Roman_ !

    (2) how is it behaving if you run Pages from an other user account ?
    If it behaves well, try:

    from the original account
    quit Pages
    drag the preferences file
    <startupVolume>:Users:<yourAccount>:Library:Preferences:com.apple.iWork.Pages.pl ist
    on the desktop
    restart Pages.

    If it behaves well it's that the preferences file was corrupted.

    It may also be a corrupted cache file but at this time, I don't know which they are under 10.6.

    Yvan KOENIG (VALLAURIS, France) samedi 3 octobre 2009 11:36:57
  • macnificent7 Level 1 Level 1 (0 points)
    Hi, thanks for the help. I truly appreciate it.

    Is this in several Pages documents? Old ones and new ones?

    When did you upgrade to 10.6.1? Do you have the latest versions of Pages'08 (3.0.3)?

    The Times New Roman doesn't work in any Pages document. ALL other fonts work fine. I upgraded to 10.6.1 as soon as I installed Snow. Yes, I have Pages '08 3.0.3

    More details you help to solve the problem. We can't know how things are on you machine, you have to tell us.


    I had been working on the same manuscript for a long time. I finished for the day, and the next day when I re-opened it to work on, the font was screwy. I changed to Times, and it was fine. I tried a dozen other fonts, all fine.

    I opened old documents in Pages, and if I changed them to Times New Roman, I got the same problem

    It could be a corrupt document. Try another font in that document. Make a new document.

    Delete the com.apple.iwork.pages.plist in User > Preferences folder

    Okay, I deleted the preference file you mention, but, unfortunately, I have the same problem. Should I delete other preference files related to Pages, too?

    Thanks very much!
  • macnificent7 Level 1 Level 1 (0 points)
    Thanks very much for your kind assistance.

    As you can see in my reply to the other gentleman who is helping with this problem, I took both of yours advice and deleted the mentioned preference file, but when I restarted Pages, the same problem remained.

    Any other ideas? If there is other information you need, please ask. I'm sorry that I don't know what info would be relevant to this situation.

    Thanks very much!
  • fruhulda Level 6 Level 6 (15,120 points)
    macnificent7
    Could you try the font in Text Edit and see if it behaves there? Also have a look in the Font book and validate Times New Roman. File > Validate

    Did you try to make a new account and open the document from there?

    You could try this :
    1) Change all text to a working font
    2) Export the document to RTF
    3) Open the RTF document in Pages
    4) Try to apply Times New Roman again
    5) Save if it works OK
  • Level 8 Level 8 (41,790 points)
    Run this script to clean the Fonts cache which may be corrupted.

    --

    do shell script "atsutil databases -removeUser"
    --


    Yvan KOENIG (VALLAURIS, France) dimanche 4 octobre 2009 12:19:30
  • macnificent7 Level 1 Level 1 (0 points)
    Hi fruhulda,

    Could you try the font in Text Edit and see if it behaves there?


    I see it works fine in Text Edit.

    Also have a look in the Font book and validate Times New Roman. File > Validate


    Just did and 4 out of 5 Times New Roman fonts show exclamation points. The following:
    Times New Roman.ttf
    Times New Roman Italic.ttf.
    Times New Roman Bold.ttf
    Times New Roman Bold Italic.ttf

    Other fonts verify fine.

    Did you try to make a new account and open the document from there?


    No, sorry. How do I do that?

    You could try this :

    1) Change all text to a working font
    2) Export the document to RTF
    3) Open the RTF document in Pages
    4) Try to apply Times New Roman again
    5) Save if it works OK

    I tried but it didn't work. After opening the RTF with Pages, the Times New Roman still didn't work. Though, as I mentioned, it did work in RTF.

    Thank you for your patience with me!
  • macnificent7 Level 1 Level 1 (0 points)
    Hi Yvan,

    Thanks for your patience.

    Run this script to clean the Fonts cache which may be corrupted.
    do shell script "atsutil databases -removeUser"


    I'm ashamed to say I don't know how to run a script. If it is not too difficult to explain, and you tell me what I need to do?

    Thanks again for your kind advice!
  • macnificent7 Level 1 Level 1 (0 points)
    P.S. fruhulda and Yvan

    Looking at the font book, I see there are duplicates of Times New Roman. Each type has a TrueType and an OpenType TrueType.

    Example:
    Regular
    TrueType Version 2.90
    OpenType TrueType Version 5.01.3x

    Is this normal? Should I delete one of each? If so, which one? The TrueType Versions or the OpenType TrueType Versions?

    Thanks!
  • fruhulda Level 6 Level 6 (15,120 points)
    Mine are the latter one, open true type. Delete the other font. Validate again. It seems to be a font problem.
  • macnificent7 Level 1 Level 1 (0 points)
    Hi,

    Mine are the latter one, open true type. Delete the other font. Validate again. It seems to be a font problem.


    The warning comes up with open true type. Regular true type has no warnings.

    I tried disabling both sets, but neither worked. I tried dragging each set to the trash and reopening Pages. Both cases, the Time New Roman didn't work.

    However, I did try creating a new user and opening Pages. When I did that, the font worked! But when I went back to my normal user, it failed again.
  • fruhulda Level 6 Level 6 (15,120 points)
    macnificent7 wrote:



    The warning comes up with open true type. Regular true type has no warnings.

    Hmm!

    I tried disabling both sets, but neither worked. I tried dragging each set to the trash and reopening Pages. Both cases, the Time New Roman didn't work.


    What do you mean with disabling the set? Did you Remove the Time New Roman? Both?

    However, I did try creating a new user and opening Pages. When I did that, the font worked! But when I went back to my normal user, it failed again.


    In this instants what do you mean the font worked? Did the document with Times New Roman behave or was the font OK in the Font book? You have something corrupt in your account. Remove the troublesome fonts and reinstall from you MacOs system DVD.
  • macnificent7 Level 1 Level 1 (0 points)
    Hi Fruhulda,

    Good news.

    I got it working!

    To tell you the truth, I'm not sure what I did. All I know is a did a SELECT ALL on the Font Book and clicked VERIFY. A bunch of different fonts came up. I removed ALL of them.

    Doing so, however, moved half of my fonts to the trash! Fortunately, I didn't dump the trash. I logged in and out a couple of times. Tried some different things.

    I moved all the fonts back, except a couple, including the open true type Times New Roman. I left those in the trash.

    I ran Pages and everything worked, including Arial and few others that I had discovered weren't working properly. Now everything seems to work.

    I lost an afternoon of time messing around, but finally seemed to hit on the right thing. Frustrating, but at least everything seems okay now.

    I really, REALLY appreciate your help and that of Yvan.

    All the very best to you!
  • fruhulda Level 6 Level 6 (15,120 points)
    Thanks for the feed back!