8 Replies Latest reply: Oct 11, 2009 11:19 AM by Ernie Stamper
superwessex Level 1 Level 1 (0 points)
I have just completed the install for 10.5.6

All e-mails have been deleted from mail, it now won't send or recieve e-mail and i have to force quit every time. I have tried restarting and also reparing privileges.

The mail files still seem to be on the hard drive library. How do i get then back into mail and get it to function correctly? Nothin ghas changed except for the update to OS X

iMac G5, Mac OS X (10.5.6)
  • Ernie Stamper Level 8 Level 8 (37,555 points)
    There was once some specific steps for this, but I think the advice now is to immediately update from 10.5.6 to 10.5.7 or 10.5.8. The messages are not lost if you don't manually take some undue action.

    From what version of OSX did you move to 10.5.6?

    Ernie
  • superwessex Level 1 Level 1 (0 points)
    Thanks I'll give that a try. I didn't want to go any further in case I made things worse.
    I upgraded from 10.3.9 but the apple rep assured me that wouldn't be a problem
  • Ernie Stamper Level 8 Level 8 (37,555 points)
    The problem you are describing was most often seen after an Upgrade using the Box sets, which had 10.5.6, from 10.4.11, but also was seen when upgrading from 10.3.9. There was a special download to repair the Mail app in these cases, but that became unnecessary after the release of the next step to 10.5.7. But you should be able to simply update to 10.5.8, now, and have the messages been seen again. You might take the precaution of making a Duplicate of the Mail folder, and dragging that resulting copy to the Desktop for temporary backup.

    Btw, no one who had been using 10.5 prior to the 10.5.6 update saw the same problem, but the 10.5.6 update was not clean for some of those, but just a different issue.

    Ernie

    Message was edited by: Ernie Stamper
  • superwessex Level 1 Level 1 (0 points)
    Thanks Ernie. It was the box set 10.5.6 that I used. the update to 10.5.8 has got Mail working correctly again but the old e-mails still aren't showing up. Any tips on how to get them back form the Library?
  • Ernie Stamper Level 8 Level 8 (37,555 points)
    Where are you seeing them? Are they in the Library at Home/Library/Mail? If so, then perhaps will only need to force a reindexing. Do you have any IMAP or Exchange accounts, or only POP?

    Ernie
  • superwessex Level 1 Level 1 (0 points)
    Actually, thats where they were. But there is nothing there this morning. It's nothing critical so I'll just leave it at that.

    Thanks for your help
  • kaotik2003 Level 1 Level 1 (30 points)
    If not with Mail app closed, just erase the envelope.index from your mail folder in Library.

    When you reopen mail it will reindex your mail accounts and rebuild them.
  • Ernie Stamper Level 8 Level 8 (37,555 points)
    Remember when advising this action, to also point out that IMAP and Exchange account folders should be removed from the Mail folder -- see:

    http://docs.info.apple.com/article.html?path=Mail/4.0/en/14019.html

    IMAP encompasses MobileMe account folders, as well. With a single mailbox that needs reindexing you can use Rebuild instead of removing the Envelope Index.

    Ernie