7 Replies Latest reply: Oct 13, 2009 11:45 AM by philg1824
philg1824 Level 1 (5 points)
The 3Comm huawei E1750 USB modem works with Leopard, but does not work with Snow Leopard.
Any assistance re drivers etc would be much appreciated. The Huawei of 3 Comm web sites are not very helpful. The Huawai web site mentions a driver but downloading and unpacking does not help

Mac OS X (10.6.1)
  • Tim Haigh Level 7 (24,185 points)
    search this forum there are solutions to get a usb 3g modem working in snow leopard.
  • philg1824 Level 1 (5 points)
    Thanks for reply. I have searched and indeed I found a solution for the Three ZTE MF627 dongle. The Huawei modem is faster and hence I want to get this one to work but cannot, hence the request
  • Tim Haigh Level 7 (24,185 points)
    Have you used the driver from this page.
  • philg1824 Level 1 (5 points)
    Tim, thanks for the prompt and helpful response. I had not used that one and it looks really good. I downloaded it, uzipped it and it installed. I then connected the huawei modem and tried to connect but got " not phone service detected, try your phone line and try reconnecting. The light on the modem was originally green and had turned to a steady blue. I tried running the installation system on the 3 comm modem and it mentions it is installing another driver. How to I check the dongle is using the new snow leopard driver. The system still works with the original slower modem when I swop the sim card back over. Your assistance is much appreciated.
  • Tim Haigh Level 7 (24,185 points)
    remember to setup the apn on modem as per your provider details.

    I just use the driver not the 3rd party software.

    once the driver is installed I rebooted my mac plugged in my huawei modem.

    Then open network prefs.

    I created a new network location and called it HSDPA.

    My modem was recognised as a network port. So removed all the other ports, airport, ethernet etc

    My provider is t-mobile

    So I created a modem configuration called t-mobile but that is not necessary.
    (the following details may be provider specfic'

    telephone number *99#
    account name blank
    password blank

    check the box 'show modem status in menu bar'

    Then i click 'advanced'

    in the modem tab

    Vendor : other
    Model : HUAWEI Mobile Connect 3 G modem

    leave everything else as default click ok

    I apply this setup, then from the menubar click the phone icon and choose connect

    worked first time for me.
  • philg1824 Level 1 (5 points)
    Thank you for the excellent instructions. I followed them but it still says phone service unavailable or similar. I wonder if it is because 3Comm have not activated the faster service with the Huawei modem, but have the slower service with the other 3Comm modem. I will check with them. (i moved from one contract of 3 gb a month download to the higher download 15gb and got a faster modem in the package. Sounds odd, but worth checking out.
    Thanks for your help. Will update you when I get a reply and when it works
  • philg1824 Level 1 (5 points)
    Spoke to very helpful 3Comm guy. Suggested going to advanced settings and select network advanced ignore dial tone when dialing and use huwaie modem in model. Still did not work. When I selected 3 connect modem script it did work. Thanks for all your help