3 Replies Latest reply: Oct 11, 2009 1:56 PM by kaotik2003
mcconachie Level 1 Level 1 (5 points)
I am currently running OS 10.5.8 with mail 3.6 (936) which I believe is all current.

I have this intermittent problem when I try to either delete mail or move emails from my inbox to a mailbox - the mailbox can be on my mac or on the server. When I attempt to delete or move, the message will disappear from my inbox, but the count of the number of messages in the inbox doesn't change and the message isn't in its destination (trash or folder). When I click away from the inbox and back again the message is back in the inbox.

The problem seems to happen when I have more than 100 messages in the inbox, but can sometimes happen with less. And sometimes doesn't happen even if there are a lot of messages.

If I go to MobileMe webmail I can do whatever to the messages and it is reflected in Mail (but I can't move the messages to the mailboxes on my mac where I store a lot of archive messages.)

Any suggestions? Is there a preference setting I should fix? Is this a known bug?

Thank you!

macbookpro, Mac OS X (10.5.8)
  • kaotik2003 Level 1 Level 1 (30 points)
    Try to erase the account and configure it again.

    It seems that you have a sync problem with mobile me imap server. When you delete the message it does not sync with the server, so at next sync it will redownload the mail message.
  • mcconachie Level 1 Level 1 (5 points)
    Do you mean to delete the account from Mail and re-set it up?? Will I lose any data if I do that? I've been having this problem for quite a while and I think I may have done this in the past, but I don't remember.
  • kaotik2003 Level 1 Level 1 (30 points)
    What I advise you to do before erasing the account is to make a copy of your Mail folder that exists on your User/Library folder to your desktop.

    By doing this you will always have a copy of all of your mails in your Desktop.

    One other thing you can also copy to your Desktop is the com.apple.mail.plist

    That file has your mailbox configuartions.

    After that you can try to erase the mailbox and recreate it or to erase the plist from the Preferences folder of your user Library and set up the account again.