1 2 Previous Next 21 Replies Latest reply: Nov 10, 2009 4:33 PM by sneude Go to original post
  • 15. Re: Epson rx680
    jmf007 Level 1 Level 1 (10 points)
    another 680 disaster here. very disappointing and will never buy Epson again. Is it me or does epson and its site seem like its from 1995?

    I bought the printer from apple's site as I would have guessed that apple would only sell third party products if they were 100% compatible. sadly mistaken, for starters it doesn't work with airport express. Epson is a terrible product and has worse support, but I really ding apple for blindly selling products that aren't 100% compatible. I hope apple isn't getting to big for its own good and support/reliability starts to move towards MS quality.
  • 16. Re: Epson rx680
    cjaiv Level 1 Level 1 (0 points)
    Thanks for the help. After re-installing the Epson printer drivers, checking all my connections, re-installing the drivers a second time, and still getting that **** error message, I was getting very frustrated. But your solution of simply going to the Print and Fax section of System Preferences, right-clicking on the printer, clicking on "reset printer system", clearing out the printers, and then choosing/adding the RX680 printer, worked GREAT. Thanks very much.
  • 17. Delete & Re-Add Printer Worked!
    r_marshall Level 1 Level 1 (0 points)
    Had exactly the same problem. The "rastertoescpII failed" error appeared after updating to Snow Leopard. Updating to Epson's 10.6 driver set didn't fix it. Deleted the printer and re-added it, presto, working great!

    Thanks so much for this thread post!
  • 18. Re: Epson rx680
    sacapron Level 1 Level 1 (0 points)
    I had the same problems, I got this advice from epson and it worked for me when nothing else did. I also did the 10.6.1 update from Mac as well.

    Re-add print queue

    Turn off the printer.
    Delete the print queue and remove the printer from Print & Fax by clicking on the minus button under the list of printers. Click OK to confirm the removal.
    Click on the Apple icon in the upper left corner of Finder and open System Preferences.
    In the System Preferences window, click on Print & Fax.
    Note: Do step number 5 only if this is the only printer currently installed in this computer.
    Press the CTRL button on the keyboard and click on the white box on the left (where the printers should be listed) and click on RESET Printing System.
    Turn on the printer. Click the button to enter the Printer Browser window. The system should automatically detect the printer. Click the Add button.
    If the printer driver for your model is included in Snow Leopard (not downloaded from the Epson website) and the system does not add the printer or if it adds it using the Gutenprint driver, contact Apple for assistance. You may need to reinstall the Epson drivers provided with Leopard.
  • 19. Re: Epson rx680
    Deonj0 Level 1 Level 1 (0 points)
    I just wanted to show my appreciation, it worked. i liked it so much, i registered, just to say thank you. it may seem like a small thing to you (me registering), but to me, i appreciated it so much that i had to say something. thanks again
  • 20. Re: Epson rx680
    hamsammich75 Level 1 Level 1 (0 points)
    Thank you so much sacapron, that fixed the issue. I was trucking right along even well after the Snow Leopard install, and this suddenly happened when I applied the Apple Software Update for my Artisan 800.

  • 21. Re: Epson rx680
    sneude Level 1 Level 1 (0 points)
    Where did you find the driver software? I can print (Epson SX600FW) but I can't find the scanner software anymore.
1 2 Previous Next