Previous 1 2 Next 24 Replies Latest reply: Aug 18, 2010 8:09 AM by dbasskin
Tim Verpoorten Level 1 Level 1 (95 points)
I've been using STP for many years. I updated to Snow Leopard and made sure all myoftware updates were current. When I went to record via my Mackie Onyx Mixer and Heil PR-30 mic, the results were a distorted sound with my voice slowed way down on top of the background distortion.

1. I changed wires and mics and mixers, no change
2. I rebooted and I upgraded to Final Cut Studio 3, no change
3. I changed to analog recording from Firewire, no change
4. Finally I tried recording in Garageband and QuickTime Pro. Both of those record just fine with no problems.

What is it in STP that is causing this distortion and drop in speed of recording?

BTW.. When I monitor my recording I can hear the distortion in the monitoring, not just the playback.

MacPro 2.66 Core2 Duo with 5 Gigs of Ram, Mac OS X (10.6.1), Final Cut Studio 3
  • Eric Lewis Level 1 Level 1 (20 points)
    Glad I came across this post as it gave me a clue as to what the issue could be. I have a bit a different case but it's related to recording as well and I was able to fix it.

    I was using Soundtrack Pro (vers. 2.0.2/ Final Cut Studio 2) for the first time to record and experienced a distortion/delay issue as well. I'm recording from a turntable (Stanton T.92USB) with USB output, to digitize my vinyl collection. Out of the box, I plugged it in, fired up STP, hit record and everything worked like a charm. I noticed though, that it recorded at 44.1kHz even though the project was set to 48kHz. So I tried to find out why as the turntable should be able to output 48kHz. I clicked on the "Device Setup" in STP which launches the "Audio MIDI Setup" application from the Utilities folder. Indeed, the default input from the turntable was set to 44.1kHz, so I switched it to 48kHz. That's probably when things got hairy.

    Going back to STP, trying to record again, the signal I got in sounded like there was tons of dust on the record and the needle would jump intermittently. The record I had just cleaned and by looking at the needle, it didn't seem to jumping either... and I just recorded the song couple minutes ago and everything was fine. So I didn't quite understand what the issue was. I deleted the STP prefs and checked under "Device Setup" that everything was back to 44.1kHz but I still had the distortion. So I thought it would be related to the turntable or the needle. I tried other records and all sounded distorted and jumpy.

    Seeing this post where you said that QuickTime recorded fine, I tried that as well and that did work just fine. So I knew the Audio Units must have gotten messed up when changing the input. For some reason, this only seemed to have affected STP and not systemwide. Anyways, in order to reset weird cache issues, is to use OnyX, a free Mac system utility. Here is what I did: open OnyX, go to "Cleaning" tab, under "System" only select Audio Components, under "User" only select Audio Units, under the remaining tabs "Internet, Fonts, Logs, Misc" disable everything and then hit "Execute". This will require a restart. After that, everything was back to normal for me.

    So my guess is, if you do have external Audio hardware that you need to configure in the "Audi MIDI Setup", there might be a bug in Snow Leopard that affects Soundtrack Pro. Maybe resetting the Audio Units fixes this but in any case, submit feedback for STP at http://www.apple.com/feedback/soundtrackpro.html so it might get resolved in a future update.

    Good luck~
  • Tim Verpoorten Level 1 Level 1 (95 points)
    Eric,
    That makes a lot of sense. I use Onyx and tried what you suggested, but in my case it has not made a difference.
    I'd appreciate any other great ideas like this that anyone else might have for me to try.
    Thanks again Eric for the information, I'm sure it will benefit someone else that has a problem similar to mine.
  • Eric Lewis Level 1 Level 1 (20 points)
    Tim, that's unfortunate that this doesn't work for you. It's weird in general that it would work for QuickTime and any other recording software but STP having issues. Not sure how you're connecting your hardware, it could be USB related as I connected via USB. I have not tried this but see whether you could record by just using the mic input of your Mac to get sound in. That way, you would at least know whether it's an interface issue with STP or solely software. If interface related, you could try with other inferfaces to bring sound in... analog, s/pdif or FireWire maybe.
  • Tim Verpoorten Level 1 Level 1 (95 points)
    I know it's very odd.
    I already disconnected the Firewire connection and ran a direct analog connection into the audio in port of the Mac Pro and still had the same troubles. Changed Mics, changed Mixers, changed cords.

    I ever tried Adobe Soundbooth and it works fine. The only application that causes this distortion and speed warping is STP. I upgraded to the new version of FCP studio, I also took the update last week for the Pro apps, still the distortion.
    It all seemed to happen with my Snow Leopard upgrade. Not 100% certain that's it, but I think it was the only change made from the time it worked well (I've been using STP for about 3-4 years now) until it came up with this problem.
    Any ideas at all?
  • Tim Verpoorten Level 1 Level 1 (95 points)
    I'm still battling this problem.
    Every other Mac software I've tested for recording works, only STP is causing the distortion and speed changes I described above.
    Is there any files in STP that are linked to the recording aspect of the application that may be corrupted? Anything that would have not been overwritten when I updated to Snow Leopard?
  • Louis Tristan Level 1 Level 1 (5 points)
    Am having the same problem tooooo. At first I thought it was M-Audio but now i've come to the conclusion that it's snow leopard.

    I have a logitech usb skype headset, when I try to record in stereo it works with soundtrack pro. However with the built in mic it does not work to record in stereo. After pulling out the USB headset was able to use the internal mic on mac to record in stereo but after reboot no. Leopard killed something with the audio being able to recored in stereo.

    Here's an issue being shared with m-audio/soundtrack pro users. Still can't record in stereo using my m-audio firewire solo.

    So try it.

    1. Plug in a usb mic/
    2. Select record in stereo/
    3. Record something/
    4. Pull out USB mic/
    5. After soundtrack pro crashes relaunch and now you can record in stereo until you reboot mac.

    http://forums.m-audio.com/showthread.php?p=65875#post65875

    Message was edited by: Louis Tristan
  • mbools Level 1 Level 1 (0 points)
    Exactly the same problem here. Upgraded to Snow Leopard, upgraded STP 3.0.1. Sound recording now distorted and slowed down as described.

    Tested equipment by recording using QuickTime Pro and everything is fine, records perfectly.

    Used internal Mic on laptop and this also produced distorted and slow recording, so the problem is not localised to my external mic it definitely seems to be STP (or perhaps Snow Leopard) causing the problem. I doubt it is Snow Leopard causing the problem as everything else seems fine.

    Playing back the recordings using QuickTime Pro reveals that the recording itself is distorted, and recordings made in QuickTime Pro played back through STP seems fine also, so it's not a playback issue.
  • Tim Verpoorten Level 1 Level 1 (95 points)
    This issue has been bothering me for several months and I've still not fixed it. Tried replacing all hardware options to make sure it's not hardware. Deleted audio caches, deleted STP settings, did all I could think of. It's only screwed up in STP recording.
  • drew.be Level 1 Level 1 (0 points)
    check your Audio MIDI setup. I tweaked mine and got my internal mic working without distortion.
  • Tim Verpoorten Level 1 Level 1 (95 points)
    To this point, nothing has been solved with this problem, any other ideas? Thank you for all the feedback.
  • Tim Verpoorten Level 1 Level 1 (95 points)
    Ok, here's an update. After Installing a new pave and nuke version of OSX Snow Leopard and then installing a fresh install of FCP Studio, I figured the problem was solved. STP started to record without any distortion. Then I noticed it was only recording on the left channel, the right channel seemed almost dead, only a whisper at the most.

    I checked all my settings and finally in the recording tab of STP, I turned the right channel to 1 to match the left channel, so I'd get at least one channel recorded. Well the distortion came back when I did that. It doesn't matter what I use to record, only the left channel records in Stereo setting and if I use Channel 1 for both left and right, the distortion comes back.

    Does this point to anything specifically? Thank you
  • Soundaround Level 1 Level 1 (55 points)
    Do the same problems occur when you record to a mono channel?
  • Tim Verpoorten Level 1 Level 1 (95 points)
    No, When I choose a new audio track and I make it a Mono recording, the sound is fine. Only when I choose stereo I have the right channel (#2) dead and when I choose both left and right to be either both #1 or #2 I receive the distortion. What caused this problem with stereo and how can I fix it?
  • Soundaround Level 1 Level 1 (55 points)
    Why do you want to record a mono mic to a stereo channel?
Previous 1 2 Next