10 Replies Latest reply: Jan 29, 2010 10:31 AM by Working Stiff
nas_nap Level 1 Level 1 (0 points)
Recently I upgraded my MacBook to Snow Leopard. After the upgrade i decided to install my X5470 multifunction printer (printer, scanner Fax). Unfortunately I can install it only as a printer by using Leopard's built-in driver. However if I do this I have no scanning capability, since no devices appear in Image Capture Application.
So, I visited Lexmark's site and I downloaded "Lexmark5400_Web_Installer10.5.dmg. When I try to install it I receive the following message:
"Lexmark 5400 Web Installer 10.5 can’t be installed on this computer. The specified message could not be found for the index 17."
Any ideas how can I make the scanner work?
Thank you all in advance for your time.

MacBook 2Ghz intel core duo -- 2GB Ram, Mac OS X (10.6.1)
  • JasonFear Level 5 Level 5 (4,935 points)
    Hi nas_nap,

    I did a little digging and found some good links for this issue. First off, the application you're trying to download and install is for 10.5 (Leopard) and you're running 10.6 (Snow Leopard). It's very possible that the installer is checking for Leopard architecture, which you don't have.

    Apple has an article regarding printer support via Snow Leopard. (http://support.apple.com/kb/HT3669#lexmark)

    It indicates the 5400 series offer scanning and printing support. In addition, Lexmark's article also indicates Snow Leopard compatibility. (http://support.lexmark.com/index?page=content&id=OS8&locale=EN&userlocale=EN_US)
  • nas_nap Level 1 Level 1 (0 points)
    Hi JasonFear and thanks for the info.

    I know that my current os is newer than Lexmark's driver version. I've also read the printer support article and I know for a fact that Lexmark's printing ability is guaranteed through Snow Leopard. But although I am able to print, I still cannot manage to scan, since my device is not recognized and this is the reason why I chose to download Lexmark's web installer for 10.5.
    I don't know whether I may be doing something wrong. Any ideas about making the os recognize my printer as a scanner as well would be appreciated. Thanks again
  • n8hawk Level 1 Level 1 (100 points)
    Same problem here, if anyone can help.
  • nas_nap Level 1 Level 1 (0 points)
    I contacted directly Lexmark through their chat support and their reply was that for the moment the do not have new drivers for 10.6. When I asked them if this means that there is no way for me to scan they simply stopped replying.. Nice support isn't it??
  • n8hawk Level 1 Level 1 (100 points)
    Yeah, what a bunch of tards. I really supported Lexmark printers until recently. I used to tell people who were looking for hardware "Get a Mac and a Lexmark printer." Now I won't recommend Lexmark. My scanner now works about 40% of the time. I have to reinstall the drivers, reboot, and pray that image capture recognizes it. It's gotten to the point that I'm just booting into XP when I want to use my **** scanner. It's frustrating.

    Message was edited by: n8hawk
  • myhighway Level 5 Level 5 (7,270 points)
    To be fair about it, there are lots of things which even Apple no longer supports:D
  • vlakdawa Level 1 Level 1 (0 points)
    Hi nas_sap:

    I had the same problem of printer driver for printing using the AEBS extreme base station for my X5470 Printer. It only worked with the USB connection. I was using the Lexamrk drivers as posted on their websit.

    This was few months ago. But just recently using the apple software update I installed the Apples' Lexmark 5400 Series driver for OS X 10.6.1. Here are the results.

    If the printer is connected to USB port, I can both print and scan. The functionality is visible in the print utility top left side, where I can select either the printer or the scanner.
    However, if I am using airport I am able only to print wirelessly, but the scanner function is not available.
    Hope apple will address this in the near future. Maybe this information will be helpful. Cheers.
  • BalooBBear Level 1 Level 1 (0 points)
    I had the same problem (printer worked, but scanner and card readers did not) with my Lexmark X5470 after updating to Snow Leopard. Lexmark CS (or lack thereof) was of no help. For months, I haven't needed the scanner until today, so I dug around Lexmark's website. I found that on 11/19/2009 Lexmark released a driver file called "Lexmark 5400 Web Installer 10.6.dmg". With my hopes up, I downloaded and installed the driver. First, the bad news: it installed a "new" 5400 Series printer (in the Print & Fax Preference tab under System Preferences) but with very few options, and the tab for Scan was gone. My "original" Lexmark 5400 Series printer was listed still, but the Scan tab went to a screen that continued to say Scanner not Connected. Now, the good news: I realized after installing the driver that I hadn't restarted. So, restart I did, and, what do you know? I went back to the Print & Fax Preference tab, and I saw that the printer listings (both my original one and the new one it created) had functioning Scan tabs. In addition, the Image Capture application works once again with the X5470. Thus, I am now back in business with full functionality with the printer, scanner, and card readers.
  • vlakdawa Level 1 Level 1 (0 points)
    @BalooBBear

    Does this mean that you are having full functionality to print and scan over the air using Airport Extreme Base station for the Lexmark X 5470 or only using the USB connection as I have been seing. Please reply.
  • Working Stiff Level 1 Level 1 (0 points)
    FYI, Lexmark has pulled the 10.6 dmg mentioned above. Don't know when they did.
    If someone has it, I'd like it.
    coolascanbe [at] hotmail.com

    Many thanks.
    Working Stiff