6 Replies Latest reply: Jan 24, 2010 10:25 AM by Forest Child
islandsmurf Level 1 Level 1 (0 points)
I import CDs that I own every so often, and sometimes I get a message that I "don't have access to your iTunes media folder or a folder within it. To change permissions, select your iTunes Media Folder in the Finder, and choose File > Get Info". But, no matter what I do, I can't import those CDs into my iTunes library. It only happens with certain CDs - as well as some songs that I have stored on a backup drive from my PC days - and I have no idea why. What can I do? I'd love to be able to import a bunch of older (80s and 90s) CDs...that I bought!

Message was edited by: islandsmurf

Mac, Mac OS X (10.6.1)
  • Chris CA Level 9 Level 9 (77,960 points)
    Did you select your *iTunes Media Folder* in the Finder, and choose File > Get Info then set it so your username has *Read/Write privileges* then click the gear and *Apply to enclosed items*?
  • islandsmurf Level 1 Level 1 (0 points)
    Not sure what you mean by 'click the gear'. Do you mean the CD drive? Usually I can do a simple 'highlight and copy over' into my ITunes Library - but for some reason, the CD is read (I can see it in iTunes), but iTunes won't let me copy the songs over.

    Really appreciate the help with this, BTW.
  • Chris CA Level 9 Level 9 (77,960 points)
    Quit iTunes.

    Open a Finder window.
    Go to \Music\ folder.
    Right click the \iTunes\ folder and *Get info*.
    Go to the *Sharing & Permissions* tab.
    Make sure yo username has *Read & Write* privileges.
    Directly below are + and - signs next to a little gear with a down arrow.
    Click the gear and select *Apply to enclosed items*.
    Open iTunes then try again.

  • Henry Burgess Level 1 Level 1 (0 points)
    Hi Chris
    I have the same problem. Have followed all steps to change permissions several times, but still can't import many CDs. What to do....?
    Rob
  • STONES2 Level 1 Level 1 (0 points)
    Hi,

    Chris is correct in what he is saying. I had exactly the same problem. I think it may be because I copied some music from my old computer onto my new iMAC.

    The key thing I failed to do was to click on the padlock and then you have the options on the gear available, otherwise they are greyed out. Once I had pushed the changes to everything in my iTunes folder this resolved the issue.

    Cheers, Stuart
  • Forest Child Level 1 Level 1 (0 points)
    Not all permissions are altered as stated above. If you are still having problems (probably with just the odd CD which was on your list before) you need to look in your iTunes Music folder (homeuser/Music/iTunes/iTunes Music) within the iTunes folder. There you need to look for a copy of the CD or mp3 file you are trying to upload. If it is already there, highlight it and 'get info' where you will see that despite unlocking the permissions, the file permission for 'staff' (or some other user which you may have defined) is greyed out and locked to 'No Access'. If this is the case, simply delete the whole folder for that CD then try uploading again.

    Worked for me after trying many times to change folder permissions on each and every file without success.