7 Replies Latest reply: Jan 6, 2010 1:26 AM by Martin van Diemen
Martin van Diemen Level 1 (5 points)
Hi,

I'm facing two problems after I've enabled extended attributes on a Xsan Volume. When I connect from a Windows machine to a Mac server that is resharing the Xsan Volume by making use of SMB I can do two things:

1. I can move files on the share but I cannot move it from the share. I get the message:
"Error Copying File or Folder
Cannot copy FILENAME: Cannot find the specified file.
Make sure you specify the correct path and file name."

If I move the file on the Mac OS X Server to a SMB share I get the message:
"The operation cannot be completed because the item "FILENAME" is in use."

2. I cannot copy the file on the share or copy it from the share.

I can delete the file.

I'm trying to move it to an NTFS volume.

Martin

Mac OS X (10.5.8)
  • Mathieu Mauser Level 2 (210 points)
    Have you tried different versions of Windows to see if it's the same behaviour? (XP, XP64, Vista, Windows 7, etc). How about from a Mac connection via SAMBA?
  • Martin van Diemen Level 1 (5 points)
    Hi Mathieu,

    I've tried this on several Windows computers but unfortunately with the same results. If I try this on a Mac via SMB the problem doesn't seems to appear.

    I have been in contact with Apple this week and they confirmed that they could reproduce the problem. It is now a case for the Apple Engineering Team to find a solution.

    Thanks.
  • Curious Gene Level 1 (10 points)
    I ran into the same thing. You need to disable Extended Attributes in Samba's config file. Edit /etc/smb.conf with your favorite text editor, and change this line:

    ea support = yes

    to this:

    ea support = no

    And the restart SMB. You might also need to change stream support to no as well. I just turned off both of them. The problem is that Windows doesn't know how to handle the extended attributes, so it gets most of the way through copying the file, and then dieswhen it tries to deal with those attributes.
  • Martin van Diemen Level 1 (5 points)
    Great discovery! I changed them both to no. Seems that this solves my problem as well.

    Thanks!
  • Mathieu Mauser Level 2 (210 points)
    It was my understanding that enabling Extended Attributes would make it easier for Windows clients to deal with files, but it seems to be clearly the opposite. If you diables EAs in Samba then are Windows clients only seeing partial files?
  • Paul McGrath Leeds Level 1 (0 points)
    We have just discovered this at our expense. We have a XSAN support contract and were having performance issues on our volumes one of their European engineers advised my colleague to apply extended attributes to the existings volumes but omitted to inform him of the SMB.CONF changes.

    After about a day we started to get the 'path to file not found' when opening any Office 2007 files.

    We have now been down for three days, 400 staff have not had access to their work. The metadata controllers were crashing, one volume could not be repaired so we have to recover 6TB onto another Promise RAID.

    This is hugely embarassing.
  • Martin van Diemen Level 1 (5 points)
    FYI.

    October 13th, 2009 was the day that I contacted Apple about this problem. I still have not got a solution provided by Apple. I did reply them the solution that [Curious Gene|http://discussions.apple.com/message.jspa?messageID=10532382#10532382] gave me.

    They told me to wait and lookup for an update. When Apple released Xsan 2.2.1 I could not find anything in the release notes regarding this problem.

    Today (almost three months later) Apple posted article TS3179: [Windows client unable to copy item from share point via SMB when native extended attributes are enabled|http://support.apple.com/kb/TS3179]