Previous 1 15 16 17 18 19 Next 280 Replies Latest reply: Feb 12, 2015 10:14 AM by Gwardlaw1 Go to original post
  • sampai jumpa Level 1 Level 1 (0 points)

    Hey guys....just tried the fix supplied by  txoovkav....posted in MARCH 2012 ...this has definately worked for my issue with mac book pro...makasi ...

  • mariane___ Level 1 Level 1 (0 points)

    Hey. I had this same problem: 2 years old MBP kept disconnecting me from the Internet every 10 minutes, although the airport kept saying I was connected. Went to the Apple Store, everything worked fine there (obviously). I tried a couple of the suggestions here, but what I think solved it is that tip from someone up there suggesting to: Go into Netweok Preferences >  Advanced > check the box "Turn Wi-Fi on or off" under "Require administrator authorization to" section. Since I did this it hasn't disconnected at all (knock wood) and it's been a whole day. It seems like even if the Airport wanted to disconnect, the computer won't let it without a password so it stays connected. Good luck! If this doesn't work, I will go nutz.

  • killuazhu Level 1 Level 1 (0 points)

    My similar problem is resolved after setting router's broadcast channel from 1 (default) to auto.

  • mcolombe Level 1 Level 1 (0 points)

    Does Apple ever look at these postings???

    I have the same problem with the Internet constantly disconnecting from my desktop Mac.  It had never done that before...It would really be nice to have an answer to this problem!!!!

  • ajnspeak Level 1 Level 1 (0 points)

    I had this problem with my MacBook Air laptop so went to my Apple store and they told me the following, which has worked for me:

    1. Alt-Click on the reception bars at the top of the screen. This should show you the routers you are connected to plus any nearby routers. It should also show you the Channel of your router and the others. Note down all the channel numbers. Ideally you need to reset the channel number of your router to at least 3 channels away from any other.

    2. Go online and find instructions from your internet service provider as to how to change the channel on your router. (Mine was BT in the UK and it was quite straightforward). You can experiment with different channels to see which one works. I changed mine from 11 to 1.

    Hope this helps.

  • JB-MBP13 Level 1 Level 1 (0 points)

    Got my MBP-13 in July 2012... have had no issues until 3 days ago... all of a sudden network performance over Wireless was terrible. Symtoms included the following:


    + not able to connect to my access point (although all my other devices in the house were having no issue)

    + when I was able to connect sessions would time-out in my browser pages would not load

    + when I opened up a Terminal window (when connected) and started pinging another host/device in my house I was averaging 25% packet loss and highly irregular response times... in some instances up to 2.5 seconds of delay


    It was completely insane not to mention aggravating.


    After scouring the boards and trying a bunch of stuff... this is what worked for me... I changed the 'channel' that my wireless router was configured to use. My Alcatel/Lucent device provided by my provider by default operates on channel 6 (Bell Canada)... I reconfigured to function over a different channel and problem solved.


    It's been 30 minutes and the problem has gone away as quickly as it arrived. I have been running continuous pings 0% packet loss AND I am backing up to my Time-Capsule at the same time.


    I am thinking something changed in my immediate area (neighbour did something, or a new device added) which created contention on the existing Operating Channel.


    Glad to have this solved.


    Questions please let me know.

  • Capriace Jones Level 1 Level 1 (0 points)

    Using MBP 13"  Version 10.7.5

    Connecting to Nokia Lumia 920 Internet Sharing (Wi-Fi). Getting MBP Wireless disconnections & drops issues like everybody else (almost). Tried investigating the root causes (via logs, network monitor, Inssider, applepushd, Channels etc) to no avail. Tried tons of solutions on the Net......remove airport keychains, plists, turn wi-fi on/off...None of it worked.


    My Solution

    Downloaded ControlPlane (Context Switcher)


    As per Feature list - Has an Option - monitor Active Network Adapter i.e. Link

    Adding to my woes - if I selected that Option it would crash!!!!!!!


    So went back to the basic - Used ControlPlane with scripts


    Step 1

    Install ControlPlane


    Step 2

    ControlPlane Preferences/Context - Create 2 Contexts

    1. Connected (You can use your own)
    2. Disconnected (You can use your own)


    Step 3

    ControlPlane Preferences/Evidence

    You can select - Active Network Adapter (If you select this & ControlPlane does not crash then kindly follow the controlplane documentation to move forward). Unfortunately the above crashed for me!!!!!


    I selected - Shell Script


    Step 4

    ControlPlane Preferences/Rules

    If you selected - Shell Script as Evidence  then you will get - "Add Script Rule" when you click the "+"

    Click Add Script Rule

    Browse for the shell script - Select (2 Scripts - Provided below)


    • Run Script - 5 Secs
    • Confidence - Full
    • Context Connected
    • Click OK

    Step 5ControlPlane Preferences/RulesClick Add Script RuleBrowse for the shell script - Select (2 Scripts - Provided below)

    • Run Script - 5 Secs
    • Confidence - Full
    • Context Disconnected

    Click OK


    Step 6

    ControlPlane Preferences/Action

    This is only for testing purpose you can disable this later on if you are successful. You can ofcourse use the rest for any other purpose I just used it for this solution

    Click "+"

    Misc Action - Speak Phrase

    Speak Text - Hellish

    At context - Disconnected

    On Arrival

    Click OK


    Step 7

    ControlPlane Preferences/Action

    Click "+"

    Misc Action - Speak Phrase

    Speak Text - Heaven

    At context - Connected

    On Arrival

    Click OK


    See how it goes!!!!!!! Works for me!!!



    Save the scripts anywhere on your MBP


    Shell Script 1 - Checking for Wireless connection i.e. Active


    IPADDC=$(networksetup -getinfo wi-fi | grep -c 'IP address:')

    if [ "$IPADDC" -eq "2" ]


    exit 0


    exit 1



    Shell Script 2 - Checking for Wireless connection i.e. if disconnected - Connect again

    (Fairly Simple for my usage only. You can modify as required by you)





    IPADDC=$(networksetup -getinfo wi-fi | grep -c 'IP address:')

    if [ "$IPADDC" -eq "1" ]


        if networksetup -setairportnetwork $AIRPORT $WIFI_NETWORK_NAME $WIFI_PASSWORD | grep -i -a "Failed" ;


        exit 0


        exit 1



    exit 1


  • NerdofNerdy99 Level 1 Level 1 (0 points)

    I had the same issue, but it turns out my router was dying.  I tried all the solutions listed here and nothing kept it from disconnected intermitantly.  I finally decided to buy a router just to check it and it worked!  I'm sure my case is very unique, but if anyone else can't seem to get it to work, I thought I'd share.


    Media Link Router

  • Phil Shirley1 Level 1 Level 1 (5 points)

    I've had the same problem over and over. Restarted my computer and it worked for awhile. I think a may figured out the problem. I was using alot of bandwith at the time and it kept disconnecting every time I was using alot of bandwith. So it's been 20 min and I've been fine.

  • MamaOwl Level 1 Level 1 (0 points)

    I can't remember who suggested this but it worked like magic for me. I went into the system prefs>Network>Advanced>TCP/IP


    The default was DHCP in the pull-down menu. I copied the IP address and switched in the menu from DHCP to Manual. I pasted my IP address in the empty slot -- I had to change the last three digits, I guess because my machine was already occupying that address -- and applied the changes. Voila.


    My problem had started two days ago and I had to turn Airport off and on before I could click on a link.


    If this didn't fix it I was just going to get a wifi dongle.

  • Xzis Level 1 Level 1 (0 points)

    The issue is do to an update.  Mountain Lion OS X 10.5.8 will natively work.  However, do not install the update for the Airport Utility especially 6.3.1 because this is what disables your wifi.  Hide this update until a number higher than Airport Utility 6.3.1 is available and try that one.  Anyway, this is what is causing the grief.

  • Xzis Level 1 Level 1 (0 points)

    Typo on numbers sorry. I meant Mountain Lion OS X 10.8.5.

  • Laura Goodrich Level 1 Level 1 (0 points)

    Txoov Kav

    I was so excited about your suggestion below. Hoping it would solve the "fall off the network" problem, but the "Turn Airport on and off" option is grayed out for me. 

    Not sure how to change this.  Any suggestions?  Laura



    "It happens to me, too.  I solved it by click on Network, click on Advanced, and down where it said "Require administrator password to:" I checked on "Turn AirPort on or off"


    Doing it this the AirPort wifi cannot be turned off by the computer without a password.  Hope this helps you all.  It sure helped me."


    Good day

    Txoov Kav

  • techguy3347 Level 1 Level 1 (5 points)

    Could you possible have too many wireless network profiles on your Mac? There is a way to fix that if you upgrade to mountain lion that should fix your problem. If you  have  the Mac App Store then you can use your Apple ID and buy the

    Mountain lion upgrade for $19.99 on the Mac App Store .

  • truegrobo Level 1 Level 1 (0 points)

    Since the most recent update Lion OSX 10.8.5 my wireless has been disconnecting randomly.  My netwrok is available and I can reconnect to it by clicking on it.  Have Airport Utility 6.3.1.  Never had a problem with it before, only since update... am I missing something?