Previous 1 2 Next 29 Replies Latest reply: May 16, 2013 1:17 AM by Marco2610
robandkate Level 1 Level 1 (5 points)
I am unable to change the "open with default" appliacation and it is really bugging me. I have ticked the option to always open with said application however when I click on a file it defaults to another application
any ideas????

mac 20" 2.4 ghz 3gB + MBP 15" 2.66 ghz 4gB + iPhone 3G 16gB = :-), Mac OS X (10.5.6)
  • V.K. Level 9 Level 9 (56,130 points)
    delete the file /users/username/library/preferences/com.apple.launchservices.plist and try again.
  • Steve Patt Level 1 Level 1 (30 points)
    I have the same problem, and this "fix" did not work for me.
  • David Sanger Level 1 Level 1 (15 points)
    fix did not work for me either.

    any other suggestions. Changing default app only works for one file, Change All is dimmed
  • cboody Level 1 Level 1 (0 points)
    I've reported this problem since OS 10.4. No help ever out here. The problem went away with Snow Leopard. I installed Parallels and now the problem is back. I can change each file, but the problem is the OS magically changed the default on hundreds of my files!
  • ichingboy Level 1 Level 1 (0 points)
    Try this out:

    1) click once on the file in Finder
    2) choose File -> Get info (or Apple+I)
    3) select the application you want to open that file under "Open with"
    4) click on "Change All..." to apply this globally
  • macjack Level 9 Level 9 (50,625 points)
    It sounds like LaunchServices to me also. These are only cache files but can get corrupted. V.K. gave you the local file but this command will also rebuild the system level file.
    Launch /Utilities/Terminal and copy & paste this at the command line to rebuild LaunchServices:


    Code:

    <pre class="alt2" style="margin:0px; padding:3px; border:1px inset; width:640px; height:34px; overflow:auto">
    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchSe rvices.framework/Versions/A/Support/lsregister -kill -r -domain local -domain system -domain user
    </pre>

    Then press return. Wait until terminal returns to the command line. Quit Terminal. After that, log out and back in or restart. Let us know



    -mj
  • davlab Level 1 Level 1 (0 points)
    I've been having a problem, since installing Snow Leopard, with one app (VectorWorks 2009) refusing to set default app to the current version. I keep 3 versions installed for backward compatibility.

    Thanks—your terminal command fixed this problem.
  • Walter Beagley Level 1 Level 1 (15 points)
    The suggested terminal command did not appear to have any effect. In my case some types of files can have their default applications changed, others cannot. One program that opens 3 different types of files, can be set as the default for one of these file types. Individual files of the other two filetypes can be set to opened by the application in Get Info. But if I click on "Change all", the default specification immediately returns to its previous setting. It would take months to change the "open with setting" for each file, one at a time.
  • geofftwibell Level 1 Level 1 (0 points)
    I had this problem in Snow Leopard when trying to change the default application for Word .docx files. The Get Info/Open With wouldn't let me select Pages for 'Change All'. I fixed it by first selecting Textedit.app then pressing 'Change All' (which was accepted) then selecting Pages.app which this time was accepted when clicking 'Change All'
  • Pstjean Level 1 Level 1 (0 points)
    I have the same problem for a few users.

    .eps will always open in preview even if i do Get info > Open With Illustrator CS3 > When i click change all it turns back to preview...

    i have full access to the files.

    How cant i change them, its getting annoying
  • kagatone Level 1 Level 1 (0 points)
    Thanks! This worked for me.
  • kagatone Level 1 Level 1 (0 points)
    I meant to address that to ichingboy's input above
  • Adriaan Renting Level 1 Level 1 (5 points)
    macjack wrote:
    It sounds like LaunchServices to me also. These are only cache files but can get corrupted. V.K. gave you the local file but this command will also rebuild the system level file.
    Launch /Utilities/Terminal and copy & paste this at the command line to rebuild LaunchServices:


    Code:

    <pre class="alt2" style="margin:0px; padding:3px; border:1px inset; width:640px; height:34px; overflow:auto">
    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchSe rvices.framework/Versions/A/Support/lsregister -kill -r -domain local -domain system -domain user
    </pre>

    Then press return. Wait until terminal returns to the command line. Quit Terminal. After
    that, log out and back in or restart. Let us know


    I only had to do the above command in the terminal window to solve my problem. I didn't need to log in or out or anything. I'm not sure what lsregister does, but it fixed it. Thanks!

    My problem was with XML files, which were locked into having Dashcode as the default application from the moment I had Xcode installed on Snow Leopard.

    It works now with my favourite XML editor.
  • Adriaan Renting Level 1 Level 1 (5 points)
    This only worked for about a week, the problem is back now. The defaults for opening files like XML or TXT have all reverted back to Xcode tools, even while I haven't used it over the last week, and again when do Get Info on for example a XML file and I change the application to open it with, and then click on "Change All", it immediately reverts back to the Xcode defaults.

    This is very annoying.

    I'm going to try the lsregister solution again, but if it means I need to do that every week, I'll get mighty annoyed.
Previous 1 2 Next