3 Replies Latest reply: Oct 13, 2009 8:47 AM by kyleroden
kyleroden Level 1 Level 1 (0 points)
Hello

I ordered an SSD for my macbook pro yesterday, which I was planning on installing when it got here today. I use a shared folder on a windows PC for time machine, and after backing up over the network for the last time last night I decided to pop my os x disk in to make sure that I knew how to restore once I had the new hard drive in.

Well I was able to connect to my wireless network, but when I choose restore using time machine, the button "connect to network drive" is greyed.

I think I need to mount the drive via the terminal, but I've been unable to do that. In OSX i was connecting to smb://192.168.1.102 and mounting the "MacBook Pro Time Machine" share(I since added a share simply named "mbptm" to avoid spaces. I opened a terminal, and made a directory /Volumes/TimeMachine, this seemed to work. I then tried:

# mount -t smb smb://192.168.1.102/mbptm /Volumes/TimeMachine

This gives the error:

mount: exec /System/Library/Filesystems/smb.fs/Contents/Resources/mount_smb for /Volumes/TimeMachine: No such file or directory

I tried with afp instead of smb (which I dont think will work because its an NTFS windows drive) and got:

AFPMountURL returned error -1069, errono is -1069

If anyone has any ideas I'd appreciate it. I don't have an external hard drive handy. The computer name of the windows PC is MEDIACENTER-PC, and the share gives access to "Everyone", so no username/password should be required

pc
  • BobHarris Level 6 Level 6 (15,905 points)
    Do you have a directory /Volumes/TimeMachine BEFORE you issue the mount command?

    The mount command MUST have a directory to mount the volume on top of.

    If /Volumes/TimeMachine is your normal mount point, then you will want to remove that directory when you are finished with it. -OR- create a temporary directory you can mount on top of. That way you will not mess up your normal Time Machine backup mount point.
  • kyleroden Level 1 Level 1 (0 points)
    yes like I mentioned, I used mkdir to create a directory /Volumes/TimeMachine. I am sure that the command completed because issuing it again gives "directory already exists" error.

    Keep in mind that I am booted from the DVD. the working directory when I do this is a directory on the DVD.
  • kyleroden Level 1 Level 1 (0 points)
    I think i've found a clever way to circumvent this problem.

    What if i repartition my original hard drive into three. leave one partition for my current stuff, a second partition for the time machine back up, and a third partition as a bootable image of my OSX install DVD. Then I will temporarily disconnect my dvd drive and hook up the SSD and the HDD simultaneously, boot using the OSX install partition, and restore the time machine image to the SSD...

    Does anyone see a problem with that? (I realize this isn't the correct forum for that anymore)