5 Replies Latest reply: Feb 3, 2010 6:56 AM by WinslowC
bottommiddle Level 1 Level 1 (0 points)
Hi there,

In order to pick up a wifi signal with my iPod touch, I almost need to be sitting on the Wifi router. Is anyone experiencing this poor range.

A friend with a 2nd Gen iPod touch has no trouble picking up networks from the same position as me.

From what I have seen online, they are using a different wifi chip in the 3rd Gen. Does anyone know if this is a known issue?

Thanks,
BM.

iPod Touch, iPhone OS 3.1.2, Mac Mini, Sony Vaio
  • c927hris Level 1 Level 1 (0 points)
    I have the exact some problem. I lost my 16gb Ipod Touch awhile back and bought a brand new Ipod 3rd generation 8gb...My 3rd gen will not pick wifi up in my room but my laptop and desktop both connect via WiFi..and my 16gb 2nd gen Ipod connected in my room.. It's F*ing dumb if you ask me. I don't pay over 200 dollars for a state of the art ipod not to have a good WiFi card. If you figure it out... c927hris@comcast.net is my home E-Mail. I will be dropping by the Apple Store tomorrow and I have your thread saved and will reply to this if i get any more information about it. Thanks. = ]]
  • luvlabs Level 4 Level 4 (3,610 points)
    Read through this article from the Apple Knowledge Base: http://support.apple.com/kb/TS1398

    I would do two things - 1) Power cycle your router (unplug it for a few minutes and restart it; 2) Reset the touch network settings.

    Between the two of those, it should start acting more normal.
  • WinslowC Level 1 Level 1 (0 points)
    Same issue here, though my Touch is a 2G, 16 GB. It had been working fine, with pretty impressive range, then suddenly it had a range of only a few feet. I've tried all suggestions, and the issue is true with all routers I've tried it on.

    Everything else is working fine, so I'm choosing to live with it...
  • Libby Johnson Level 1 Level 1 (5 points)
    Winslow, what version of the software is on your iTouch? I'm really suspecting 3.1.2 is causing my problem.
  • WinslowC Level 1 Level 1 (0 points)
    Sorry it took so long to wander back this way...!

    I was running 3.1.2 as well. Have just upgraded to 3.1.3, and now we'll see if that makes a difference. In my case I'm suspicious it's a hardware issue, but I would be happy to have a software fix instead.