8 Replies Latest reply: Dec 27, 2009 7:14 PM by mconstance88
iMacPodshuffle Level 2 Level 2 (305 points)
I just upgraded to snow leopard today and I'm already having some big problems. The worst of them is that my Lexmark X1185 won't work anymore. It used to work fine in leopard, but since I upgraded, I can't scan, print or do anything else.
Here's what I tried to do to solve the problem:
1. Tried to reinstall it from the manufacter CD (that didn't work cause snow leopard would crash every time I tried to open this CD).
2.Deleted the printer in "Print and Fax System" under system preferences, and then added my printer again (also didn't work).
3. Tried to look for drivers (the latest driver to the Lexmark X1100 series, wich my printer belongs, was for Tiger. It also didn't work.
Also, when I turn on the computer, I get this error message: “/Library/StartupItems/LexSleeperX.app” has not been started because it does not have the proper security settings."
Any ideas on how to solve this problem? I urgently need my printer....

Edit: I'm running 10.6.1, my Mac is an aluminum iMac, 2.4Ghz, 1Gb RAM

Message was edited by: iMacPodshuffle

 24" iMac mid 2007 (Aluminium), Mac OS X (10.5.8),  iPod nano 8Gb  shuffle 2Gb  iPod touch 32Gb
  • iMacPodshuffle Level 2 Level 2 (305 points)
    I was looking for third-party drivers for my printer, but I couldn't find any. Is there any driver I could use? Or could I use another printer's drivers?
  • iMacPodshuffle Level 2 Level 2 (305 points)
    My printer appears in the Fax and print menu, it's set up properly. When I try to print something, another window appears, and it says "printing" (that's the same window I used to see in Leopard, that gives you options to pause the printer, resume printer,delete, etc.). Everything is fine, except that... my printer doesn't print, nothing happens, just like it was dead. However, the problem isn't with my printer, since it works perfectly in the same machine in windows (boot camp).
  • iMacPodshuffle Level 2 Level 2 (305 points)
    When I try to print, as I said, nothing happens but if I wait for some time this error message appears: "unable to retrieve workset from PPD: /private/etc/cups/ppd/LexmarkX1100Series.ppd". Does anyone know what that means? Thanks in advance.
  • tigerug Level 1 Level 1 (0 points)
    hi guys!!!
    i have the same problem!!! tried everything but nothing works....
    any idea on how solve this problem???????
  • R-White Level 1 Level 1 (0 points)
    /usr/libexec/cups/backend/usb failed or Missing USB Class Driver

    I have been experiencing the same issues printer there but no one home!

    I have spent 6 (yes 6) hours on the phone to Lexmark today, they advised that it was due to the format of my Hard Disk not supporting their drivers. Apparently they do not support Mac OS Extended (Case-sensitive, Journaled) which means I will need to reformat the hard disk correctly to not be Case Sensitive. Apparently this will affect any driver installed.

    To find out if this is the case go FINDER > Go > Utilities > Disk Utilities (look bottom left FORMAT) I don't have any other solution to this. Spoke to Apple and they said if thats whats suggested by Lexmark then thats what needs to be done! Good Luck
  • iMacPodshuffle Level 2 Level 2 (305 points)
    Yeah... I'm not sure if I want to reformat my hard drive, lose all my data and see if this solves the problem. A much better solution would be if Lexmark updated their drivers, which are very, very out of date.
    Thanks a lot for posting your experiences here, hope we'll have our printers working soon.
  • iMacPodshuffle Level 2 Level 2 (305 points)
    I bought a new Canon pixma MP480, and it works great with snow leopard.
  • mconstance88 Level 1 Level 1 (0 points)
    Trying to configure My Dell Photo AIO Printer 966 as a printer on my MacBook Air.

    I've read on various db's that in order to get the mac to recognize the printer, you have to use Lexmark's LPD 9300 Series driver for Mac OS.

    When I install it, it goes ahead and recognizes the Dell printer using the Lexmark driver. However, when I try to do a test print on any program(apple script, text edit, even from the Internet) it immediately shuts the printer down after I try to print.

    Anyone have some suggestions on how to get this printer to work?

    Would hate to have to dump this printer and get a new one...it's an all-in-1.