5 Replies Latest reply: Sep 10, 2013 1:12 AM by mecium
ziehensack Level 1 Level 1 (0 points)
Well, as the subject says really. I imported a 2 disc CD set into iTunes. I have ticked 1 of 2 and 2 of 2. They have the same title and the same artist but it refuses to merge them and it's really irritating. Does anyone have any ideas?

MacBook Pro, Mac OS X (10.6.1)
  • Diane Wordsmith Level 5 Level 5 (5,995 points)
    Double check the album name. It's likely that one has Disc 1 at the end of the name and the other has Disc 2. If you want them to appear all together, the album name must be exactly the same. (If they don't say 1 and 2 in the name, check for errant spaces in the field for the name.)
  • SeaBeast Level 4 Level 4 (2,870 points)
    It is really your choice. I do prefer to have CD set seperated but you don't. That's why you can change the info as you want.

    iTunes seperate albums as soon as there is a difference in info fields. So, if you enter 1 of 2 and 2 of 2, the result will be to CD as defined. If you want the 2 CD to appears as one, simply remove 1 of 2 and 2 of 2 in the info field and make sure that the title of both album are the same.
  • ziehensack Level 1 Level 1 (0 points)
    I've sorted it now. Still don't know exactly what the problem was because I had marked all tracks together and entered artist and title and at first it made no difference. Okay now tho.

    As for entering 1 of 2 etc, that's worked with all my other CD sets so far. It was just this one that was giving me grief.

    Anyway, thanks for all the input. It was much appreciated.
  • turingtest2 Level 9 Level 9 (55,285 points)
    SeaBeast wrote:
    It is really your choice. I do prefer to have CD set seperated but you don't. That's why you can change the info as you want.

    iTunes seperate albums as soon as there is a difference in info fields. So, if you enter 1 of 2 and 2 of 2, the result will be to CD as defined. If you want the 2 CD to appears as one, simply remove 1 of 2 and 2 of 2 in the info field and make sure that the title of both album are the same.

    Eek! Unless you renumbered the tracks before doing so the album would play all out of order, track 1 from disc, track 1 from the other, then the tracks 2's etc. a la iTunes 9.0.0. For more on this and other split album issues see my previous post on Grouping Tracks Into Albums, in particular the topic One cover for multi-disc album.

    tt2
  • mecium Level 1 Level 1 (0 points)

    I had the same problem and it was really beginning to get under my skin after spending WAY too much time trying to get one 2 disc set to show under one title.  Then a moment ago another cd I was importing did the same thing.  But this time I was determined to find the answer and here it is:

    Right click the album art and go to "Get Info".

    Click on the tab for "Options".

    Make sure the option for "Part of a compilation" is "no".

    Do this for both discs and you will have one set together.  Both of the issues I had involved one of the discs being marked "yes" and as soon as I marked "no" they went together.  I hope this helps others with the same problem in the future.