Previous 1 2 Next 20 Replies Latest reply: Oct 27, 2009 6:41 AM by Oliver Lu
Oliver Lu Level 1 Level 1 (60 points)
I ran PreferentialTreatment because my Mac (10.6.1) has been getting sluggish no matter how many times I have DiskWarrior repair it (it always has incorrect critical values in the volume information), it (PT) stopped because there was some plist file that was "empty", but I can't find it.

I did "Find" in the Finder and set Kind to invisible, but nothing came up under that. I also did a Google search but nothing seemed to be spot-on, I remember doing something a while back (via the Terminal?) in the same situation but I don't remember what it was.

Thanks in advance.

P.S. The file's name is .a23t.mk4e.plist if it matters (The error message reads: "Conversion of string failed. The string is empty.)

Dual-Core 3.0 GHz Mac Pro, Mac OS X (10.6.1), 2GB RAM, 22" Samsung T220 LCD, 500GB OWC Mercury Elite-AL Pro
  • Carolyn Samit Level 10 Level 10 (98,750 points)
    HI,

    Go here for help to find .plist files.

    http://web.me.com/carolynssamit/CarolynsMac_Blog/Path_for_.plistfiles.html

    "has been getting sluggish"

    PT can help to a certain extent but perhaps you need to more trouble shooting.

    Boot from your install disk, run Disk Utility to check for errors on the disk and repair if necessary.

    Insert Installer disk and Restart, holding down the "C" key until grey Apple appears.
    Go to Installer menu and launch Disk Utility.
    Select your HDD (manufacturer ID) in the left panel.
    Select First Aid in the Main panel.
    *(Check S.M.A.R.T Status of HDD at the bottom of right panel. It should say: Verified)*
    Click Repair Disk on the bottom right.
    If DU reports disk does not need repairs quit DU and restart.
    If DU reports errors Repair again and again until DU reports disk is repaired.
    When you are finished with DU, from the Menu Bar, select Utilities/Startup Manager.
    Select your start up disk and click Restart

    While you have the Disk Utility window open, look at the bottom of the window. Where you see Capacity and Available. *Make sure there is always 10% to 15% free disk space*

    If you need to free up disk space go here.

    http://www.thexlab.com/faqs/freeingspace.html

    Go here for help Maintaining Mac OS X

    Also, according to VersionTracker PT is only compatible up to 10.5. You may want to delete the app to see if that is what's causing your Mac to slow down.

    ".a23t.mk4e.plist" <--- no idea what file that is or belongs to.

    You can <a href=http://support.apple.com/kb/HT2319> Force Background Maintenance  without using 3rd party software.






    Carolyn

    Message was edited by: Carolyn Samit
  • V.K. Level 9 Level 9 (56,130 points)
    you need to include system files in the search when searching for plists else they won't be found. to do that start a finder search by entering command+f in finder. click on "kind", scroll without releasing the mouse button and click on "other". in teh resulting popup select "system files" and include them in the search.

    that said, your problems could easily be with something other than plists, like caches or fonts. try running YASU to clear all caches.
    http://jimmitchelldesign.com/yasu/
  • Oliver Lu Level 1 Level 1 (60 points)
    Thanks for your response.

    I've already run Disk Utility and repaired the permissions (some of which couldn't be) and the disk itself (which was listed as fine).

    There is plenty of space on it.

    The problem predates PT (I only run it when I have a problem, and haven't run it in quite some time).

    The video doesn't help me find the file, it doesn't appear anywhere (that is why it is "invisible").

    I don't even think the plist is really the source of the problem but I would like to be able to rule it out (or just have things work better when it's gone); I can literally run DiskWarrior, fix "Critical values" in the Volume Information, reboot into the main disk, immediately restart back into the external disk, run DW, and find more Incorrect Critical values in the VI again.
  • Tony T1 Level 6 Level 6 (8,830 points)
    In Terminal: find / -name ".a23t.mk4e.plist" 2>/dev/null
  • r_bonnet Level 1 Level 1 (0 points)
    the following way can work:
    open "Find" and check the option "invisible file" ond you have the option "visible","unvisible",..
    Other way check in terminal "line command" the file with a dot at the beginning
    Example: to see the invisible file "file.plist" (in some directory) in terminal mode write "ls -a .ile.plis"
    (ls -a xxx) is the standard way to check the invisible file.plist
  • Oliver Lu Level 1 Level 1 (60 points)
    ok thanks for your replies but i actually i don't really want to look at the file i just want to delete it (i'm assuing it's worthless because the "string" is "empty").

    i don't want to experiment trying to do this in the Terminal because I've heard that's a bad place to do stuff unless you understand them.
  • K T Level 7 Level 7 (23,700 points)
    Use plutil to verify the syntax of .plist files.

    $ plutil ~/Library/Preferences/com.apple.iChat.plist
    /Users/saruman/Library/Preferences/com.apple.iChat.plist: OK

    $ plutil -s ~/Library/Preferences/*.plist
    Option '-s' reports only error conditions, and is silent on success.

    Are you comfortable enough with the Terminal to run this command?

    plutil -s ~/Library/Preferences/*.plist
  • Oliver Lu Level 1 Level 1 (60 points)
    I ran the second one (first line only) with the name of the file in place of the asterisk but received the following message:

    -bash: $: command not found
  • Tony T1 Level 6 Level 6 (8,830 points)
    huh?? you said "I remember doing something a while back (via the Terminal?) in the same situation but I don't remember what it was." and now you say "i don't want to experiment trying to do this in the Terminal because I've heard that's a bad place to do stuff unless you understand them."

    Anyway, just do a back-up (Time Machine, Clone, whatever) first and then use the find command in Terminal and you'll find what you're looking for.

    (btw, I purposely left out "-exec rm {} \;" from my suggestion)
  • K T Level 7 Level 7 (23,700 points)
    -bash: $: command not found


    The $ isn't used....that's a just an onscreen prompt. Don't worry - you'll get the hang of it

    Do it just like this and substitute the name of the plist, exactly...case and all just to be sure:

    plutil -s ~/Library/Preferences/*.plist
  • Oliver Lu Level 1 Level 1 (60 points)
    thanks i did it and got the message

    Conversion of string failed. The string is empty.

    (same message as in Preferential Treatment)

    but i'm still assuming this means file is junk and can be deleted-how do i do that?
    tia
  • K T Level 7 Level 7 (23,700 points)
    Do you know how to locate it using the Finder? You can search and set filters for visible and invisible, but it will only be on one of two possible locations...speak up if you need help with this.

    Drag it to the desktop and the next time the related application/process runs it will build a fresh one. Transparent and painless.

    Once you're satisfied, drag the borked file from the desktop to the trash and flush.
  • Oliver Lu Level 1 Level 1 (60 points)
    that's what i'm trying to do (find the file so i can trash)
  • K T Level 7 Level 7 (23,700 points)
    The two locations are:

    /Library/Preferences (when you look at the top level of the drive in the Finder)

    /((YourUserNameHome))/Library/Preferences (when you click on your user name/home directory/folder

    Or, again, just search in Finder cmd-f and then set change from 'Kind' to 'File Visibility' and set that to visible or invisible...type in the name and be sure to search your mac
Previous 1 2 Next