Previous 1 2 Next 15 Replies Latest reply: Jun 3, 2010 4:11 AM by 4miler
cohortq Level 1 (0 points)
Hello! I have tons of sub folders in my inbox, and I would like it to sort them all alphabetically. This was all fine, but recently the last 6 folders I added to the list were appended to the bottom of the list, and not sorted alphabetically with the rest of the sub folders. Is there anyway I can reapply the sort alphabetically feature to the folder list? I cannot seem to find it anywhere.

Troubleshooting steps I have taken:
1) Closed and restarted Mail App
2) Restarted Computer
3) Added another new folder and it is still appended to bottom of list even after all the reboots
4) Mail is confirmed to work

Any help would be great. Thanks!

iMac, Mac OS X (10.6.1)
  • The Mayor Level 1 (0 points)
    No clue how to fix it but I just started experiencing the same issue. I'm guessing it has something to do with the amount of sub folders. What OS are you running?
  • Matt Garr Level 1 (0 points)
    I am having the same problem. I have to move the folders manually.
  • HaraldE Level 1 (0 points)
    I experience the same problem since I switched from 10.5.8 to 10.6
  • JDMarshall Level 1 (0 points)
    I have the same problem with IMAP folders for my Gmail account. The folders appear in alpha order on my Gmail webmail page, but not in Apple Mail.
  • S Das Level 1 (10 points)
    Go to Preferences -> Accounts. Select the IMAP-based account, then click on the "Advanced" tab and disable the account. Save the settings and close Preferences. Then go back and re-enable the account. The IMAP folders will now appear in correct alphabetical order.
  • Kenji Kono Level 1 (0 points)

    I'm not sure, but I suspect the new Snow Leopard feature ...
    ... that lets you move folders around manually might be what's causing the weird behavior.

    In Leopard, you could move a folder inside another folder but, otherwise, they would always stay in alphabetical order, I think.

    Anyways, in Snow Leopard (and Leopard for that matter), there's an invisible file around ~/Library/Mail/<name of your email account>/.mboxCache.plist It seems to keep a list of the mboxes in that folder/account. In Snow Leopard, the first time you manually move an mbox out of alphabetical order, a new key called MailboxDisplayOrder seems to get created in that plist for all the existing "non-special" (i.e. not INBOX, Sent, Drafts, etc.) mboxes in that folder. Once that key exists, it seems like new folders get appended to the end of the order.

    I don't know the right way to fix the problem though. I'm really just posting my observations, based on what I'm seeing on my computer. I'd be very careful about manually messing with invisible files in your mail, especially if you don't have a good backup. (No idea if you can restore an invisible file with Time Machine.) A lot of this is guesswork. But I thought maybe it'd help someone.

  • NSB_1717 Level 1 (0 points)
    I've been having the same problem since I upgraded to Snow Leopard.

    S DAS: Thanks for offering a solution; unfortunately it didn't work for me.

    I have a TON of folders for all my clients, and projects. This is quickly turning into a serious headache. I'm hoping Apple will get it together and fix this. I can't imagine that alphabetical sorting is all that challenging in this day and age.
  • liontaris Level 1 (5 points)
    I have tried the solution suggested by S Das and it has worked for me also. After disabling the account I completely quited, then re-launched it and enabled the account. After a short delay, the IMAP folders appeared in alphabetical order. Thanks.
  • davidwittig Level 1 (5 points)
    You have to quit and restart in order for this to work.

    I really hope Apple fixes this soon.
  • MDGP Level 1 (0 points)
    I had the same problem and S DAS` suggestion worked for me too.
    I wonder if I create a new folders it will happen again...
  • 3v3n1ng5t4r Level 1 (0 points)
    I think it's a new feature in the newer versions of Apple Mail, not sure when it got added but I'm running 4.2 (1077). The way I understand it is that in each mail account folder (/User/<username>/Library/Mail/<mailbox-name> there is a file called .mboxCache.plist that contains a key called "MailboxDisplayIndex" which is used to index the display order for the folders.

    What I did to fix the problem was to quit Mail, rename the file to something else (like .mboxCache.plist.backup) and then restart Mail. This restored all my folders to the default alphabetical sequence. If you ever drag a folder to rearrange the sequence, then you can reset it by just doing the same steps above again.

  • BTeague Level 1 (0 points)
    I have the same problem but my mail accounts are pop so if I delete it I lose the mail. All they need to add is a sort by folder, I can sort by just about everything else. AGH!

  • cohortq Level 1 (0 points)
    Sometimes I am unable to find and delete the ~/Library/Mail/<name of your email account>/.mboxCache.plist file. that would be the normal way I resolve this issue, but S Das disable and re-enable trick through mail preferences works every time. This problem WILL resurface in a month or two, but at least there are 2 possible ways to resolve it. My users are using with Exchange 2007 server.
  • bozinsky Level 1 (0 points)
    Thanks, S Das. Nice workaround for the issue, works all the time for me.
Previous 1 2 Next