11 Replies Latest reply: Nov 11, 2009 9:22 AM by batucaves
Harland Level 1 Level 1 (0 points)
I have been syncing my 3G with an HP Windows XP. I just bought a 13 inch MacBook Pro. How do I sync with both computers and maintain all of my calendars, contacts and apps with Outlook on Windows and iCal on the Mac? Can this be done?

MacBookPro 13 inch, Mac OS X (10.6.1)
  • wjosten Level 10 Level 10 (93,705 points)
    The iphone only supports syncing with one computer at a time. However you can sync just your contacts and calendar with two computers, but not your music or purchased apps. You need to decide what computer you want to "sync" with then only sync your calendar and contacts with the other. You want to make sure that on the second computer that you select manually manage music, make sure that nothing is checked, same thing with your apps, nothing in itunes is checked. Before you sync your contacts or calendar with the second computer, make sure you have one contact and one appointment in whatever supported program you use for those purposes. Make sure you select "merge" at the prompts. Make sure you go to iTunes preferences and under the Devices tab, deselect automatically sync when an iPhone or iPod is connected.
    Same thing with photos, they can be transferred to an iPhone from a single computer only
  • Harland Level 1 Level 1 (0 points)
    Thanks, that was very helpful and very detailed. Just what I was looking for.
  • batucaves Level 1 Level 1 (0 points)
    I must be doing something wrong but I can't get my work calendar (iCal) to sync. I want to sync everything to my home iMac but calendars with my work iMac. I've done everything mentioned above i.e. select manually manage music, uncheck all the rest except calendars, deselected the automatically sync option in preferences, when I replug the iPhone at work, it reverts to my home settings and will delete all Apps, music, videos and ringtones if I want to update the calendar.

    Maybe I just have to get MobileMe. Sigh..
  • wjosten Level 10 Level 10 (93,705 points)
    Since you want to sync contacts and calendar events only with the Mac at work, this should be the only thing selected under the Info tab for your iPhone sync preferences with iTunes on your Mac at work. Do not select sync music under the Music tab for your iPhone sync preferences with iTunes on the Mac at work. Is that what you did?
  • batucaves Level 1 Level 1 (0 points)
    The last time round I selected only Calendars, and the "manually manage music & videos" and unchecked everything else, which left my music, videos, podcasts, iTunesU and photos intact, but deleted my Apps (the ones purchased on my home iMac) and my calendar updated fine. I guess the problem is that my Apps keep getting deleted at every sync cycle at work.
  • wjosten Level 10 Level 10 (93,705 points)
    You can stop that by transferring purchases to the work computer. On your work computer, go up to "Store", "Authorize this computer". Next time you connect your phone, do not sync. Go up to "File", "Transfer purchases made on this ipod to this computer". All of your purchased music & apps will then be transferred to your work computer.
    Also, on your work computer make sure that there is NOT a check in the box marked "Sync applications" on the apps tab if you don't want to sync apps.
  • batucaves Level 1 Level 1 (0 points)
    Thanks for the help, the iCal/Address Book sync is OK, but when I uncheck "Sync applications" at work, it just reverts back every time. I guess there's enough space in my work iMac for my 32GB iPhone.
  • Allan Sampson Level 10 Level 10 (123,370 points)
    You don't have to select manually manage music and videos with iTunes on the 2nd computer - not sure where this came from.

    If you are syncing music/videos and transferring apps from your Mac at home, do not select anything under any of the tabs for your iPhone sync preferences with your computer at work except for selecting sync contacts and calendars under the Info tab.

    Selecting manually manage music and videos for your iTunes sync preferences with your computer at work was not needed and is what caused the problem.
  • batucaves Level 1 Level 1 (0 points)
    Thanks for the suggestion. So, I've deselected "manually.......videos" on both iMacs. I've just realised that if I connect my iPhone to my MBP, I can do what I've wanted to do all along i.e. to just sync my add bk and iCal. It's only my work iMac that seems to "remember" the previous settings and forces me to decide between syncing the applications, music and videos or remove everything. How can I reset this?
  • wjosten Level 10 Level 10 (93,705 points)
    Try this:

    Launch isync and reset your sync history. Reboot, see if that fixes the problem.
  • batucaves Level 1 Level 1 (0 points)
    Thanks but that didn't work.