Previous 1 2 3 Next 30 Replies Latest reply: Jan 19, 2010 10:24 PM by KOENIG Yvan
Michael Cucka Level 1 Level 1 (5 points)
This is frustrating...

I have an iMac that came with a trial version of iWork '09. Once it expired, I purchased a retail box version. According to Apple, the full version should install over the trial - no serial number needed.

Unfortunately, when launching any of the programs, they ask me for a serial number - which, of course, I don't have since the retail version does not include any s/n.

I've read thru multiple posts on this forum about others who have had the same issue - and the solution (but only for some) seems to be deleting the remnants of any prior iWork from the mac and installing fresh from the disc. This has not worked for me.

I've deleted everything I can find in the main Library, user Library folders - including applications, .plist files, application support, templates, packages, etc. Restarting, repairing permissions, etc still with failure to install from disc - asking for a serial number.

So, I tried installing the retail version on my laptop, which also has a trial version of iWork '09 - it installed fine. Encouraged, I then reinstalled the iWork '09 trial back onto my iMac - then installed the retail disc - still with the s/n problem.

Any other suggestions? Running OS 10.5.8

Thanks -

2X3GHz Quad-Core Intel Xeon, Mac OS X (10.6.1)
  • R_Dare Level 1 Level 1 (0 points)
    I had this same problem.

    I got it to install by erasing the previous iWorks '09 folder form the Applications Folder AND the iWorks '09 folder that's located in Library > Application Support.

    This did the job for me.
  • Michael Cucka Level 1 Level 1 (5 points)
    Thanks -

    Unfortunately, I've tried this and still have no luck...
  • fruhulda Level 6 Level 6 (15,120 points)
    Why do you install both the retail version and the trial after you had trash the trial?

    This problem has been discuss several times with no real resolution. As you have bought the iWork you are entitled to Applecare help. Call them. When the the problem is solved do tell us how you solved it.
  • Michael Cucka Level 1 Level 1 (5 points)
    Just trying combinations when the installation wouldn't work the way it should.

    Many posts here have been successful, but some have not - curious that an installation should be so difficult...
  • fruhulda Level 6 Level 6 (15,120 points)
    I did install the CD with iWork over the trail and didn't have any problem as I can recall. Maybe I first deleted the iWork apps using AppZapper because it does delete all plist files.It is only 2 month ago but I can't remember the details (age creeping up on me!) as I didn't have any issue with it.
  • Level 8 Level 8 (41,790 points)
    Delete two files:


    Before installing from the in the box DVD.

    Yvan KOENIG (VALLAURIS, France) jeudi 22 octobre 2009 17:29:28
  • Peggy Level 8 Level 8 (38,595 points)
    Back in January I installed the retail family pack DVD over the trial on my MacBook Pro without problems. It seems something has changed recently.

  • Xeri Level 1 Level 1 (25 points)
    I had this same problem just today. I installed the trial in a new Snow Leopard installation, then realized that I needed to enter the key again. After finding my media and discovering that there -was- no key, I tried to install over it, which persisted in asking me for a serial.

    In the end, the things I scrubbed off the system to get this to work again was a composite of the suggestions on this thread:

    /Applications/iWork '09
    /Library/Application Support/iWork '09
  • Michael Cucka Level 1 Level 1 (5 points)
    Thanks -

    I tried deleting those files already, Koenig - as well as many others, with no success.
  • jonesdh Level 1 Level 1 (0 points)
    So, same problem. I spoke to Apple Care... First guy told me to wipe and reinstall snow leopard. I disagreed. He hung-up. Nice to know there are bad apples, even at apple!

    Anyway spoke to a lovely lady who helped me we removed the application from applications, /Applications/iWork '09 and from /Library/Application Support/iWork '09. We then removed the icons from the dock and...

    *most importantly emptied the trash.*

    I then did another install, whilst believing that she was wrong and I would have the same problem but no she was right. If you think when you delete an app but click on the link in the doc the OS points out that the app is in the trash. So to full remove the app (in addition to the previous comments) you must remove the dock icons and the empty the trash.

    I thought it was going to be successful when during the install the dock restarted, and the new iWork icons appeared. I told the support agent I would post this solution!

    Hope this helps, and some-one can solve their problem too!
  • fruhulda Level 6 Level 6 (15,120 points)
    I had a peak in HD > Library > Application Support > iwork 09. In the Frameworks folder there is a folder called SFLicense.framework!!!!! That must be the one giving problems.
  • jonesdh Level 1 Level 1 (0 points)
    Did that solve it for you?
  • fruhulda Level 6 Level 6 (15,120 points)
    I never had the problem but it has been a problem to help others.
  • Ivan Prince Level 1 Level 1 (0 points)
    Thanks for all the info on this discussion .
    It worked for me , although it should be stated somewhere to remove any iworks trial software before
    installing retail pack

Previous 1 2 3 Next