4 Replies Latest reply: Oct 30, 2009 8:23 AM by Pondini
jia10 Level 4 Level 4 (1,715 points)
Hi Folks,

I have an iMac, 3.06GHz Intel Core 2 Duo, Leopard 10.5.8 and 4GB of SDRAM on board.
I would have thought that 4GB of RAM would be sufficient to run most processes; however, I have recently installed Capture One (a photo raw file editing program) and am finding that it eats into the RAM very very quickly to the point at which it crashes. What seems confusing is that this seems to happen when my activity monitor still shows that I have about 1GB of inactive memory available. My question therefore is why is this memory not being used when it is required? Is it reserved only for some applications?

Many thanks for all offers of assistance.

Intel Core Duo 3.06GHz iMac, Mac OS X (10.5.8)
  • J D McIninch Level 5 Level 5 (4,060 points)
    The reason Activity Monitor tell you that is because you aren't running out of memory. If an application were to consume ever more memory, it would eventually start to swap memory from the hard disk, which would slow your computer down significantly -- but it wouldn't crash. Applications can gobble up a lot more memory than your installed RAM and still not crash.

    If the application is crashing, then there's an internal error in it somewhere. If the application is telling you that it's for lack of memory, that's either inaccurate (e.g., there was another cause) or inarticulate (it was specifically attempting to do something with memory that failed and presumed it meant out of memory).
  • Pondini Level 8 Level 8 (38,720 points)
    As J.D. says, there's another cause for the crash.

    You should be able to find out why (or at least get a clue) from the Crash log.

    Use the Console app (in your Applications/Utilities folder).

    When it starts, click +Show Log List+ in the toolbar, then navigate in the sidebar that opens up to the CrashReporter folders (there may be 2 or more of them). Inside each folder should be separate logs for each crash, named with the name of the app that crashed plus the date & time.

    Most of what you see there will be gibberish; so copy part of it and post here.

    Please do NOT copy the whole thing. A few lines down should be +*Crashed Thread:*+ followed by a number. Below that will be information for each thread, starting with zero. Copy from the top of the log to the bottom of the section for the thread number mentioned above.

    Also, navigate in the Console sidebar to your system.log. Select it and navigate to the date/time of the crash. There should be a clear message about the app crashing. Copy a page or so from that message upwards, and post it, too.

    One or both should contain clues that somebody here may recognize.
  • jia10 Level 4 Level 4 (1,715 points)
    Thanks JD and Pondini. As requested, here is the relevant information from the CrashReporter:

    Process: Capture One [1022]
    Path: /Applications/Capture One.app/Contents/MacOS/Capture One
    Identifier: com.phaseone.captureone
    Version: Capture One 4.8.3 (4.8.3.31298)
    Code Type: X86 (Native)
    Parent Process: launchd [94]

    Date/Time: 2009-10-27 09:02:03.835 +0000
    OS Version: Mac OS X 10.5.8 (9L31a)
    Report Version: 6
    Anonymous UUID: 53BE94E3-5960-4C6C-9A48-DF6C41BB0378

    Exception Type: EXC_CRASH (SIGABRT)
    Exception Codes: 0x0000000000000000, 0x0000000000000000
    Crashed Thread: 0

    Thread 0 Crashed:
    0 libSystem.B.dylib 0x929b5e42 __kill + 10
    1 libSystem.B.dylib 0x92a2823a raise + 26
    2 libSystem.B.dylib 0x92a34622 __abort + 97
    3 libSystem.B.dylib 0x92a3468a cproc_forkchild + 0
    4 com.phaseone.captureone 0x001a6f4b 0x1000 + 1728331
    5 libSystem.B.dylib 0x929b42bb _sigtramp + 43
    6 ??? 0xffffffff 0 + 4294967295
    7 libSystem.B.dylib 0x92a2823a raise + 26
    8 libSystem.B.dylib 0x92a34679 abort + 73
    9 com.phaseone.CaptureCore 0x00361037 P1::Universal::LogMsgAssertFailed(wchart const*, P1::Universal::LogMsgLineInfo const&) + 219
    10 com.phaseone.CaptureCore 0x00367108 P1::Platform::WaitObject::~WaitObject() + 316
    11 com.phaseone.CaptureCore 0x003676ad P1::Platform::EventConditionMac::~EventConditionMac() + 49
    12 com.phaseone.CaptureCore 0x0036c2c1 P1::Platform::ThreadMac::~ThreadMac() + 61
    13 com.phaseone.CaptureCore 0x003712ba P1::CaptureCore::Internal::BaseEventSource::EventDispatcher::~EventDispatcher() + 156
    14 com.phaseone.CaptureCore 0x00377d8e P1::CaptureCore::Internal::BaseRootObject::Release() const + 136
    15 com.phaseone.CaptureCore 0x00373fe7 P1::CaptureCore::Internal::DefaultReferenceCounter<P1::CaptureCore::Internal::B aseEventSource::EventDispatcher>::Release(P1::CaptureCore::Internal::BaseEventSo urce::EventDispatcher*) + 17
    16 com.phaseone.CaptureCore 0x00374038 P1::CaptureCore::Internal::ObjPtr<P1::CaptureCore::Internal::BaseEventSource::E ventDispatcher, P1::CaptureCore::Internal::DefaultReferenceCounter<P1::CaptureCore::Internal::B aseEventSource::EventDispatcher> >::Release() + 76
    17 com.phaseone.CaptureCore 0x00374056 P1::CaptureCore::Internal::ObjPtr<P1::CaptureCore::Internal::BaseEventSource::E ventDispatcher, P1::CaptureCore::Internal::DefaultReferenceCounter<P1::CaptureCore::Internal::B aseEventSource::EventDispatcher> >::~ObjPtr() + 18
    18 com.phaseone.CaptureCore 0x0037276f P1::CaptureCore::Internal::BaseEventSource::RemoveReceiver(unsigned long, P1::CaptureCore::Internal::ObjPtr<P1::CaptureCore::Internal::IEventReceiver, P1::CaptureCore::Internal::DefaultReferenceCounter<P1::CaptureCore::Internal::I EventReceiver> >, void*) + 599
    19 com.phaseone.CaptureCore 0x00346d49 -[P1CaptureCoreRootObject(P1CaptureCoreEventSource) removeReceiver:selector:eventID:object:] + 129
    20 com.phaseone.CaptureCore 0x0034b423 -[P1CaptureCore_CaptureObject removeReceiver:selector:eventID:object:] + 77
    21 com.phaseone.CaptureCore 0x0034b8ad -[P1CaptureCore_CaptureProvider removeReceivers] + 65
    22 com.phaseone.CaptureCore 0x0033e3f4 -[P1CaptureCore_RootObject(Private) dealloc] + 82
    23 com.phaseone.CaptureCore 0x0033e52c -[P1CaptureCore_RootObject(Private) release] + 218
    24 com.apple.Foundation 0x92fe444f NSPopAutoreleasePool + 431
    25 com.apple.Foundation 0x92fe842a nsnotecallback + 106
    26 com.apple.CoreFoundation 0x9736e47a __CFXNotificationPost + 362
    27 com.apple.CoreFoundation 0x9736e753 _CFXNotificationPostNotification + 179
    28 com.apple.Foundation 0x92fe5680 -[NSNotificationCenter postNotificationName:object:userInfo:] + 128
    29 com.apple.Foundation 0x92feeed8 -[NSNotificationCenter postNotificationName:object:] + 56
    30 com.apple.AppKit 0x92339188 -[NSApplication terminate:] + 353
    31 com.phaseone.captureone 0x000cf365 0x1000 + 844645
    32 com.phaseone.captureone 0x0022926c 0x1000 + 2261612
    33 com.apple.Foundation 0x92fe99ac __NSThreadPerformPerform + 476
    34 com.apple.CoreFoundation 0x9738d3c5 CFRunLoopRunSpecific + 3141
    35 com.apple.CoreFoundation 0x9738daa8 CFRunLoopRunInMode + 88
    36 com.apple.AppKit 0x923c504c _NSUnhighlightCarbonMenu + 127
    37 com.apple.AppKit 0x92221e8e _NSHandleCarbonMenuEvent + 283
    38 com.apple.AppKit 0x92188bc2 _DPSNextEvent + 1918
    39 com.apple.AppKit 0x92187f88 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 128
    40 com.apple.AppKit 0x92180f9f -[NSApplication run] + 795
    41 com.apple.AppKit 0x9214e1d8 NSApplicationMain + 574
    42 com.phaseone.captureone 0x00002793 0x1000 + 6035
    43 com.phaseone.captureone 0x000026c1 0x1000 + 5825

    Very much hope this makes some sense to someone out there!

    Many thanks for all your help.

    Jose
  • Pondini Level 8 Level 8 (38,720 points)
    jia10 wrote:
    . . .
    Exception Type: EXC_CRASH (SIGABRT)


    As I understand it, SIGABRT means the application detected some sort of problem and SIGnalled itself to ABoRT.

    This does not appear to have anything to do with insufficient memory.
    Usually, if an app can't get enough memory, either OSX will page memory in and out to disk; or the app will send a message about not being able to get enough.

    I don't know enough about this stuff to tell just what it was doing, or tried to do, much less whether it has a memory leak, but it sure seems to be something wrong with the application itself.

    There may be another clue in the system log. Navigate in the Console sidebar to your system.log. Select it and navigate to the date/time of the crash. There should be a clear message about the app crashing. Copy a page or so from that message upwards, and post it, too.

    If you scroll all the way up and find that the log starts after this crash, go back to the sidebar and navigate towards the bottom to the previous logs.
    They're named +*system.log.0.bz2, system.log.1.bz2,+* etc.

    But I think you're going to have to contact the folks at PhaseOne sooner or later.