5 Replies Latest reply: Oct 23, 2009 10:03 PM by iphone3ger
stromboy84 Level 1 Level 1 (0 points)
Okay, I'm fairly new to Macs, so go easy on me. I've been using my new Macbook for a few months now, always with my airport express, with no problems. I've been having some issues with my internet provider, so I wanted to bypass my airport and plug my ethernet straight into my laptop to see how it did. But when it's plugged in, I don't get any internet. Here's what my ethernet settings say:

Ethernet : Self-Assigned IP (with the yellow dot next to it)
Status:connected
Ethernet has a self-assigned IP address and will not be able to connect to the Internet.

Configure IPv4: Using DHCP

It looks like it has to do with the self-assigned IP address, so how do I change that?

Thanks in advance!

Macbook, Mac OS X (10.6)
  • iphone3ger Level 3 Level 3 (630 points)
    a self assigned ip address normally indicates its not getting an ip assigned from your lan router.

    when you look at your lan router do you ever see the link light come on?

    i would try another ethernet cable just to eliminate the cable as the problem.
  • stromboy84 Level 1 Level 1 (0 points)
    I have an apple airport express, that is plugged into a modem provided by comcast. I've just been unplugging the ethernet cable from the airport and plugging it into my macbook. The cable works fine when it's used with the airport, so I don't think that's the problem.

    My modem doesn't have a light labeled "link", but there is one for "PC". The PC light blinks when it is plugged into the airport, is off when it's unplugged, and blinks again when plugged into my macbook.

    So you think this is a problem with my modem? With every other laptop I've owned, I just plugged the ethernet cable in, waited a few seconds, then started browsing. Are there no settings on the laptop to get an IP assigned?

    Thanks for you help,and sorry if these seems like a dumb issue.
  • iyacyas Level 4 Level 4 (1,535 points)
    Doubtful that it is the modem.

    Have you tried to "Renew DHCP Lease"?

    Open Sys prefs/Network select eh Ethernet the advanced once in the advanced menu make sure you are under the TCP/IP tab and press the "Renew DHCP Lease" button.

    If this doesn't work then still under advanced select eh Ethernet tab then make sure that configure is set to Automatically.

    If still a no go try resetting the modem by unplugging it for about 10-seconds then perform the Release again.

    I will have to ask though what are the problems that you're experiencing with your ISP or network in the first place?
  • stromboy84 Level 1 Level 1 (0 points)
    Thanks. I'm not home right now, but I'll give that a shot later.

    About 3 weeks ago, my internet connection slowed down dramatically. Normally I get about 10mbps, but it dropped to under 1mbps. And it dropped the connection entirely every now and then. A tech looked at it today and replaced the modem, which seems to have fixed that problem. But even with the new modem, I still can't connect using ethernet, only through wifi.
  • iphone3ger Level 3 Level 3 (630 points)
    ahhh ok... if the release and renew suggestions above don't work try powering the cable modem down and then backup after you plug it into the macbook. cable modems tend to lock to the MAC address of whatever device is connected to them at powerup. if that works don't forget to power the cable modem down and backup when you reconnect it to the airport express.

    i don't think its a problem with your modem persay... i think its differences in the way macos asks for an ip from the modem... are the other laptops you are refering to running another operating system?

    if you really want to use wired consider getting an airport extreme base station (or even a cheapo linksys etc) ... they have the wifi and LAN ethernet ports... that way you can connect wired and wireless through the same device (and at the same time)!

    be well