5 Replies Latest reply: Feb 9, 2010 7:15 PM by pgonzalez
prairie-guy Level 1 Level 1 (0 points)
I am migrating my personal mail server from Tiger Server to Snow Leopard Server.

I have had Postfix on the Tiger Server working for years. I am having trouble configuring Snow Leopard to do the same. My set up for SMTP is to relay email from my respective Postfix server to my ISP, mail.speakeasy.net, and then authenticate with my speakeasy name/password. As I use SSL, I come in on port 995.


From Postfix's perspective, this involves configuring SASL.
Here are the relevant SASL configuration lines from postfix.conf

smtpsasl_authenable = yes

smtpsasl_passwordmaps = hash:/etc/postfix/sasl/passwd

smtpdclientrestrictions = permit_mynetworks permitsaslauthenticated rejectrblclient zen.spamhaus.org rejectrblclient bl.spamcop.net permit

smtpdrecipientrestrictions = permitsaslauthenticated permit_mynetworks rejectunauthdestination checkpolicyservice unix:private/policy permit

smtpdsasl_authenable = yes


When I attempt to relay through mail.speakeasy.net, here are the log file entries in my Snow Leopard SMTP Log files:

Oct 22 17:26:38 tin postfix/smtp[98906]: warning: SASL authentication failure: No worthy mechs found

Oct 22 17:26:38 tin postfix/smtp[98906]: D6EC5500F2: to=<cdaniels@speakeasy.net>, relay=mail.speakeasy.net[69.12.123.12]:25, delay=0.29, delays=0/0/0.28/0, dsn=4.7.0, status=deferred (SASL authentication failed; cannot authenticate to server mail.speakeasy.net[69.12.123.12]: no mechanism available)


Any advice would be appreciated.

Thanks,

MacMine, Mac OS X (10.6.1), Snow Leopard Server
  • Kevin.McK Level 1 Level 1 (0 points)
    I added the following line to the main.cf file:

    smtpsasl_securityoptions =

    restarted postfix and I was able to relay mail via my ISP.
  • trillian_42 Level 1 Level 1 (0 points)
    combining prarie-guy and kevin mck posts, heres what worked on my snow leopard 10.6.2 box:

    error was:

    Jan 6 17:05:10 cavell postfix/smtp[36921]: warning: SASL authentication failure: No worthy mechs found
    Jan 6 17:05:10 cavell postfix/smtp[36921]: 08A7856920: to=<foo@bar.com>, relay=mail.telushosting.com[216.251.32.97]:25, delay=1.2, delays=0/0.01/1.2/0, dsn=4.7.0, status=deferred (SASL authentication failed; cannot authenticate to server mail.telushosting.com[216.251.32.97]: no mechanism available)

    to fix:

    stop mail using server admin or cmd line
    in terminal window, sudo -s -H
    cd /etc/postfix
    cp -p main.cf main.cf.orig
    vi main.cf

    check the following lines are set up as follows:

    smtpsasl_authenable = yes
    smtpsasl_securityoptions =
    smtpsasl_passwordmaps = hash:/etc/postfix/sasl/passwd

    smtpdclientrestrictions = permit_mynetworks permitsaslauthenticated permit
    smtpdrecipientrestrictions = permitsaslauthenticated permit_mynetworks rejectunauthdestination checkpolicyservice unix:private/policy permit
    smtpdsasl_authenable = yes

    restart mail.
  • pgonzalez Level 1 Level 1 (0 points)
    this post was the answer to my month long aggravation with mail...THANKS TO ALL WHO CHIMED IN!

    Apple & my DNS name provider only provided limited help as (understandably) one party won't help in the others camp.. *I can't believe I needed to perform these steps to make mail work???*

    Well now that I've performed these instructions, mail works but have I compromised mail junk filtering?

    This email address is new and would receive junk email on a previous mail server, but now I'm getting junk everyday. I'd like increase my junk mail filtering settings but will that lose all the settings I've made to the postfix config file and block all incoming & outgoing mail again?

    Thanks!
  • Kostas B Level 1 Level 1 (90 points)
    I just added the +smtpsasl_securityoptions =+ line.
    No problem with the junk filtering, though.

    Thanks

    Kostas
  • pgonzalez Level 1 Level 1 (0 points)
    Well just as I suspected I adjusted my junk mail filter settings and I no longer can receive emails.

    I put a check the 'enable junk mail filtering' which had a dash in the box after the changes to the postfix main.cf file as advised in this post.

    and

    I moved the minimum junk score slider away from 'cautious' to 'moderate'

    restarted mail and nada...no incoming mail

    actually one message came in an hour after being sent.


    anyone?

    Message was edited by: pgonzalez